[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

Hi Sam. Tried to update and left the Vero running. When I came back I got the message unable to connect to update server. After clicking OK, I got a prompt asking me if I want to exit to install update. I clicked Yes and it’s been a slow update. Is it normal to have a timer on screen? Pls see photo uploaded.

It spikes up to 2 hours and then goes down to 30 mins. And seems to be very slow. At 2% so far

All good. Updated properly. Thanks.

Now that is easy, thanks! Please consider updating your starting post for the updateprocess.

Another question: how can I show the MaxFALL and MaxCLL values from Vero? Longpressing the i-button on the remote does not give me the information.

We will not be doing so for all the reasons sam mentioned a few posts before…

You can check that via the system journal

Kernel has been updated again with more playback fixes.

1 Like

I installed an HDFury Integral2 and it shows that there is no metadata sent. Both MaxFALL and MaxCLL are on 0.

Any idea about this one, guys?

Could I ask a question about the 4.9 kernel, when it’s out, will it support the Dual-hd tuner stick as referenced in this post? Hauppauge DualHD not found on Vero4K - #49 by KickerTom

AFAIK it should, I sent the patches to Sam for integration, but I haven’t had the time to test the 4.9 build yet, sorry.

1 Like

Please post some logs.


I haven’t updated in a while. I’m still on Kodi 17.6. I’ve been maintaining a separate device for 3D movies for quite some time. From the sounds of things it sounds like 3D is basically there. My question is if I update via the hotfix posted a day ago will my settings still be saved? Will the fstab setup still be there and kodi settings the same? Also is there any issue going from 17.6 to 18.6? If I upodate I plan to stick with this one for a while as it sounds pretty stable. Any issues with my approach?

Hi @sam_nazarko. I ran into 2 bugs.

  1. On reboot/restart, the USB drive wasn’t mounted. This is not consistent. Sometimes it would mount, sometimes it won’t. I caught it and included it in the log below.

  2. Played an MKV and it was stuck at buffering. See attached photo.

    Video was 30+ seconds short, it played indefinitely until I stopped it at 40+ seconds.
    Log - https://paste.osmc.tv/uzikarenod
    Video - https://drive.google.com/file/d/1tAzmdnkrv5zIB5adfAe2EmQ9G2gyyO8K/view?usp=sharing
    Media info

Unique ID : 38015792481946129765145421216624949069 (0x1C9993478520FBE08867629CB630374D)
Complete name : AGT.mkv
Format : Matroska
Format version : Version 4
File size : 10.4 MiB
Duration : 33 s 634 ms
Overall bit rate : 2 596 kb/s
Encoded date : UTC 2020-04-17 15:18:14
Writing application : mkvmerge v45.0.0 (‘Heaven in Pennies’) 64-bit
Writing library : libebml v1.3.10 + libmatroska v1.5.2

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.1
Format settings : CABAC / 5 Ref Frames
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Duration : 32 s 32 ms
Bit rate : 2 466 kb/s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 29.970 (30000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.089
Stream size : 9.42 MiB (90%)
Default : Yes
Forced : No

ID : 2
Format : E-AC-3
Format/Info : Enhanced AC-3
Commercial name : Dolby Digital Plus
Codec ID : A_EAC3
Duration : 32 s 32 ms
Bit rate mode : Constant
Bit rate : 256 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Compression mode : Lossy
Stream size : 1 001 KiB (9%)
Service kind : Complete Main
Default : Yes
Forced : No

ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Duration : 30 s 197 ms
Bit rate : 105 b/s
Count of elements : 15
Stream size : 397 Bytes (0%)
Language : English
Default : No
Forced : No

Back up everything first
Update to OSMC stable
Then add this 4.9 repo.

Thanks for the reply!

Your log shows that your two drives mounted without issue under /media.
The file you are trying to play seems corrupted. I suggest remuxing it.

  1. Internally mounted but the HDD didn’t show under videos -> files. Sometimes this also happens after playing a video for almost 2 hours.
  2. I’ll try remixing again. But I did try it on vlc and it played.

Sounds like a potential power issue.

I tried playing the exact same file on a Vero using the stable March release with 3.14 kernel. Played without issue. Here’s the log.