[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

I was talking about Jellyfish, but will do.

:man_facepalming:

Sorry. :slightly_smiling_face: Yes, I’m using jellyfish-300-mbps-4k-uhd-hevc-10bit.mkv

Both that and Billy Lynn are in local flash storage.

new to this. tried to set this up to play 3d bluray ISOs. this is the only reason i bought this sice nvidia is not supporting 3d anymore. just got this like 3 hrs ago. followed the instructions. signed in with a keyboard locally with username password osmc. think i got to the part successfully where you have to edit /ect/apt/sources.list. but it doesnt show you how to edit it. tried to type it in and press enter and it says access denied. at the top it says den3dkodibox 3.14.29-157-osmc. i thought after manual update that its suppose to be 4.9. i’m confused. is their a step by step tutorial for lay persons that can get them from start to finish and the enproduct is being able to play 3d bluray iso. skype, paid service hotline. please not 1 step by 1 step everyday on aaaa blog. thanks for any hepl with this non plugnpllay machine

Welcome to the forums.

How did you try and edit the file?

As soon as this testing is stable, we will make it part of a standard update that you can install when prompting without any command line access.

We have introduced a slight barrier to entry here intentionally so that we get testers that can appreciate that this is experimental. There are still some bits that are rough around the edges.

We can produce a hotfix code for you (which allows you to just enter a few letters under My OSMC -> Updates -> Manual Controls -> Apply Hotfix) and that will be it, but you will need to understand that 3D and this video stack are still experimental and likely won’t be stable for a couple of months yet.

Sam

i just typed it in. there aren’t any instructions on how to edit it. i bought this nd to reading for weeks on the progress of this. i have read damn near everything about vero 4k+ and how only little cavits are a problem now that’s why i got it but i cant even figure out how update it properly. i’ve followed the instructions it the tutorials but it wasnt enough to get me up to par. another thing is it says change password with osmc passw. but doesnt tell you how. if you can elp me please i need it. thanks

I will produce a hotfix code for you, as well as instructions shortly.

You would type ‘passwd osmc’ via the terminal and you’ll be prompted to change the password.

If you are not port-forwarding on your router, your risk is low. You could disable SSH via Services under My OSMC, but this isn’t recommended in case you need to login to the device and Kodi isn’t responding.

i have ssh enabled
i thought 4.9 was a stable build already but the new kodi wasn’t. sorry very new to this. i thought everything had moved pass 3.14 already.

i changed the password. thanks

Not to be rude, but the title of this post does clearly indicates that the 4.9 kernel is under testing.

Just from a personal experience before you commit to updating to the beta build, whilst my testing with the Vero 4K+ has been generally behaving well with the 4.9 kernel, it has not been faultless during daily use - Just something to keep in mind before committing if you are expecting a faultless experience.

Regardless, happy to point you in the right direction if you require any assistance with getting it up and running. :slight_smile:

i see that. but i’m new to this and i remember somewhere it said 4.9 is out. i guess i assumed that meant it was official. was in the middle of a forum. I haven’t dealt with any lunix or osmc platform until today. i was so frustrated 2nd to the fact that i’m used to reading instructions and following them step by step and that has worked for me in the pass. that wasn’t the case here. almost everything in my house { from sprinkler system to my lights and fridge) are smart gadgets. even my alarm system and cameras. idid that all my self . based on extensive reading and tutorials. i was frustrated because i’m used to figuring out things once i have researched them prior to receiving them.

Your device will be updating normally.

But because this is a special build that we are not ready to release yet, we are providing it via a separate repository. This allows us to get feedback without breaking anything significantly for those users that are interested in stability. When we’re confident that things are ready to release, we will then push it as a stable update.

You could try this update. If you have problems, you can re-install OSMC easily enough.

Please try the following instructions:

  • Go to My OSMC -> Updates -> Manual Controls -> Enter Hotfix
  • Type ‘usofibunar’ exactly, without the quotation marks.
  • Press OK
  • When prompted, press OK again
  • After a few minutes, the system will reboot.

Now, go to My OSMC -> Updates, -> Manual Controls -> Check for Updates now. When prompted, install the updates.

Your system will then reboot itself again.

Now go to Settings -> System Info and it should show 4.9.113 as the kernel version. This means you are updated.

Now, 3D MVC files should be working.

We are trying to collate all of the 3D feedback in one place, so issues / queries with that should go here: 3D Frame Packed output.

Let me know how you get on.

Cheers

Sam

i haven’t read anywhere where anybody had problems editing in command line so i figured itbwould be simple and easy. usually when something akesa tedious process there will be numerous people asking for help on how to fix it. I always look at other people fixes. never ha to actually reach out myself. seems like the osmc community has some some degree of experience for the most part. looks like most prob. started with raspberry pi. poss why no one really had the problems i have.

ok; thanks. will try right now

sorry for all the grammar errors; my cheap bluetooth keyboard is horrible.

It’s possible you ran nano but not ‘sudo nano’

For most problems we don’t have an issue giving people detailed instructions to accomplish most tasks. It is just for some things we feel it best to not post things that make it easy for someone to cause themselves issues unless they know what they are getting into. This isn’t about you specifically, it is about a barrier for the community as a whole. Most people should not be running a testing build, and if they were it would prove a support nightmare. If you wanted to dive more into how to work with OSMC at a lower level you would just need to learn some basic Linux.

oh, I get it now. I have no idea about nano vs sudo nano. seen a lot of threads with scripts that start with sudo

Keep us posted.

3d ISOs playing off an external HDD with no prob. even tested some 4k titles. setting up audio took some fumbling around. still have a world of configurations to work on. thanks. that’s what i needed. the rest I should be able to figure out by reading through the forums.
I’m taking that playing from blu ray menu doesn’t work 2nd to the java issue. don’t really care as long is i can watch movies in 3d and hear audio i’m fine with that. now I have to work on sharing on my network. I’m using a windows 10 pc with multiple hard drives attached. Read somewhere that I have to set osmc to smb1 when using windows home. I do have windows pro but not on that old PC. Ill figure it out from the threads. thanks a mil sam.

1 Like

Have you seen: Audio hardware and software configuration for audio?

Blu ray menus will work if they are non BD-J.
You can still watch the films though.

No need to set SMBv1 with Windows, unless you are trying to use browsing.
If you can enter IP and share name directly, you’ll be fine. See File sharing with a NAS, media server, windows share or other device.

If you have any questions just open a new thread and we will be glad to help

Cheers

Sam