[TESTING] Support for DVB adapters


For some time we’ve been struggling to get DVB support to work properly on the Vero 4K. Fortunately, we’ve now made some progress.

Further, there’s no longer any need to patch TVHeadend or any userspace application; as the ioctl compatibility support is wholely in kernel. This means you can use any tools like w_scan etc without having to recompile them for the Vero 4K.

It seems that the media_build backports from 4.4 wasn’t reliable. Instead, we’ve chosen to get most adapters working, rather than to have none working. With that said, we will continue to refine support and do our best to support as many DVB devices as possible.

I would appreciate your feedback on this and if results are promising, I’d like to get this in the next OSMC update.

Many thanks to @anbodearg for patiently testing a plethora of attempts at fixes over the last month and a half and for testing our new DVB-T2 dongle.

To test:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Keep your eyes out for a couple of more improvement threads over the next few weeks. We are constantly working to improve the Vero 4K experience.




It works!

1 Like

really cool! yes it works for me as well. I see only the dvb-t and not the t2 but here in Italy they havent started with that yet so its all good for now.

I appreciate really your help on this! again never seen support like this, super!

i dont manage to have the dvb dongle and my hd 2TB at the same time directly connected, the HD keeps re-spinning so i guess its not enough power and i need a powered hub. Any idea how much amp Vero 4k is able to provide to its 2 usb outputs?


Thanks for your kind words.

This should solve the problem: 4 Port USB 3.0 Powered Hub - OSMC.

The Vero 4K will only provide 1A via USB. Split across two devices this won’t be enough to power a mechanical hard disk.


Unfortunately not working here with August DVB T210 tuner for freeview HD. It doesn’t appear under the adapters tab.

Before the update the adapter was there, and recognised as a Silicon Labs Si2168, but the mux scan failed.

When did you buy it? There are at least 2 versions.

Can you post the output of dmesg | grep si2 please? And lsusb?

It’s a couple of years old.

dmesg | grep si2 returned nothing. lsub returned command not found.

try lsusb

sudo apt-get install usbutils

Thanks, installed and now have:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0572:c688 Conexant Systems (Rockwell), Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Ok, thanks. I think we need full logs. You are not alone, but my August T210 is working perfectly.

Thanks. paste.osmc.tv/kuyikufafe

It’s working on a linux box that I’ve been using as tvh server, so if you need any details from that please ask. (If there’s an error in the log about the tvh client not connecting that’s it trying to connect to that server as I hadn’t changed the details in the client)

Thanks. I think the devs have found the issue. Watch this space…


I believe that the driver simply isn’t present in the current 3.14 series of DVB drivers.
The 4.4 drivers were loading for your dongle, but weren’t working (which is rather pointless).

I will see what can be done.


Before the update the adapter was there, and recognised as a Silicon Labs Si2168, but the mux scan failed.

That tuner is the same that my PCTV stick uses and it’s simply not supported by the 3.14 kernel. Since the unreliable backports Sam worked so hard on had to be removed again, I’m afraid we’re out of luck until upstream (AMLogic) provides a 4.x kernel for the Vero’s SOC.


We’ll see.


Hello, I’m new to the forum so apologies if in the wrong place. I have just bought a Vero4K and the DVB-T2 from the osmac store. I have plugged it into a USN port, connected aerial connection, installed TVHeadend service from the app store then logged into tvheadend via my PC on the network. Whatever I do I cannot get tvheadon to see the DVB-T adaptor. I have honestly googled everything but cannot get this to work. My understanding is unless the adaptor is recignised in tvheadend then no point in continuing further. Please help.

Sounds strange. I recommend you log into the Vero via SSH and provide the output of grab-logs -Jso we can see if any hardware issue

Improved DVB support will come in Sunday’s update for all devices.

For now you need to use the staging repository for this to work as expected (instructions in first post).

After Sunday this will not be necessary. Our update got pushed back a bit. We haven’t advertised the DVB dongle yet but it seems to already be selling well; so a few users got caught out.


Thanks for your help. New update worked, I could see the adaptor in tvheadend however once I restarted Vero I now cannot login to tvheadend at all any more - the default user name pw no longer let me in. I suspect I may have input something wrong in setup - how can I reset the whole tvheadend and start again?