[TESTING] Transmission app


I have released a preliminary Transmission app for testing. This is available for all OSMC platforms and it is optimised for performance. I have not tested this application at all yet myself. You have been warned.

Simply go to My OSMC -> App Store and select the Transmission server

Webclient should be on port 9091


Seems Pi 1 did not build correctly, so I will investigate that shortly


Sorry if I’m being dim, but does this mean there’s no transmission app for the Vero hardware? Thought I’d give it a test as requested, but with no specific package listed here, and no app visible in the store, am I being precipitous? The standard debian build works just fine, but happy to look at other options if it’d help.

There is a build for Vero, just use armv7.

It is not in the app store yet because it needs testing, but no one seems to have stepped up to it yet.


Updated original post for clarification

“Unable to locate package armv7-transmission-app-osmc” I’m afraid. I used vi rather than nano to modify the source list file, but I’m pretty confident that shouldn’t be the difference.

I’ve tried installing the daemon package as well, but that tells me “/opt/vero/lib/libOpenVG.so is not a symbolic link”

That’s not an error.

Did you run sudo apt-get update and enable the staging repo as outlined above?

Fixed the missing armv7 repo.

I did, and I’m pretty confident that the addition of the jessie-devel repository has taken effect, because the update output closes with the line “Ign http://apt.osmc.tv jessie-devel/main Translation-en”

Thanks for clarifying that the symbolic link message isn’t an error: because it was the last line of output with no conclusive success/failure, it seemed worth mentioning, but perhaps I should have included the full output.

Regardless, Apt is still unable to locate the armv7 package. Perhaps I’m not your best test user, but I’ve tried to identify which repositories Apt is checking:

$apt-cache policy
100 /var/lib/dpkg/status
release a=now
500 http://apt.osmc.tv/ jessie-devel/main armhf Packages
release o=OSMC,n=jessie-devel,l=OSMC,c=main
origin apt.osmc.tv
500 http://apt.osmc.tv/ jessie/main armhf Packages
release o=OSMC,n=jessie,l=OSMC,c=main
origin apt.osmc.tv

And then a bunch of debian.org addresses

is there a OSMC bild for AppleTV to test this app?

Not just yet


@sam_nazarko Now, to install, run:

sudo apt-get install armv7-transmission-app-osmc hi sam when I run this I get (unable to locate armv7-transmission_app-osmc ?? any ideas thanks

Hi Sam,
Transmission app doesn’t appear to be in the repository, tried to install it manually as apt-get couldn’t find it, apt.osmc.tv takes me here but no app in folder…

Yes it’s missing from the repository at the moment. We’ll let you know once that is fixed.

can anyone say has this been fixed yet or not ?

You’ll be first to know…

lol thanks mate :smile:

We ran into an issue while rebuilding the transmission package which needs some figuring out, however just at the moment we are busy pushing out RC3 - once RC3 is released (hopefully later today) fixing transmission will be back on the agenda.

It seems to go through the motions in the App Store on the GUI on Pi2, but doesn’t install for me. I have no issue with SSH or Cron

That’s because as mentioned the app package is missing.