The Hurricane Heist 4K playback problem

Just have a search here on the forum, enough issues resolved after fstab instead of kodi nfs.

I’m not saying using fstab isn’t faster than not. I’m asking whether fstab is faster than a gigabit usb nic, which you said it was.

I said fstab provides better throughput, but I meant compared to kodi nfs, not better then a Gbit link :rofl:
So it is still better to use it, even with a Gbit adapter.

Ok there was some confusion then.

In any case I’m using that gigabit nic with NO fstab (haven’t really been able to figure out how to make it work with Plex/Plex Kodi Connect - or want to spend the time to make it work).

There have been no issues with high bitrate titles like Lucy etc.

1 Like

i give it a shot add this line to the fstab just because i like to learn

// /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,guest,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

i change the ip address to my ip, save it, then i run sudo mount -a and nothing happen no prompt back no error or anything, im using the guess option, i know i probably doing something wrong a little help will be appreciated

Post the line from your fstab, not the line from the Wiki entry. Were you using the guest option when using Kodi SMB mounts?

yes i use guest on kodi

// /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,guest,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

and thanks

That is not a valid IP address!

i know i just dint want to put the real ip, but i put the real ip on the line thas the only diferent

You could try smbclient:

$ smbclient -L <IP address>

and show that output. I think the next step is going to be that we need to see logs.

i type that and get this

-bash: syntax error near unexpected token `newline

Replace <IP address> with the IP address

Disclosing the real IP address is not a security issue. It’s the same set of IP addresses that 80% of us all use. Your router protects these for you.


i did smbclient -L <> or smbclient -L got same error

That’s correct. So what happened?

i get command not found, i use terminal and google shell secure, gone give a try wiht putty, same error on putty

Sorry, I thought it was installed by default.

$ sudo apt install smbclient

to install it.

after install smbclient, now after type smbclient -L i see all my shared folders on the server, it means that everything is working?

Share the output from smbclient -L and your fstab please. I need to see if they match.


rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)

#/dev/vero-nand/root / ext4 defaults,noatime 0 0
// /mnt/Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,guest,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

smbclient -L

WARNING: The “syslog” option is deprecated
Enter osmc’s password:
Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.7.7]

    Sharename       Type      Comment
    ---------       ----      -------
    WDSab           Disk      
    WDBackup        Disk      
    3DMKV           Disk      3D MKV
    4K              Disk      UHD Bluray
    ADBackup        Disk      Backup Dockers
    APK             Disk      Android Kodi
    App Portable    Disk      App Portable
    Backup          Disk      Backups
    Cloud Server    Disk      OwnCloud Shared
    Concerts        Disk      Music Videos
    Docker          Disk      Dockers
    HT Demo         Disk      Surround Sound Demo
    ISOs            Disk      WMware
    Mac             Disk      Mac Upload
    Movies          Disk      HD Movies
    Music           Disk      Music
    Photo           Disk      Photo & Videos
    TV              Disk      Download TV
    TV Shows        Disk      TV Shows
    Time Machine    Disk      Unraid Time Machine
    appdata         Disk      Data
    domains         Disk      saved VM instances
    downloads       Disk      NZBD Downloads
    IPC$            IPC       IPC Service (Media Server)

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.7.7]

    Server               Comment
    ---------            -------
    SERVER               Media Server

    Workgroup            Master
    ---------            -------
    WORKGROUP            SERVER