Things have gotten really messed up

I’m not even sure where to start on this :frowning:

A couple of moths ago (maybe a bit further back) my OSMC/RPI/HDD sys started acting up. It would do unscheduled, unexpected restarts. I lost use of the MyOSMC app (something abt settings service no longer available). I did try a reinstall of media-center, but nothing changed. So, I decided, once again to flatten and start from scratch :frowning: I expected it to be straightforward, but it has been anything but…

I can get OSMC installed on the uSD card and it seems to work fine from there. Then I try to xfer teh system to the HDD (using instructions found here: Configuring the drive | Using an external drive. However, when I do a sudo reboot things really go haywire. I get a series of msgs of the sort ("…" is a placeholder for the left 5+ chars that seem to be off the screen…): applet not found user specified rootdelay of 5 seconds root file system device
....e2fsck: No such file or directory while trying to open
....bly non-existent device file system corruption found. We will do our best to repair this now.

....k 1.43.7 (16-Oct-2017)
(repeats lines 4 & 5 from above)
NG: OSMC cannot repair the filesystem and serious corruption may exist...... (ya think?  :(

then finishes with...

....:mounting on /real_root failed: Invalid argument
ERROR: OSMC cannot mount  of ext4 filesystem (maybe this is key because I created an ext4 partition on the HDD I was trying to install)
OSMC initramfs Rescue Console.
For help and support...yada...yada...yada...which is why I'm back here...

I have a 2nd RPI3, 2nd HDD, uSD that I have tried. I even swapped out the USB-SATA interface I thought might be the issue. And each time ended up with the same results as above. P/S is a 5A unit and working fine.

Needless to say, this has gotten to be “above my pay grade”. Any insight, suggestions, etc. greatly appreciated. Thx.


Use the official OSMC method instead

Interesting. Did not realize that existed. The 1st time I set up an HDD and the past few times I had to flatten and rebuild, I went with the instructions in the link in my previous posting. I wonder if more recent versions of OSMC no longer work with that process. I figured it must be s/w since I essentially eliminated all the h/w as source issue.

So, in the OSMC install options page I see 4 “run” options:

o from an SD card
o from a USB stick
o from an NFS share
o from internal storage (this one is disabled so cannot be selected, tho, seems the HDD connected to USB might be considered internal storage)

I would guess “from a USB stick” also means USB HDD, and would be the right option. True?

I suppose I saw the “install options” and didn’t quite sort out the “where would you like to run OSMC from?” part of it. Also, the date at the bottom shows 2015. Is that the most recent?

Thx for the help and fast response…cheers…

Yes – you will still need an SD card for booting though.

You can choose the version of OSMC you want to run in the first dialogue

Understood abt still needing the uSD card. Never thought otherwise.

Actually, I was referring to the date of the install s/w, not the OSMC OS.

That’s just a copyright header, not the version

So, then can I assume that the downloader/installer I get from the website is most likely the most recent.

Just wanted to say extend a “BIG” thanks for the help. Getting OSMC onto the HDD was buttery smooth. Don’t know why I hadn’t seen that before (maybe because I hadn’t had to flatten/rebuild in quite some time) and may explain why my system seemed to go a bit haywire.

Thought I was going to have another question regarding accessing Samba shares. However, after shutting down the Win 10 sys last night and rebooting this morning, everything abt Samba seems to be working fine (also have a Fedora 32 sys that can get to the OSMC without any problems). There seems to be some minor things regarding having both an ipaddr and hostname show up identifying the same shares connection to the OSMC sys, but I’ll have to play with it for a while and see if it settles out OK.

Again, appreciate the support. Great to have my OSMC sys back up and running (had seriously considered going to LibreElec, but glad I decided to stay with OSMC :slight_smile: Now it’s on to getting tvheadend back into shape…


I’ve got the system up and doing great. Seems really stable again.

I did have a kind of follow on question (wasn’t sure if I should start a new topic or not)…and this may, or may not, be the appropriate forum…

I’m using what is supposedly the official Kodi remote on an Android phone.

Before this recent flattening/rebuilding of the system, I was able to step 10 or 20 secs. ahead or back by using the main menu arrow buttons (part of the cluster in the lower part of the phone display of large left/right/up/down arrow buttons with a round middle button for enter or select (it has the kodi symbol on it). Now, after the rebuild, I cannot use the left or right arrow buttons to step forward or backward during videos. However, the buttons do work correctly when in a menu. I can still use the strip of buttons that appear near the top of the screen to go forwards or backwards, but it isn’t in steps. Pressing those buttons just increases the speed of movement.

What I’m wondering is if there’s a setting in OSMC/Kodi that will allow me to use the big arrow buttons again for stepping.

Thx and cheers…

What exactly are they doing when you press the arrow buttons now? The arrow keys are working correctly in the official iOS Kodi app. FYI the arrow keys during full screen video are not just short and long skip step. If there is any bookmarks or chapters in the file then up/down controls those and you loose the large skip function. On the small skip step it switched between time and percentage skip depending on the length of the file so that can cause some confusion as well.

Just to make sure we’re on the same page. I’m not on an iPhone. I’m on an Android phone so my version of the Kodi remote may be a bit different.

The larger arrow buttons that are pretty much always visible for menu select/activate functions are the ones I’m referring to. Up until this most recent rebuild :frowning: the left/right arrows would provide a single step/skip of 10-20 secs. forward or backward while watching a video (can’t remember at the moment if they do the same when watching music, but I believe they did) and the video would go back to normal speed. They don’t do this anymore.

This is as opposed to the smaller arrow buttons that appear (along with the stop and play/pause buttons) at the top of the remote when material is playing. Those provide an increasing or decreasing speed (x2, x4, x8, etc.) of movement thru the material and you have to press play or stop to either stop or go back to normal speed, or the opposite small arrow button to slow down the speed.

I really like the skip function would enjoy being able to get it back. Thx.

I understand your using Android. I don’t own one of those types of devices so I made a point of specifying what I was testing with. I doubt there is a difference in the JSON commands being sent for the direction keys.

I asked what the direction keys are doing when you press them now, not what they used to do. Also the audio should do skip step with left/right direction but this is only when you are in full screen mode.

1 Like

Does the Yatse app work any better?

Appreciate your patience. Just want to be sure. Thx.

When in either music/full screen or video, none of the large arrows (left/right/up/down) seem to have any effect on the music or video playing, or anything else, for that matter. However, like I stated before, they all work fine when being used for menu action.

I did notice something I hadn’t before. When I enter a function that requires text input (like Search), my phone used to pop up a text window and a keyboard (along with the keyboard on the HDTV screen). Now that also doesn’t happen and I have to use the clunky on-screen keyboard to enter text.

Wonder if the 2 problems are related?

Assuming the program your using is Kore I was able to find reference to needing to enable event server for this feature to work in that app.

In Kodi go to System -> Settings -> Services -> Remote control and enable the option “Allow remote control by programs on other systems”

In Kore go to the media center list (top item on the side menu), tap on your media center and enable “Use EventServer”.

Make sure that port 9777 isn’t blocked.

Also see

and for other issues with that app

Just as a follow up…I forgot I had Yatse on my phone. Turns out Yatse does support the skipping function as I remember it. However, same thing when it comes to opening a keyboard and a text window on the phone when text input is required like doing a function such as search or rename.

I remember seeing that setting and made sure it was off for security reasons. I’ll check that out and your links and see how that meshes with what I want vs. what I can actually have. I’ll post back with my results.

Thx again for the help and support.


Also confirm you have the correct port configured in your app. I’ve seen having port 8080 when port 80 was correct (or vice versa) resulted in limited function. Correcting to the proper port returned full function.


I had run into the 80 vs 8080 before. In my case, it flat out would not work if the ports weren’t matched. Thx tho.


Thx for the links and help, again. I turned on the “use eventserver” and that seemed to do it. Not sure why I had to do that this time, tho. Never did before. Oh, well. Got my arrow key functions back and I’m a happy camper again :slight_smile:

Onto a couple of other minor annoyances I need to sort out.


1 Like