Too dark picture. Vero 4K+

#1

Hey. I am new here and welcome everyone.
Yesterday I bought Vero 4K + and I have some problems with it.
First of all, the picture on my TV (Panasonic VT30) is quite dark. The same material reproduced on my current player (Med800X) is much brighter and has more details in the dark elements.
It helps to raise the level of brightness and sharpness a bit. Is this how it should be? Is it possible to adjust color coding to 10 bit in the settings?
The dark picture for me is on the 1080 material and probably on 4K too.

#2

Have you tried with HDR content?
Can you post some logs so we can check your settings?

If you enabled Adjust Refresh Rate we will do this automatically.

Thanks

Sam

#3

Thank you for the quick reply. When I get back home, I will send the logs with my settings.
But too dark the picture was also on FullHD 1080p.

#4

That will depend on the material that you are playing; and some settings.

Sam

#5

I know it depends on the material, but the same material seen on Mede8er is much brighter and has more details in blacks.

#6

You may have different settings on your other device.
It is hard to speculate without some logs.

#7

Even picture settings from the TV can be different per HDMI connection, but you probably have checked that first.

#8

The VT30 keeps different settings for each HDMI input. Try plugging the Vero into the same input as the Med800X was plugged into and see if it fixes the issue.

If it does, you should copy all the settings from this input to the input you want to plug the Vero into. There is no easy way to do this other than to write down all the settings, then switch inputs, and set the settings the same.

#9

Of course, I connected vero4k + to the same input on TV and even the same HDMI cable.

And here promised logs:
https://pastebin.com/0vs0PzK4

And one more information that can be important. The signal from the 4K + vero goes to the Onkyo 905 receiver and from it to the TV.

#10

Please use the log uploader in MyOSMC after setting logging to debug in Settings-System-Logging.

So you mean you are using the same input on the Onkyo for Vero and the other device?

#11

Exactly.

#12

OK
https://paste.osmc.tv/utuyufikij

And I still have a second problem. When playing a 4K movie with a soundtrack including The Dolby True HD receiver gets PCM Multichanel even though it is set in the passthrought player and should Onkyo 905 decode this audio format.

#13

You have “sync playback to display” active at settings->player->video. This prevents audio passthrough.

#14

Thank You.

It helped. I thought that it only adjusts the frequency of video playback and here it also affects the audio stream.

So there is only a problem with a bit too dark image.
And I will ask you how to unmount the attached hard drive without disabling Vero?

#15

Regarding the dark picture: This could be caused using the wrong colour space setting. Try

  • settings -> system -> video and activate “limited colour range”

but better check

  • in the vt30 picture menu look for a DVI setting and choose another value instead “normal”

just an idea, no guarantee

#16

Eject a drive:

Try settings->file manager, go to the drive item and press the context button (three horizontal bars)

#19

Thank you once again. It works.

#20

I have noticed a similar problem. I also have a Panasonic TV (ST60) and the Vero and Firestick are both plugged into a Marantz amp. The TV is set to full colour range for that input - It has to be to get a good picture from the firestick but this makes vero pictures too dark. The full colour setting on the vero makes the picture too dark. Is there a brightness setting to match the vero with other devices?

#21

We are missing some information, here. My Panasonic cannot be set to full range with a YCC input, only with RGB. Is that what you are using? Does the Firestick output in RGB, perhaps? (The Panny should tell you, on-screen.)

If you set both vero and TV to limited range (as they should be) do you get a ‘right’ picture?

Is this problem dependent on video material?

#22

Thanks @grahamh, the Firestick doesn’t give me any way to change the output (other than a hidden framerate menu, it’s the older type of firestick). The tv doesn’t tell me what type of signal it is either. Also, it doesn’t seem to automatically select the correct type so I have to manually adjust every time I switch between firestick and vero.
So it sounds like:
The firestick is locked to RGB full range and
the vero 4k+ is locked to YCC limited range
Does that sound correct?

Further info: My TV just has the options Auto/Normal/Full. Full also works best for the bluray player. I don’t notice the issue on all videos but I know a couple of scenes in films which are obviously crushed when set to full. Everything on the firestick looks dark on normal.