TOSLINK output to external decoder?

You might remember my efforts to get 5.1 sound through an USB soundcard? Well it has worked fine, but now, with the new TV I have another signal source, so I bought an old Yamaha Dolby box, three amps and decoder and three toslink inputs.

Problem is that I cannot get 5.1 over toslink on the Vero. If I understand correctly I should set the soundcard to passthrough, but there, underpassthrough I only see the built in soundcard HDMI output.

What do I have to do to get 5.1 on the toslink?

1 Like

Excellenti writeup yes. According to it I should select the internal AML-M8AUDIO HDMI&SPDIF, 2 channels and enable passthrough, but the problem is that I cannot select AML-M8AUDIO SPDIF as the passthrough device. Only AML-M8AUDIO HDMI?

If I add my USB souncard, I can select SPDIF on that and I get full 5.1 so that should in essence solve the problem, using something I already have, but not being able to use the built-in toslink irks me.

Could this be of my own doing? But I cleared out everything I had put in asound.conf in the past and still the selections I have for passthrough device are:
USB Sound Device

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Sure: suxubawema

Here are some pictures of the issue. As you can see I cannot select the optical for passhrough. It does not matter whether I pull the USB soundard or not and it works with he USB soundcard.


What happens if you set the The Audio Output Device (Not the passthrough one) to Default (AML-M8AUDIO: HDMI, S/PDIR & analogue) ?

Thanks Tom.

1 Like

It happens what I wrote initially :slight_smile: It does not work. There is no audio passthrough. I assume that ends up in the HDMI cable.

Edit: Ie, that is the first thing I tried. I only added back the USB card today as a troubleshooting measure.


I maybe wrong, but I think if you set output to default device and enable passthrough and set channels to 2.0. It should send audio output to toslink. Have you tried this?

I was also recommend Enabling “Mute HDMI AUDIO output” Its Under Settings, System, Display.

Thanks Tom.

Yes, that is correct that is how it works here.

1 Like

It does send audio to toslink, but not passthrough.

That must be a new setting. Have not seen it before. Must be new as it is not translated in the skin :slight_smile:

(If you need help with Swedish translations, just ask)

Anyway. That setting does not affect the problem. Ie the only built-in device available for passthrough is HDMI.

It does work for me for the supported formats (e.g. DD5.1)
If you configure pass-through and 2 channel.

Here the the view from Guisettings

And two screen shot

Screenshot from 2020-11-16 00-05-43

1 Like

Thanks for verifying that and now it works for me. I wonder if, initially, something else was out of whack and then it should have worked, but I blindly assumed it did not as the passthrough device was grayed and said “HDMI”? Anyway, now the Yamaha processor work just fine for both 5.1 and DTS Ans wife can get surround from both TV and Vero. HAppy days!

1 Like