Transmission locks up/freezes Rpi2

Hi everyone,

I have two Raspberry Pi 2 Model Bs. One is running the latest version of OSMC (December), other the latest version of Raspbian Jessie. Both are connected to 100 up/down wired ethernet and use the official raspberry power supply unit. Also, both use Sandisk Ultra Class 10 32GB SD card.

I have the transmission daemon running on both of them - in the OSMC one I installed it via the app store, and in the Raspbian I installed it the normal way. Other than than transmission they are both stock. The issue is that transmission does not work well at all - the symptoms are identical on both raspberries.

When starting just a single torrent download at reasonable speed (from 0.5MB/s to 8 MB/s) raspberry starts locking up and freezing, in the transmission web interface the download is shown, but speed goes up and down from max to 0 KB/s and the web interface disconnects after a minute, I have to wait for SSH to respond for two minutes or so (normally 2 seconds), Kodi is almost unusable in the OSMC pi, etc. The only way to make the Pis usable again is to wait till SSH connects and to manualy stop the transmission daemon.

It is important to note that when I set a download speed limit to 500 KB/s both raspberries do not lock up and the web interface does not disconnect, but speed of the torrent will still drop to 0 KB/s and then jump back up to max available every 30 seconds - this is not acceptable. I also have to note that I have played around with the transmission settings file (after manually stopping the daemon, of course) and set the cache size to 32MB, as well as set the max number of peers to 10, etc. Nothing seems to help, really.

Naturally, I want to fix this situation. I am sure that I am not the only one experiencing this. I have read about other users having similar problems, but I have not been able to find a clear description of the cause and solution to this. In my setting a typical download speed of a torrent is close to 8 MB/s and I am willing to accept something like 4 MB/s, but not 500 KB/s with constant speed drops to 0 KB/s. I want to understand whether the issue lies in the raspberry design, raspbian design, the transmission daemon, my SD card, or somewhere else.

Hence I would appreciate if someone:

  1. Suggested steps to diagnose the actual cause of this. I am ready to provide any logs necessary, but please tell me which ones you need.
  2. Confirmed that indeed it is possible to, for instance, run the transmission daemon non-stop downloading a torrent at 5 MB/s.

Thanks

To get a better understanding of the problem you are experiencing we need more information from you. MOST IMPORTANTLY, you need to provide DIAGNOSTIC LOGS so we can diagnose the problem. If you don’t supply logs, we can’t help you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Alright. So this is what I just did:

  1. I rebooted the OSMC Rpi2 running transmission.
  2. Right away I connected to the transmission’s web interface. There was one torrent downloading at speed of 4 MB/s. The page did a couple of the usual 5-second refreshes and then the refreshing stopped. When I tried to reload the web page nothing was happening.
  3. I managed to ssh into raspberry after waiting around 2 minutes til successful login (without transmission downloading something an SSH login takes 2 seconds).
  4. I entered grab-logs -A and after 5 minutes of waiting (without transmission downloading something it takes 5 seconds) I got this URL: http://paste.osmc.io/togujinami
  5. Finally, below you can see my transmission settings.json file. As noted before, I reduced the allowed number of peers and increased the cache-size-mb to 32. This did not help to solve the issue.

{ "alt-speed-down": 50, "alt-speed-enabled": false, "alt-speed-time-begin": 540, "alt-speed-time-day": 127, "alt-speed-time-enabled": false, "alt-speed-time-end": 1020, "alt-speed-up": 50, "bind-address-ipv4": "0.0.0.0", "bind-address-ipv6": "::", "blocklist-enabled": false, "blocklist-url": "http://www.example.com/blocklist", "cache-size-mb": 32, "dht-enabled": true, "download-dir": "/home/osmc/Downloads", "download-queue-enabled": true, "download-queue-size": 5, "encryption": 0, "idle-seeding-limit": 30, "idle-seeding-limit-enabled": false, "incomplete-dir": "/home/osmc/Downloads", "incomplete-dir-enabled": false, "lpd-enabled": false, "message-level": 1, "peer-congestion-algorithm": "", "peer-id-ttl-hours": 6, "peer-limit-global": 30, "peer-limit-per-torrent": 20, "peer-port": 51234, "peer-port-random-high": 65535, "peer-port-random-low": 49152, "peer-port-random-on-start": false, "peer-socket-tos": "default", "pex-enabled": true, "port-forwarding-enabled": true, "preallocation": 1, "prefetch-enabled": 0, "queue-stalled-enabled": true, "queue-stalled-minutes": 30, "ratio-limit": 1, "ratio-limit-enabled": true, "rename-partial-files": true, "rpc-authentication-required": true, "rpc-bind-address": "0.0.0.0", "rpc-enabled": true, "rpc-password": "{1332f5eb84c4d2000367d7630054e0e20c44e13eNDxos.66", "rpc-port": 9099, "rpc-url": "/transmission/", "rpc-username": "miks", "rpc-whitelist": "*.*.*.*", "rpc-whitelist-enabled": true, "scrape-paused-torrents-enabled": true, "script-torrent-done-enabled": false, "script-torrent-done-filename": "", "seed-queue-enabled": false, "seed-queue-size": 10, "speed-limit-down": 1500, "speed-limit-down-enabled": false, "speed-limit-up": 500, "speed-limit-up-enabled": false, "start-added-torrents": true, "trash-original-torrent-files": false, "umask": 18, "upload-slots-per-torrent": 14, "utp-enabled": true }

Please? @sam_nazarko

[  240.369590] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[  240.369597] cron            D 807386d4     0   507    243 0x00000000
[  240.369625] [<807386d4>] (__schedule) from [<80738cd8>] (schedule+0x58/0xc8)
[  240.369644] [<80738cd8>] (schedule) from [<802e2678>] (start_this_handle+0x414/0x768)
[  240.369661] [<802e2678>] (start_this_handle) from [<802e2ac8>] (jbd2__journal_start+0xfc/0x214)
[  240.369677] [<802e2ac8>] (jbd2__journal_start) from [<802c34d0>] (__ext4_journal_start_sb+0x7c/0x170)
[  240.369692] [<802c34d0>] (__ext4_journal_start_sb) from [<80286d24>] (__ext4_new_inode+0x5a8/0x14c8)
[  240.369708] [<80286d24>] (__ext4_new_inode) from [<8029c12c>] (ext4_create+0x130/0x1dc)
[  240.369725] [<8029c12c>] (ext4_create) from [<801ed13c>] (path_openat+0x1448/0x1548)
[  240.369743] [<801ed13c>] (path_openat) from [<801eded4>] (do_filp_open+0x70/0x104)
[  240.369761] [<801eded4>] (do_filp_open) from [<801d51e4>] (SyS_open+0x128/0x1e4)
[  240.369777] [<801d51e4>] (SyS_open) from [<80016d40>] (ret_fast_syscall+0x0/0x1c)```

Are you downloading to an SD card?
Are you watching TV while you're torrenting?

Yes, I am downloading to the internal 32GB SD card.
No, I am not doing anything in parallel, because it is simply not possible to do anything - ssh hangs, kodi interface lags significantly. Naturally I would want to be able to use kodi and torrent in the background. I must add that it worked perfectly with ATV1, hence I suspect this is a raspberry-specific issue.

Thanks

I don’t think the SD card is equipped for continuous writeback operations while doing other things. The ATV probably worked better because you probably ran off the internal disk.

Use a USB drive, torrenting to an SD card is not a good idea.

Thanks for the tip - I attached and external HDD, pointed transmission’s download folder on it and now everything works perfectly - average download speed 8 MB/s, no drops in speed and system (incl. Kodi) works perfectly in parallel.

I would highly recommend on adding a comment at the Transmission’s page in App Store about this - I would say that an external HDD is a must and SD card is an absolute no go.

Thanks once more!

PS Can I use a high capacity USB flash drive/SSD instead of HDD? Will I still be able to torrent and use Kodi? Or will the USB flash drive/SSD have the same issues as SD card?

@sam_nazarko

I’m having this same issue, only I already am using an HDD to download to. As soon as I add a torrent, the rpi goes mental and takes forever to do anything (even ssh). I looked at my logs and I don’t see anything obvious in them, this is my transmission settings.json.

I’m wondering wether this issue in my case could be related to the fact that my HDD is using ntfs. @reinis what filesystem are you using in yours? Does anyone have any other ideas?

NTFS goes via fuse and will be really slow

@sam_nazarko is exFAT a good option for the rpi + osmc? I want to have the HDD usable for osx and the rpi, but as quick as possible on the rpi. This seems to be the best option from what I saw on stackexchange etc.

Format it as HFS+

I managed to test this, HFS+ doesn’t make the rpi freeze. Kodi is pretty slow while downloading something, but at least the rest of it is responsive. It looks like the filesystem is a potential issue too. Thanks @sam_nazarko!

Hi,

Sorry for respond for this old topic but after last update i have this same issue. 2-3 months ago i dont have any problem with downloading something from transmission and now osmc or even ssh is freezing. I know that You all write 2 years ago that potential problem is external HDD on NTFS. But as i write beafore with this same disk i have no problem 2 months back. Can anyone have this same issue ? Any ideas what to check ?

First check the power supply. Are you saying that the downloads stall? Or that the entire Rpi locks up? Can you still access by SSH?

I bought power supply with my rpi, its original rpi3 power supply.

Download is progressing but rest of rpi is freeze. When i type something into SSH console response come after 2 min. When i type top to see what is draining my pi respond with info was shown after all downloads in transmission was over. I was able to type something into SSH console only because i start it beafore transmission started download. When i close SSH window and try to open it again it wont work. I try to access OSMC folder from windows explorer but nothing loads until transmission downloads are over.

Hi,

Even the official PSUs can fail, I would try another as ActionA recommends.

Thanks Tom.

Ok I try tomorrow. But why it can be problem with psu only when transmission is downloading but for example when streaming movie to my tv from external hdd everything is ok

Higher CPU demand = more power demand. Power supply, or any other hardware, performance will deteriorate over time.