Transmission's low speed in large files

Hi everyone,

I face a problem with transmission and I would like some help.

Every time that I choose to download a big single file, i.e. Blu-Ray ISO, as further as the download goes, there are two issues that appear.

  1. The download speed is reduced. My default download speed is at 10-12Mbps and this speed is reduced at 2-3Mbps when the size of the downloaded file reaches around 15GB.

  2. The access to the client from Kodi and from the laptop (via Transmission Remote GUI) is really hard with huge lags and disconnections.

This issue has been forever since I am using Pi and OSMC, so it is not a software issue from a corrupted installation since I have reinstall both several times.

So my question is, is this a common Transmission issue or is something wrong with my HDD?

FYI, the playback of Blu-Ray ISOs is flawless…

Thank you

Perhaps your temp Transmission folder is still the default one, which is on the SD card. You should always change that to your hdd. I can imagine your SD card is simply starting to fill up. This happened to me once and I had the same symptoms.
I don’t have any of these symptoms with the temp and download folder set to my harddrive… But i also limit Transmission to 2500KB/s simply to keep bandwith for other stuff. BTW my RPi2 is connected via LAN, not WLAN. And access to Transmission’s webGUI is via laptop/WiFi.

My download folder is at the HDD. I don’t have such a big SD card :grin:

I also have my Raspberry connected via Ethernet and I don’t have any problems with files smaller than 10GB. During those downloads, my speed it at the maximum all the time and the access to Transmission is flawless from Kodi and remotely. The problems occurs when the downloaded file is over around 10-15GB. To be more clear, if I select a 25GB file, then till the first 10-15GB the speed and the access to Transmission will be fine. After the 15GB everything in Transmission will start to lag.

Are you sure your temp folder is also the HDD?
Those are 2 different folders, Download and temp which is called “Incomplete” by default (/home/osmc/downloads/incomplete).

I actually don’t even know my download speed. Files are usually added automatically to Transmission and I see them in Kodi. Sometimes I check the UI but speed is not important to me… most files are usually ready to watch when I want to watch it.
But I never experienced any lag with the webUI… not even with multiple 18GB files finishing their downloads.

I will check later where my temp folder is. Probably you are right…

I changed in Transmission Options the “Default Download Folder on remote host” that was at osmc/downloads like you said, but I really don’t understand what is the purpose of that option, since in the Application Options I have as a path my HDD and I always choose to download my files in my HDD.

Also, the “Directory for Incomplete” is unchecked, like before.

Now I have to find a big file and try if this will solve the problem.

Transmission defaults to using an “in progress” folder to store torrent data until that torrent is complete, at which time it moves the file/s to the completed directory that you had already selected as your HDD path. This has been transmission’s behavior for quite some time. I imagine it is so that incomplete files are not visible in completed directory where a user might have scripting or scraping that would be detrimentally affected by having incomplete files present.

I know this might be a little off topic but have you tried using the scp protocol. A great little program I like to use to move files over is called winscp.

I have exactly the same problem, the first 10GB goes fine, but thereafter begins to lag. The default temp folder is on my HDD:
“incomplete-dir”: “/media/HDD/Downloads/Incomplete”,
“incomplete-dir-enabled”: true,

Tested with 2 different Raspberry Pi and 2 different external HDDs…

Are there any other options that should be changed?

Thank you

From the Transmission Remote GUI I have the following (Elements is the name of my HDD):

In Transmission Options:

  • Default Download Folder on remote host:

  • Unchecked the directory for incomplete files

In Application Options:

  • Paths:

Thank you for your answer, but my problem was apparently the weak power supply… Since I’ve changed for a better one, the server is always fast accessible, doesn’t lag. The download speed is still not perfect, it jumps regularly to <10kB/s or Idle for few seconds, but besides that it is good.

Im experiencing the same problem. I have rpi2 connected through ethernet with a usb ntfs hdd attched to it, when i wzs downloading 10-15gb fil3 everything was fine but now with 30gb files my speeds max out at 2mb/s combined and the web gui is very very slow. Any solutuon? Btw the rpi is powered by the 5a power plug

Could one of you experience the problem please try a fresh install with raspbian or something not OSMC and attempt to replicate the problem.

I’ve a feeling this is more of a hardware limitation of sorts as opposed to a specific distro issue, either way it would really help towards finding a solution or cause.

There may even be improvements made by using EXT4 formatted HDDs as opposed to NTFS. Just a hint…

I guess i can try but then my tv,windows pc nor Sonos system would be able to read the drive. Im installing krypton right now. Then if u tell me how to backup evrrything to restore later i can try something else

Are you not sharing the drive by samba server from the pi already? If you are, it makes no matter what filesystem the HDD is, the data provided by samba will be read without issue. The filesystem type would only be an issue if you try to connect the drive to these devices directly.

Correct im reading through Samba. But have no way to back 2tb of data. I will try and create a ext4 partition on whats left on the drive. Also could you tell me how to clear unused repos as i cant install updates anymore…i think i have a broken package somewhere

This should be an extremly simple google. “remove kodi repository”

Ign jessie InRelease
Get:1 jessie-updates InRelease [145 kB]
Hit wheezy InRelease
Hit jessie/updates InRelease
Hit jessie Release.gpg
Ign ./ InRelease
Hit jessie InRelease
Hit jessie Release
Hit krypton InRelease
Hit wheezy/main armhf Packages
Ign ./ Release.gpg
Get:2 jessie-updates/main armhf Packages/DiffIndex [6916 B]
Ign ./ Release
Get:3 jessie-updates/contrib armhf Packages [32 B]
Get:4 jessie-updates/non-free armhf Packages/DiffIndex [736 B]Get:5 jessie-updates/contrib Translation-en [14 B]
Get:6 jessie-updates/main Translation-en/DiffIndex [2704 B]
Get:7 jessie-updates/non-free Translation-en/DiffIndex [736 B]Ign ./ Packages/DiffIndex
Hit jessie/updates/main armhf Packages
Err ./ Packages

Hit jessie/updates/contrib armhf Packages
Get:8 jessie/main armhf Packages/DiffIndex [2023 B]
Hit jessie/updates/non-free armhf Packages
Ign wheezy/main Translation-en
Err ./ Packages

Hit jessie/updates/contrib Translation-en
Hit jessie/main armhf Packages
Hit jessie/contrib armhf Packages
Hit jessie/updates/main Translation-en
Err ./ Packages

Hit jessie/non-free armhf Packages
Hit jessie/contrib Translation-en
Hit jessie/updates/non-free Translation-en
Hit jessie/main Translation-en
Get:9 krypton/main armhf Packages/DiffIndex [2023 B]
Hit ./ Packages
Hit jessie/non-free Translation-en
Ign ./ Translation-en
Ign jessie/main Translation-en
Ign krypton/main Translation-en
Fetched 160 kB in 23s (6789 B/s)
Reading package lists… Done
W: Duplicate sources.list entry krypton/main armhf Packages (/var/lib/apt/lists/apt.osmc.tv_dists_krypton_main_binary-armhf_Packages)
W: You may want to run apt-get update to correct these problems
osmc@osmc:~$ sudo apt-get update

Removed the duplicate entry but still got errors with distro upgrade
Get:5 jessie/main armhf Packages/DiffIndex [2023 B]
(Reading database … 46873 files and directories currently installed.)
Preparing to unpack …/rbp2-mediacenter-osmc_17.0.0-4_armhf.deb …
Hit jessie/updates/non-free armhf Packages
Hit jessie/updates/contrib Translation-en
Hit jessie/updates/main Translation-en
Err ./ Packages

Hit jessie/updates/non-free Translation-en
Get:6 krypton/main armhf Packages/DiffIndex [2023 B]
Err ./ Packages

E: Sub-process /usr/bin/dpkg returned an error code (1)