TVHEADEND not scanning

First congratulations to Sam and the team on getting the RC out the door. Looks good. I’ve downloaded TVHEADEND from the store but have had trouble getting it to scan. Does anyone know of a good tutorial for this specific version oh TVH?
I’m fairly sure I’ve set up the adaptor, networks, muxes etc. correctly and they all seem to be linked. I assume the scan is supposed to start automatically at some point but it’s disappointing not to have a “scan now” or “rescan” button or any sort of progress indicator. There seems to be no way of knowing what if anything is happening at any stage in the process.
Also I’d love to hear from others’ experience with particular Deb-t tuners. I’m testing with an August DVB-T205, trying it plugged directly into the Pi2 and also into a powered hub. Pi2 powered by 2amp power supply. I’m using a rooftop aerial that gives 100/100 strength to my TV but the best I’ve so far gotten from the T205 is 22% (Openelec). Would love to know if I’m wasting my time with this tuner, hub or whatever.

1 Like

Some additional info. I’ve tried the August T205 stick plugged into a Windows machine and connected to the the same outdoor aerial as before. Results were excellent. Perfect picture and sound. So I’m guessing it’s the no-name usb hub that’s the problem on the Pi2, although it has had no problem powering too usb hdd drives plus a wireless mouse dongle.
Anybody know what the power requirements of the T205 are? Their pr just says very low power but can’t find exact figures anywhere.
Hope a pro reads this and can help.

Try MyOSMC>PiConfig>enable max_usb_current and reboot

Thanks. I’ll try that. Won’t know if it works until I can figure how to get TVH TO scan😌 but will let you know.

Ok, started from scratch with clean install of RC. When I entered the first mux it scanned immediately - no services. I added 6 more muxes to same network and waited and waited… Eventually I rebooted and all muxes were scanned but no services were found.
Is there any other version of TVHEADEND that will work with OSMC? Or any other backend ?

Did you enable max_usb_current and then reboot? Can you confirm that the line is now present in /boot/config.txt?

Yep. Max_usb_current=1. Rebooted, which started the scan I mentioned. Decided to reboot again and Pi froze. Had to do hard reset - pulled the plug. After restart TVH still the same. Any other backends supported by RC?

I don’t use tuners etc… Would be quite helpful to confirm that the line is properly appended to config.txt though.

Yes the line
is in the config.txt file.

Hi ActionA,
Appreciate your difficulty if you don’t use these things yourself. Hoping someone in the community might weigh in. Is the AppStore version of TVH maintained by OSMC guys or outside?

Thank you!

Just wondering where best to post this problem. It could be my hardware or it could be software related, drivers for example? Is OSMC Team responsible for this version of TVH or should I post in TVheadend forum?

Noggin, over on the RPi section of the Kodi forums wrote up pretty easy to follow step by step instructions for TvHeadend setup and config just recently…

@wrxtasy, thanks for the link. That’s a pretty recent build but not exactly the same as the OSMC version. I can’t find anywhere you can select a transmitter, e.g. Crystal Palace in the OSMC version. The Network Discovery doesn’t work either, and the Force Scan option is also gone, but I’ve now moved beyond the scanning problem as I can force this by rebooting, but I get no services. My power supply seems to be adequate, but I’m left with these results, using the same tuner stick: on a windows machine, all channels with 100% signal, Openelec on Pi2 all channels with an unusable 22% signal, and OSMC on Pi2, no channels at all at all.
I know it’s a difficult one to help with from a distance, just hoping someone will suggest a way forward that doesn’t involve buying lots mor gear on spec.

I have the exact same problem with my triplestick t2 292e that i use the DVB-C tuner in. I can scan muxes and find channels with w_scan but tvheadend dont find anything on scanning the muxes. For now im using VDR

I used this guide for installing and configuring VDR:

But the VNSI server installation is outdated in the guide and dont work. so for the VNSI part instead do this:

git clone
cd vdr-plugin-vnsi
sudo make install

Then activate VDR VNSI Client pvr plugin in OSMC.

Thanks for the link Simon. Unfortunately it looks to be beyond my skill level. I’m good enough to follow the instructions but if (when) a problem came up, I’d be out of my depth. I actually got VDR up and running on Openelec, found some channels but signal wasn’t good enough to be usable. So still don’t know if the problem is hardware or software.

I can definitely confirm that those TvHeadend instructions work on a OpenElec / RPi B+. I end up with a 78% signal using a PS3 Play TV usb. A 22% signal seems abnormally low. I doubt anyone could tune anything with such a low powered signal, which is very likely why your having issues.

So to answer your question from your first post, I think your wasting your time with your August DVB-T205. It looks like its time for new Hardware. :frowning:

I built the latest stable tvheadend from source and now I get all my channels on scanning and everything works with the kodi addon.

@wrxtasy You’re probably right but then there are those 100% figures on a very average Windows PC with the same stick? I was hoping to prove the concept with the cheap stick before committing to a more expensive HD one.

@SimonO, any chance of an idiot’s guide to building TVH from source?

Hope this will work, not sure if I had installed anny of the required packages for building earlier.

sudo apt-get install build-essential pkg-config libssl-dev bzip2
gunzip 3.4patch1.tar.gz
tar -xf 3.4patch1.tar
cd tvheadend-3.4patch1

for now I have not made any autostart for it so im just running it from the source directory and had to do some tweaks do get the webinterface working.

cd build.linux/src
mv webui webui.orig
ln -s ../../src/webui
cd ..
./tvheadend -C