TVHEADEND not scanning

Have made some progress with my problems with Tvheadend, but am stuck with it refusing to scan - the “Initial scan complete” reports false on the Muxes tab, and the Scan Q length is reported as 1 on the Network tab. What is “w-scan” mentioned above??? Help please

As another test to find out if it was a hardware or software problem, I tried the same tuner stick on a Pi1 with Raspbmc. TVHeadend found all channels with 100% strength, but Raspbmc went into a permanent reboot loop, which appears to have been a fairly common problem after switch from xbmc to kodi. I can’t afford to waste any more time on this. I’ll check back in in the future sometime when TVH may be working.
Meanwhile, Thanks to everyone who tried to help here.

Just wanted to say that i’m having exactly the same issue. I have an Afatech AF9015 based DVB-T. Using TVheadend 3.9 from the OSMC AppStore. I am no longer able to see the regional data to automatically add the muxes which I have had to add manually but as mentioned above it scans but no services are found. I have also set the usb to maximum current and the light does come on on the usb stick itself indicating activity but no services are found.

has anybody had any luck with scanning muxes. I have an RTL2832 based DVB-T adapter and I can’t get any channels/services.

I have to say it is the first time that I use tvheadend but it definitely looks like the adapter is recognized fine but I can’t get any channels.

Tried different guides but nothing

If anybody has had any luck please let me know.


Nirvana, and Dadooq if still monitoring this board:
My successful experience with adaptors is limited to laptop installs, and year-old Hardware by Hauppage.
The instruction manual indicates that the device will need the undivided output ( ie dedicated) output of a USB port, and hubs are not permitted. It is quite possible that the adaptor could perform a successful scan, but
Antenna and other reception-related factors were also critical.
I intend to try this with the adaptors etc as recommended in other posts.

so, we should use TVHeadend from OSMC app store or from source? im now little confused…

I have had no luck with tvheadend from the AppStore, the same as most others as far as I can see. I use the build as described by HarryL… Works great.

1 Like

yes, that build works great for me now :fireworks:

Hi Jehop and
CC @HarryL
CC @DBMandrake
I sent the August 205 back to seller as non-working. Bought Pctv 292e. New install of OSMC, followed HarryL’s script to install TvHeadend (Thanks Harry) Added access control directory as per DBMandrake’s script (thanks Mandrake) in same thread. Everything working perfectly. Thanks to all contributors for sharing experience.
Oh, and I searched this forum to find out how to make TvHeadend start on boot.
Would be great if all this was brought together by someone who knows what they’re doing so that all amateurs could benefit.

Dadooq: good on you. It WOULD be great if someone got all this together. Sam Nazarko has a publication on RPiMediaCenter which has been superseded by his move to OSMV/Vero. I have recommended to Sam that he should produce a similar user manual for OSMC and Sam may be in the process of doing just that, either in PDF download or other format. Meantime I am counting on you and HarryL etc to get me on OSMC TV. Then I can get back to learning Linux and Python and experimenting with RasPi which was the original show.
And Mio:
Your problem is solved. Great.

Hi there all… some time ago i compiled all the old tvheadend versions on osmc, they all worked fine exept the newest version that them self link to(and osmc uses)… but the git version works great for me…it’s a bit header to config but works if you know your MUX’s.

i have some advice that you maybe can use…

  1. disable or uninstall tvheadend package ( disable by “sudo systemctl disable tvheadend” )

  2. Start over, delete /home/osmc/.hts ( rm -Rf /home/osmc/.hts ).

  3. Don’t create the “/home/osmc/.hts/tvheadend/accesscontrol/1” file, don’t wast time on that it can be createt from within the webui when it all works (just start tvheadend with -C).

  4. Get to know your local TV provider, in Denmark it’s YouSee and Stofa for CableTV and freeview/DVB-T( )… they all have information you need like network-ID,Frequency,Constellation(qam),Symbol Rate.

  5. iPhone Tvheadend app (tvhclient):

  6. Remember not to have wifi equipment nearby your Tuner or coax cabel.

  7. buy or use a new coax cabel, older ones are not shielded enough.

Read my guide her:

Hope this helps

I did build tvheadend from source and I got it all working, everything is working for me now.

Unfortunately I coudn’t get it to scan and work with the OSMC tvheadend package.

A lot of options were missing on the web interface and the adapter also didn’t appear in the same way in the osmc package.

You can follow what I did.

The instructions below gives you a working setup on RTL2832 DVB-T stick (that’s what I have).

Main steps were posted from bberski in TVHEADEND 3.9 config

I’ll repeat/ammend what I had to add to get it all built and working.

My slightly changed step by step version (make sure you uninstall the OSMC tvheadend package before you do the below of course):

you can use the same procedure above to create new packages and update your tvheadend with latest source, just skip the installation of the “packeges to build tvheadend”
you also need to remove the current source from /tmp/src/

let me know if you are successfull.

Is any possibility to make TVHaedend installed from app store working?
I found that TVHeadend will not initialize a hybrid tuner…
Maybe it can help a little:

with the current tvheadend package on the store I could not get it to work for now. I’d suggest following the instructions above if you want a working tvheadend.

I have also not been able to get things working from the OSMC Store version of TVHeadEnd server (no default list of Mux, no scanning etc - like others have reported).
However, going through the manual build process worked fine.
So - my suspicion is that the OSMC Store version is not installing some of the needed configuration/support files … such as the default list of multiplexes.

That could be the case, however I also noticed that my adapter show less option and is not recognized in the same way by tvheadend(store version)

My tvheadend was working for more than a month, (I use a version I compiled HTS Tvheadend 4.1-117~gf27ac40-dirty) it has however stopped working around a week agon (last recording successfully done on the 3rd of August).

I’ve been troubleshooting the issue for a while and at one point thought it was the adapter that was unable to scan, used w_scan to scan frequency with the old adapter and nothing. It did the scan but it found nothing, also tvheadent can’t find anything.

I bought a new adapter basd on Realtek RTL 2832U, same chipset os the old card however this is still not workin so I’m trying to figure out what happend.

This is my dmesg

[    3.270805] usb 1- Manufacturer: Realtek
[    5.523480] usb 1- dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
[  219.500800] usb 1- Manufacturer: Realtek
[  219.508413] usb 1- dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
[  219.563503] DVB: registering new adapter (Realtek RTL2832U reference design)
[  219.578720] rtl2832 3-0010: Realtek RTL2832 successfully attached
[  219.578771] usb 1- DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[  219.614699] input: Realtek RTL2832U reference design as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5.7/1-
[  219.614990] rc0: Realtek RTL2832U reference design as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5.7/1-
[  219.654195] usb 1- dvb_usb_v2: 'Realtek RTL2832U reference design' successfully initialized and connected
[ 2069.128009] usb 1- dvb_usb_v2: 'Realtek RTL2832U reference design' successfully deinitialized and disconnected

I could see the adapter in tvheadend for a while but then it got disconnected, anyway even when always connected I can’t tune in to any channel.

Any Idea?

Looks like the new kernel pushed on the 3rd of august broke my DVB-T Tuner.