TVHeadend not talking to PVR client


I’m using OSMC (Kodi 16.1) on a RasberryPi 3. In general I am extremely pleased and everything works very smooth. However, for a few days now I try to get LiveTV working. I use a DVBSky 960 DVB-S2 receiver connected directly to the Pi’s USB port. I’ve installed TVHeadend from the App store (version 4.0) and enabled the Tvheadend HTSP Client under MyAddons. The TVHeadend server is up and running and I can stream LiveTV to other devices (iPhone, Macbook, iPad, etc.) through VLC but also KODI installed on those devices.

However, on the Pi3 itself I’m getting the following error message after booting:
TVHEADEND HTSP CLIENT connection lost. Needless to say, I use the same login credentials on all devices.

On the Pi3 I’ve tried different IP addresses (the “external” IP of the Pi3 i.e., localhost i.e. I’ve created a second user on the TVHeadend server with no login/password as suggested in another post on this forum but none of this seems to help.

The log shows this error message:
11.795101 T:1693447152 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to

Any help would be highly appreciated.


Let’s do some basic test. Access the Pi with ssh and run


And post the output here, should be something like

HTTP request sent, awaiting response… 401 Unauthorized
Username/Password Authentication Failed.


HTTP request sent, awaiting response… No data received.


yes, that’s the output. Here you go:

osmc@osmc:~$ wget
converted '' (ANSI_X3.4-1968) -> '' (UTF-8)
--2017-01-16 20:59:27--
Connecting to connected.
HTTP request sent, awaiting response... 401 Unauthorized

Username/Password Authentication Failed.

osmc@osmc:~$ wget
converted '' (ANSI_X3.4-1968) -> '' (UTF-8)
--2017-01-16 20:59:55--
Connecting to connected.
HTTP request sent, awaiting response... No data received.

Looks good, so suggest to enable debug logging and then once more check the configuration with username/password. Use as the IP
If still failed upload the debug logs

did as you suggested and could reproduce problem - I uploaded the debug log:

Thanks for your help!

Could it be that you have a power problem? Because it looks like sometimes the connection works (as channels will be read).

Hm - will try and connect the receiver to a powered USB hub (is that what you mean - that the USB port is not providing sufficient power?). It’s weird though that using any other device I never have a problem - that seems too much of a coincidence to be true
Anyway, will try.

Well I don’t mean that exactly. I just believe as it seems to work sometimes. That your Pi is not getting enough power and therefore in the moment you try to access PVR from the same Pi you get power drops.
Just a potential source as no other explanation

Dear Alchimist and Fzinken !!

Since I’m in a very close case (I’ve a Volar Green HD TNT Tuner USB stick instead ) could you tell me if you find a solution, a piece of solution or if it is illusory to want to use an TNT USB stick to play HD TV on a Pi3 ?

Thanks a lot guys !

Provide URL from dmesg | paste-log
Also install usb-utils and provide output of lsusb

Fzinken … I’ve restarted my pi and connected the tuner usb, as seen at the end of the dmesg log :

And the lsusb output:
Bus 001 Device 005: ID 13fd:1840 Initio Corporation INIC-1608 SATA bridge
Bus 001 Device 004: ID 1997:2433
Bus 001 Device 006: ID 07ca:3835 AVerMedia Technologies, Inc. AVerTV Volar Green HD (A835B)
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Thank a lot for your help !

‘Avermedia A835B(3835)’ successfully initialized and connected

Looks all perfectly fine. So did you install TVHeadend server from App Store and configured it?

For sure yes !! I did the server config from the IP:9981 as expected I think. I found all the channel that I expected to find (on the server)

And last time I test it I couldn’t activate the TV on Kodi without having very high temperature alert on my pi3.
But … there is a but … today (during we were discussing) I did it and no temperature alert appears at all !! Strange.

But unfortunatly that still doesn’t work because when I try to see a channel TvHeadEnd tells me that there is “no free adapter” … do you see what they mean with this message ?

Fzinken … I still not sure with the procedure but it works !!! I’ve to restart the tvheadend service actually … and now channel are available from the front … so sorry for the inconvinience


I am having the same problem accessing the internal website! I have tried


but can’t get it working.

  1. Check if tvheadend is running sudo systemctl status tvheadend
  2. Check the port sudo netstat -tlnp | grep 99

Nov 06 12:17:06 osmc tvheadend[626]: htsp: Got connection from
Nov 06 12:17:06 osmc tvheadend[626]: htsp: Disconnected
tcp 0 0* LISTEN 626/tvheadend

Assuming this was the output of netstat would indicated that only the HTSP port is running but not the HTTP port.

  1. Did you install TVHeadend from App Store or any other method?
  2. Paste system log to check if anything wrong grab-logs -J
  1. Yes, it was within OSMC.


Also more about OSMC status

osmc@osmc:~$ sudo systemctl status tvheadend

  • tvheadend.service - TVHeadend Server
    Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled)
    Active: active (running) since Mon 2017-11-06 11:43:30 ACDT; 1h 58min ago
    Process: 624 ExecStart=/usr/bin/tvheadend -f -p /run/ -C -u osmc -g video (code=exited, status=0/SUCCESS)
    Process: 282 ExecStartPre=/bin/sleep 10 (code=exited, status=0/SUCCESS)
    Main PID: 626 (tvheadend)
    CGroup: /system.slice/tvheadend.service
    `-626 /usr/bin/tvheadend -f -p /run/ -C -u osmc -g vi…

Well there is not info why the HTTP port is not served
Nov 06 11:43:30 osmc tvheadend[626]: http: Starting HTTP server

Did you already tried to restart OSMC?