TVHeadend (OSMC App Store version)

Hi, I am just trying the OSMC App Store version of TVHeadend (rbp-tvheadend-app-osmc).

Is it me or in general tab there is no ‘Tools’ table?
I mean the one with 'Add DVB network by location" and ‘Map DVB services to channels’.

Thank you.

Where did you find the app store to install tvheadend?

I was about to ask a similar question also, as I assume this is the best or easiest way to watch live TV on OSMC?

With Alpha 3 I also struggled to install a programme guide which showed UK channels such as BBC etc, and would appreciate some advice on the correct way to do this

Thanks. :smile:

[quote=sam_nazarko Project Lead]
As it stands, we haven’t got anything solidly defined. I’m going to allow a mixture of both platform and architecture specific addons as well as generic. So you’ll be free to use any language you like (be it C++ or Python) provided you adhere to GPLv2 or another copyleft license (acceptable licenses TBC)

An app is actually a Debian package with the suffix -app-osmc and prefixed by the platform if it has one. For example, you can install the TVHeadend ‘app’ with:[/quote]

sudo apt-get install rbp-tvheadend-app-osmc

thanks! i did that.

but what version of tvheand is this i get this version.

HTS Tvheadend 0.0.0~unknown

is there also an app for oscam?

i need it for to descramble encrypted channels.

For me it says “Unable to locate package tvheadend”

Should I add something to sources.list to make it work?

did you apt-get update first?

After apt-get update I was able to install the above app successfully.
Unfortunately it did not detect my dbc-c cards and it also said version 0.0.0

I removed it and followed these instructions to install a different package and it works well:

RPi 2 can record all seven channels from the same mux, including 2 HD ones. CPU load is about 40 % of one core.



Somehow, no tvheadend (backend) version I installed seemed to store my settings. I suspect some permission issue is at play here (with the default hts user ?)

Thanks !

There is still the same problem with the appstore-version of TVHeadend: Only EPG and DVR tab. No configuration tab available.

I have compiled tvheadend my self now on RPI2 osmc alpha 4… now tvheadend works for me… tvheadend don’t need to be installed, can run from the same folder where it is compiled… no when the appstore version work… i just install that.

EDIT: RC1 tvheadend still not working from app store… but my compiled version works fine…

Here the same problem with tvheadend.
No configuration tab.
Can i help to fix it?

Some discussion in this thread.

Can now access the configuration tab and scan muxes but it can find no services although it is working in Raspbmc, not sure where to go now.

Tvheadend support also hdhomerun drivers (compiled in the program)
Can somebody tell me how to build an app for osmc?

I’m giving up fiddeling and will wait on the final release. :disappointed: TVHeadend Version from Appstore is not running at all and old 3.4 Version from is working but has access problems with recording on external USB.

Yes, I agree the App Store Tvheadend version appears not to work. Been trying most of the day without luck.

Here guide

Has anyone found this to work direct from the app store? I can get the (very splendid) HarryL workaround to work but really it should be ‘out of the box’ from the app store.
If I use the app store version I can (in the TVHeadend web UI) see the interface and map a network to it… but I don’t get the option to find local muxes… so it all grinds to a halt at that point.
Any help appreciated!

Never been able to get it to work. Waiting patiently and using HarryL’s build instructions until it is fixed.