TVHeadend (OSMC App Store version)

Are there any plans to update the appstore Version of tvheadend in the near future? It is still from April.

The app store Tvheadend is updated , and it’s working…:wink:

1 Like

Thanks a lot!!!

Sweet, just logged in to ask if it was still not functional, awesome news, will test it out tonight

Good news, i have always used the direct tvheadend with the command “apt-get install tvheadend” though you need to add the keys so that the apt search can update its source. This has always worked for me, has anyone tried the one on the osmc app store, last i tried it wasnt very friendly. Also has anyone been able to receive HD channels. Mine works well, though its all SD, and the usb card is HD capable. Need to know if someone knows something i dont know. Please do share.

Thanks.

Still no joy here, unless I’m missing something.
I can select pre defined muxes now (au-Melbourne) but no services get mapped. Guess it’s back to compiled version?

Wait… wait… wait… missed a step, lol, all good now. In case any one else makes my basic mistake, here’s where I went wrong:

under configuration -> DVB inputs -> TV Adapters
select your adapter and in the Parameters window, under Basic Settings, check Enabled
in the Parameters window click Save

under configuration -> DVB inputs -> Networks
click Add to add a network (DVB-T in my case) Name it and choose pre-defined muxes for your area
click Create

Now go back to configuration -> DVB inputs -> TV Adapters
select your adapter and in the Parameters window, under Basic Settings, select the network you just named in the Networks: drop down box.
in the Parameters window click Save

under configuration -> DVB inputs -> Services
click Map All
in the Map Services box, click Map

the services should now start populating (give it a minute), at least it did for me

My mistake was not going back to my TV Adapter and selecting the network I created.

Hope this helps someone, or at least gives them a chuckle at my stupidity lol

@Spasmodean Try the Tvheadend from the Debian store. You wouldn’t need to set up the networks. It’s all preconfigured, all you have to do is pick your closet network and it automatically populates the muxes for you. Saves you so much stress. That’s what I use.

That not a debian feature, but tvheadend… it work in ours to, first add your network and then enable your tuner/adaptor with that network, some tuners can take awhile to “start”… but wait for a few minutes.

-H

My bad, i meant “deb http://apt.tvheadend.org/stable wheezy main” That was all i added to my source list and you wouldnt need to add your network as its all updated automatically. Just by the way are you able to get HD channels

Which version is it ?

I would recommend just to use OSMC version that’s the version we support here…

But if all fails, and tvheadend is not working, try to start over like so via ssh

rm -R /home/osmc/.hts

reboot

Hi guys,
I’ve reinstalled the latest version from the App Store today for use with a HDHomerun Dual network tuner.
The TVHeadend doesn’t come up under configuration -> DVB inputs -> TV Adapters as the guides suggest.

Do I need to tell TVHeadend the IP address of the HDHomerun? I can’t see where to add it.

Cheers,
Alan

it may be worth noting that I haven’t installed dvbhdhomerun as I have read this is already installed into OSMC. is this correct?

cheers

as it is now, you will have to follow the guide that i wrote here about dvbhdhomerun: Here

for hdhomerun you need dvb-hdhomerun software "wrapper".

cd /usr/src

ln -s /usr/include/libhdhomerun/ /usr/lib/libhdhomerun

wget http://downloads.sourceforge.net/project/dvbhdhomerun/dvbhdhomerun_0.0.15.tar.gz

tar zxvf dvbhdhomerun_0.0.15.tar.gz

cd /usr/src/dvbhdhomerun-0.0.15/userhdhomerun
make
make install
run like this 
/usr/local/bin/userhdhomerun -u osmc -g video -f

an actual userhdhomerun package is coming, an easier way…

only the kernel module is in OSMC…

awesome, thanks Harry,
I’ll give that a shot tonight.

I’ve just put a fresh OSMC image on the RPi and installed the TVHeadend Server.
Using SSH, I’ve a followed what you’ve written (but added sudo -s at the start), but have the following issues.

When I type “make”, I get “bash: make: command not found”
When I type “make install”, I get “bash: make: command not found”
when I type “/usr/local/bin/userhdhomerun -u osmc -g video -f” I get “bash: /usr/local/bin/userhdhomerun: No such file or directory”

I’m not what you’d say experienced with Linux at all, so I’m probably stuffing something up.

After doing this, I’ve tried the whole guide on the link. Similar issues there.
do I need to reinstall the SD card, then install the App Store version again, and follow the whole guide, or just the exert you’ve pasted?

thanks

I’ve just followed the guide on your link, and when I get ./configure for the TVHeadend it comes up with this.

root@osmc:/usr/src# cd tvheadend
root@osmc:/usr/src/tvheadend# ./configure
Checking support/features
  checking for cc execinfo.h ...                    ok
  checking for cc -mmmx ...                         fail
  checking for cc -msse2 ...                        fail
  checking for cc -Wunused-result ...               ok
  checking for cc getloadavg ...                    ok
  checking for cc atomic64 ...                      ok
  checking for cc lockowner ...                     ok
  checking for cc qsort_r ...                       ok
  checking for cc stime ...                         ok
  checking for cc recvmmsg ...                      ok
  checking for cc sendmmsg ...                      ok
  checking for cc libiconv ...                      fail
  checking for cc libdvben50221 ...                 fail
  checking for py module gzip ...                   ok
  checking for xgettext ...                         fail
ERROR: WARN: no gettext binaries found
root@osmc:/usr/src/tvheadend# make
Makefile:23: .config.mk: No such file or directory
Makefile:559: /support/.mk: No such file or directory
make: *** No rule to make target '/support/.mk'.  Stop.

in the link there is some packages there is needed.

apt-get install git build-essential pkg-config libssl-dev dvb-firmware-osmc dvb-tools libdvbv5-0 liburiparser-dev liburiparser1 libavahi-client-dev zlib1g-dev libavcodec-dev libavutil-dev libavformat-dev libswscale-dev libhdhomerun-dev libhdhomerun1 hdhomerun-config cmake

now you can compile :wink:

Hi there,

I’m new to OSMC and Live TV so it might be I’m a bit dizzy but as I read it: “Tvheadend is a TV streaming server” and HDhomerun does just the same.
So why oh why do i need both of them?

I installed TVHeadend from the OSMC App Store an it worked so far as it found channels which i could map etc.
So when i access tvheadend from my windows Laptop by :9981 and click an “Play”

(Stole the Image from this How To [Obsolete] Instructions for Viewing Live TV by EMJB)
I get a m3U File which makes Windows Media Player showing me the Stream.

But when i try to Play Live TV in OSMC it says: “No Input Detected”.

What am i getting wrong?

Thanks a lot in advance.


Der Deifi