TVheadend problems

Am trying to migrate my TVheadend service from an LE Pi (which works fine) to a Vero 4K. I am using a DVB-T stick and channel scan works, I can get BBC HD etc from my London transmitter so basic set up is ok. Two problems I’m stuck on:

Access to the TVheadend web page consistently refuses my osmc/osmc log-in credentials - sometimes it lets me in, but often it does not. I just did a completely clean install, and still have the issue. Not even being able to access the web config page in a reliable way is a bit of a problem.

Although there is some EPG info coming through, the OTA EPG download performance seems to be really poor compared to my LE Pi. When I first set this up on the Pi, the EPG was built pretty quickly, via latest OSMC, EPG download is very flaky and much of it is missing (I’ve done the clear data via Kodi). I think the LE Pi and Vero are running the same nominal version of TVheadend.

Can’t seem to avoid a start-up warning from the TVheadend client that the server is not available when booting the Vero - eventually it realises the server is available, but with the same configuration I don’t get this warning on the LE Pi.

Would like to get these glitches fixed if anyone can help. Thx.

The default username / pw is osmc:osmc.

Try giving it a little while to settle. If you kept it on for a bit, like the Pi, it should be fine. I suspect the Pi had a higher uptime.

Try enabling Wait for Network under My OSMC.

thanks, but how does that help? uname = osmc, pw = osmc is what I’ve been using, it sometimes works, sometimes doesn’t. I should switch both to osmc:osmc ?

Ive had this problem before, not just using osmc, on other platforms running TVHE as well.

Clearing stored data from the browser for TVHE seems to solve it for me.

Edit: (the login issue)

Maybe, after several hours, the SD channels look ok, HD ones have almost no EPG details at all. I may leave it overnight to see if that changes. I really don’t recall it being this slow with the LE Pi.

We haven’t changed anything that would impact EPG speed.
Did you perhaps have a web grabber enabled?

You could also try copying the TVH directory entirely to the Vero to ensure identical settings. But the versions must be the same.

Sam

@ac16161 Regarding EPG update, compare the “EPG scan time-out” value of both machines whether they are equal? I assume you’re using the same DVB-T stick.

(This is an example with a DVB-C twin-tuner, so your necessary time-out value could be different.)

A few more details in case helpful.

LE Pi: TVheadend version 4.2.6-7. I have no options in the interface to switch views between basic/advanced, everything is fairly advanced, except that in the EPG Grabber screen, there is no panel with EPG scan time-out settings.

Vero: TVheadend version 4.2.6. EPG Grabber scan time-out currently set to 600 (not something I’ve touched).

This is the stick I am using (I’m swapping it between devices, so it is literally the same stick)
https://www.amazon.co.uk/gp/product/B01BU4UIOW/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

LE Pi TVH reports this as a Silicon Labs Si2168 : DVB-T #0

Vero TVH has Silicon Labs Si2168 #0 : DVB-T #0 (entries copied from TVH)

And why not drastically reduce this time-out and start a “trigger ota epg grabber” for a test? 600 means the grabber tries 10 minutes to catch epg data from a mux without epg data before switching to the next.

Please bear in mind I am using the “out of the box” settings here. I did as you suggested and reduced the timeout to 30s, here is a representative extract from the TVH log - in this case for my main HD mux (BBC 1, 2, ITV, CH 4) - this is consistent with lack of EPG for these channels - whereas on my LE Pi, it just works. Oddly, these channels do show up in my mapped services and they play just fine - it’s only the EPG that is missing.

2018-09-25 19:40:23.485 mpegts: 545.833MHz in DVB-T Network - tuning on Silicon Labs Si2168 #0 : DVB-T #0

2018-09-25 19:40:23.485 subscription: 0014: "epggrab" subscribing to mux "545.833MHz", weight: 4, adapter: "Silicon Labs Si2168 #0 : DVB-T #0", network: "DVB-T Network", service: "Raw PID Subscription"

2018-09-25 19:40:58.485 epggrab: EIT: DVB Grabber - data completion timeout for 545.833MHz in DVB-T Network

2018-09-25 19:40:58.485 epggrab: PSIP: ATSC Grabber - data completion timeout for 545.833MHz in DVB-T Network

2018-09-25 19:40:58.485 subscription: 0014: "epggrab" unsubscribing

Pi running LE and Vero running OSMC will use different kernels and tuner modules.

Can you test OSMC on a Pi and see if it improves things? If so, then it’s just a case of us backporting some DVB fixes that might be causing this. If it stays the same, maybe we need to look at TVH.

Thanks

Sam

This should not need any tweaks to TVH. My setup is identical to yours, except I have the August T210 which has the same guts as your MyGica T230.

Have you solved the login to the webui problem, yet? If not we can compare my config files with yours to see what’s up.

thanks for further suggestions. I can log in to the web config page, it’s just intermittent that the credentials fail.

I have an OSMC Pi in a cupboard, I can dig it out tomorrow and see how it does with TVH. Will report back then.

Curiosity got the better of me. OSMC Pi has the same problems. EPG built for most SD channels quickly, nothing for some SD and all HD channels although HD channel ID’s are present and they play. Looks like I’ll be keeping an LE box running for a little while yet.

Thanks for letting me know. Sounds like a TVH bug. I’ll check what version of TVH LE ships and we’ll resolve this for you.

It might take a day or two as it’s busy at the moment.

FYI, I have only the Freeview OTA EPG enabled. I recall it did take a while a while to get the EPG populated last time I installed TVH, but can’t remember whether I had to do anything special to make that happen (eg disabling other EPG feeds).

Just chiming in here to let you know I also had EPG missing data on my RPI with version 4.2.6.

Noticed I hadn’t this problem before so I downgraded to version 4.2.4 and the EPG worked fine.

So you may try downgrading to see if it helps.

Thanks, how do I install a downgrade?

It’s better for us to upgrade and see if that resolves things.

Sam

I was just looking again at the set up on my LE Pi. With LE, TVH server is a stand-alone add-on, that users can download separately just like any other add on. I checked, and several previous versions are easily available to me should I wish to downgrade due to a regression in functionality. But with OSMC, TVH server is tied in through the app store (that isn’t really an app store, but that’s a separate discussion). Why is TVH server tied to the OSMC version in this way? Could it not be broken out to allow independence in terms of version? At present, to downgrade TVH, I need to downgrade the whole of OSMC, mark TVH server to hold via SSH, then upgrade OSMC again? Seems a lot of hassle to address something that with LE I can accomplish in a few seconds. Is there an easier way to downgrade TVH in OSMC? And if not, does this suggest that maybe the implementation needs a re-think?