TVheadend problems

Lets try this then:

tar -czf ac161.zip /home/osmc/.hts and send us the file ac161.zip.

As I suspected, you have not enabled the Freeview EPG grabber. Mine looks like this:

I understand XMLTV works as well, but I’ve not tried it.

Oh, and you must click the Save button after any changes. Clunky.

Thanks for looking at this further. Your screenshot is showing tabs that my TVH does not have, eg mine does not have a tab for EPG Grabber Modules:

Go to General and set user interface level to Expert.

Extended the GUI as advised and enabled the Freeview EPG grabber on high priority, it’s made no difference. I did the Clear data in Kodi, I’ve reinitiated a scan, increased the timeout, and as before, the HD channels have no EPG. I’ll leave it running in case it settles down.

Since as noted above my OSMC Pi has the same problem, but my LE Pi just works out of the box, is this perhaps an OSMC issue with my DVB stick?

We build v4.2.6. I don’t know which version LE uses?

It seems like an issue with the TVHeadend version we ship (latest 4.2 stable release).

I doubt it. Maybe LE have turned on Freeview EPG by default. Your channels should come up in time - but you should also reset the timeout to 600.

So I came back after a couple of hours, I had already raised the timeout back to 600 and once again, nothing. I was hoping to use a Vero 4K as the TVH server and as a local client, but for now will stick to my LE Pi as a headless TVH server and the Vero boxes will all be clients. If this can be fixed at some point that would be great, appreciate the OSMC team is super busy at present.

I’d love to fix it but I just can’t reproduce it.

As a last resort, I would rename the .hts directory on vero then copy the whole .hts directory across from the working LE device to the vero.

Having said that, I think a Pi as TVH server makes a lot of sense, especially if you have more than one DVB stick. And you can run TVH under any OS you like.

Also can’t reproduce this here.
Checked LE and there is no difference with the TVH they ship.

Sam

@ac16161 I tested some things and here the “EPG grabber modules” are removed, if the individual User interface level is wrong/not set to expert level.

So,

  1. follow @grahamh’s advice to set the general user interface level to expert
  2. goto Configuration->Users-Access Entries and check/edit the user osmc
  3. set ALL flags for
    Change parameters
    Streaming
    Video recorder
  4. Also set HERE the User interface level to expert since a wrong setting lets fade out the EPG grabber modules in my TVheadend’s GUI.

Here is a screenshot of TVH from my LE Pi. We can see that unlike the OSMC build, the Freeview grabber is enabled by default, although unfortunately enabling it on my Vero did not fix the EPG issue. Also, there are some slight differences in the interface: note that there is no “Priority” parameter for the grabber as per the screnshot @grahamh posted yesterday. My next step is to see if I can copy over the .hts folder from the LE version to see if it fixes it.

Thanks for sharing the LE settings. I think your best bet is to uninstall TVH, wipe or rename /home/osmc/.tvh, and reinstall. The sequence that should work is set out here: Watching live TV with a USB DVB tuner or network TV tuner

1 Like

I did a clean reinstall of TVH, and immediately disabled all EPG grabbers and enabled only Freeview - the result: an essentially empty EPG. It looks like the Freeview grabber is not working with my stick under OSMC. Ho-hum, have spent a lot of time on this now, maybe one day the mystery will be solved. In the meantime, have the LE box to fall back on.

Well, although the EPG scan did nothing for an awfully long time, at some point overnight it kicked into action and I have a full EPG. I do wonder if LE’s TVH is better set up to work from the get-go, as I’ve observed some little configuration differences here and there, but if my Vero settles down as a reliable TVH server I’ll be pleased.

2 Likes

Yes, I think it was the same for me on first install but I didn’t think it took 2 days. I haven’t had any issues since.

What are the configuration differences?

Sam

there are some differences already noted in this thread. LE TVH required no configuration of the Freeview EPG grabber, and with the GUI view set to expert, there are still some slight differences (OSMC has a priority field per grabber that does not show in the equivalent tab on LE). There are some other small differences I’ve seen, such as whether periodically save the EPG to disk is set. Anyway, it’s working now, but was much more time consuming than I recall when installing TVH under LE. I’m not convinced that the Trigger OTA EPG Grabber function is working correctly as the log just shows time-out messages, but it seems to sort itself out eventually.

It could be something stupidly simple. I was going to compare the settings for the time intervals for TVH to grab the EPG and the time intervals for Kodi to query TVH for the EPG. The intervals can be quite long. There is also a setting in Kodi that says don’t check EPG while watching live, so if your TV is on 24/7 it would never get the EPG. And a setting to trigger the EPG grab on start-up.