Tvheadend status and versions

Just FYI:
4.0.7 works but has issues FFing in some streams
4.3 works but crashes when I try to record
4.2.4 works, but cannot watch recodings on xbmc
4.2.5 crashes in the CAM descrambler

I’m using TVHeadend 4.2.4 from the OSMC store and Tvheadend HTSP Client 3.4.27 for viewing on the same OSMC device, a Vero 4k.
What add-on do you use with what issue? Can you provide an example? I could try it in my environment.

Same device, Vero 4k and same client, but I am running TVHeadend on separate hardware. With 4.2.4 everything but watching redorded material over HTSP works. When I try I get:

2018-01-13 11:47:04.802 [WARNING] htsp: [ | Kodi Media Center ]: failed to serialize data

Mhhh, typically there should be another error/info before.

By this small information I nevertheless would check the user rights: For the client add-on you have had to configure a user+password. AfaIk this user is the one you find in the tvheadend web interface on the remote machine. Perhaps this has not the required rights to access the files on the remote system.

Web interface -> configuration -> Users -> Access Entries

Tried that. But as I said. That same thing works fine with 4.0.7

You need to give your user some explicit streaming parameters in their profile which 4.0.7 seemed not to bother with IIRC.

Ah. So create a special user in tvheadend and set parameters correctly? There is a bewildering array of settings there:

I gave it all

You definately must have failed view selected. That means you can see recordings that have ‘failed’ which for some reason includes recordings you have stopped manually.

OK. Must try again then. But FWIW, I can see all recordings, play them, but not schedule a new one.

The recording crash was a bug in 4.3. It has been fixed now: Bug #4846: 4.3 crashes when trying to add a recording - Tvheadend

So we don’t know what the issue was with 4.2.4? I for one cannot reproduce that. Recording and playback works as it should.

Same here even with server and HTSP client running on different OSMC devices. Tried to get out some more infos+understanding out of So, does it mean the user and password were not set in the HTSP Client configuration on OSMC?

My issue might have been that I used a 4.3 config with 4.2, but that made my tvh crash. 4.2.5 works now. And yes, no user/password entered.

They don’t believe in backward compatibility but keep messing with the format.

That is true. They should have a check that warns. Error was mine anyway as I played with too many versions as once. I never bothered to test more with 4.2.4 as 4.2.5 worked just fine.

I am still on 4.0.7, but will upgrade to 4.2.5 soon and then 4.3 when it is stable. Currently everything works there, evem Oscam, but it is still regarded as “development”

According to TVH, the odd-numbered minor versions are unstable by definition. So 4.2 is the LTS and 4.4 will be the next LTS.

The code fix in 4.3 as that they did not account for the scenario where the user and/or passwords were null.

But if you would have set a user/password on the Tvheadend HTSP Client configuration within OSMC you would not have all this problems at all?

Reason I ask: I’m the author for this how-to article and would like to understand whether I should change anything to prevent others to step into this trap.

Oddly that did not work for me and now I have the fixed code anyway.