TVHeadend won't install from App Store - solved(ish)

Hi - thought I’d share this as it may solve some pain… also may be a dupe (so feel free to delete) but couldn’t see anything. Also I am of the copy & pasting level so I may have steps that aren’t needed - feel free to edit :slight_smile:

So basically trying to install TVHeadend on Pi3… go to app store and install is greyed out. Check internet connection etc etc… then head over to TVHeadend site and see this

Repository Status

(!) 10/17/2018:
Unfortunately Bintray have (once again) blocked us - the reason being is that our unstable packages are not classed as release artefacts - we’re working on a more concrete solution! For the moment please download the packages from here.

so… think I need to manually install TVHeadend… so to do that

  1. SSH into your OSMC box - lots of How To’s exisit for that
  2. Install TVHeadend from a different source
  3. Run configuration thingy

Then the real fun begins…

so to do 2 & 3

Some quick stuff that I learnt - run as ‘sudo’ - runs as root and sorts permission issues

  1. Install keys (Presume gives permission to install)

sudo apt-key adv --keyserver hkp:// --recv-keys 379CE192D401AB61

  1. Choose build type and repro - this is Pi version (I think!)

echo “deb Index of /stable/ raspbian-stretch main” | sudo tee -a /etc/apt/sources.list.d/tvheadend.list

  1. Update APT and Install

sudo apt-get update

sudo apt-get install tvheadend

If when you do sudo apt-get update it complains and says something about not having https transport then run this command

sudo apt-get install apt-transport-https

which presumably allows it to use https/http (it installs both)

Once installed you can then run the config

sudo dpkg-reconfigure tvheadend

(its a minor thing but when it asks you (on a blue scree) for a password for the account you are creating it gives no indication you are typing! Typing my password in twice meant I had to do a full re-install as I couldn’t find out how to change it once set!

and restart afterwards…

sudo service tvheadend restart

If you want to delete and start again run this

sudo apt-get purge tvheadend

If it all works you should be able to login to the web interface using something like

Where 192.blah.blah.blah is your Pi’s IP…

I hope these are useful! I also ran a bunch of other commands to install stuff - I think/hope these aren’t useful but if the above doesn’t work for people I’ll try and dig out the other commands…

Some useful links

Now I have to get it all working before the Strictly Result Show is on tonight :wink:

TVHeadend is installed via App Store from an OSMC server.
So you could install it from App Store. If this didn’t work, output of sudo apt-get install armv7-tvheadend-app-osmc would be interesting.

This is what I get

osmc@osmc-Waldo : ~ $ sudo apt-get install armv7-tvheadend-app-osmc

Reading package lists… Done

Building dependency tree

Reading state information… Done

E: Unable to locate package armv7-tvheadend-app-osmc

osmc@osmc-Waldo : ~ $

Here is a screen shot of the app store showing the greyed out install link
I’ll try to attach a video too - it is highlighted and then greys out before you can click on it
I am working off a slightly older version of osmc just cos I tried that to see if an older version would work - the current release is doing the same thing. I am burning images using Etcher and image downloads as the build app just would stick on formatting disc when booting for the first time…

What is the output you see when running sudo apt-get update from command line?

Hi - I get this

Hit:1 stretch/updates InRelease
Ign:2 Index of /debian stretch InRelease
Hit:5 Index of /debian stretch-updates InRelease
Hit:6 Index of /debian stretch Release
Hit:3 Index of /osmc/osmc/apt stretch InRelease

Ign:4 Index of /stable/ raspbian-stretch InRelease
Get:7 Index of /stable/ raspbian-stretch Release [470 B]
Get:8 Index of /stable/ raspbian-stretch Release.gpg [455 B]
Ign:8 Index of /stable/ raspbian-stretch Release.gpg
Reading package lists… Done
W: GPG error: Index of /stable/ raspbian-stretch Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 89942AAE5CEAA174

E: The repository ‘Index of /stable/ raspbian-stretch Release’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Tho… I have been trying to get TVHeadend installed so error may be due to that - As I said earlier - I am a bit of a copier and paster - so may well have got some stuff crossed over at some point - but the fresh install of OSMC and greyed out app store is without any of my messing about…

I have got it working - but can’t now get it find any TV… I’ve got the adaptor working, the network set (tried both Crystal Palace & Oxford) and while I get Mux’s they don’t scan :frowning:

Sorry - think I replied to the wrong post AND it would only let me past 5 links at a time so I had to split my reply…

I’m trying to understand why you are not able to make the app store download, I’m not concerned about the failed tvheadend repo. I would simply comment out (place a # at the start of those lines) that repo in your sources.list. Prior to your attempt, had you tried to update OSMC? Did you ever use apt-get update prior to attempting to apt-get install armv7-tvheadend-app-osmc? I suspect, if you never updated the system, then apt-get update (which would be run in the update script from MyOSMC manual update) has never been run and we would expect that the tvheadend package would not be found.

I suspect that now that you have run the update command, sudo apt-cache search armv7-tvheadend-app-osmc will return as expected like below.

osmc@vero4k:~$ sudo apt-cache search armv7-tvheadend-app-osmc
armv7-tvheadend-app-osmc - TVHeadend for OSMC

While your workaround has worked for you, it’s not recommended by us as it creates a situation where some might expect us to support tvheadend that was installed in a less graceful way (compared to our provided method) that includes a configuration that we didn’t optimize for OSMC systems.

So now, is the option to install from the app store still greyed out and un-selectable? Are you running a Leia 18 build or the default 17.6?

Hi, I deffo don’t want to cause confusion so feel free to delete thread once sorted :slight_smile:

So that I know nothing I have previously done is causing the issue I have just re installed from scratch onto my SD card using the Mac installer and the latest OSMC build (August 2018 2018.08-2). Kodi 17.6 confirmed on settings screen. Put the SD card into Raspberry Pi3 let it do its stuff, OSMC boots up fine. Go into App Store, TVheadend and install greyed out, re-boot, install still greyed out. (Install is greyed out for all AppStore items - Samba etc)

I have done nothing SSH wise, other than login and reboot (my better half is trying to watch TV, so trying to do as much as possible without stopping her!)

For what it is worth when the individual app store page loads (TVHeadend, Samaba etc) the install link momentarily looks active (white) but dims straight away before it can be clicked on.

So now it is a totally fresh install with the same issue. If you let me know any steps to help diagnose I am happy to try them…

Ok, try sudo apt-cache search armv7-tvheadend-app-osmc. If it returns blank, then it should confirm my suspicions. After that, you can try sudo apt-get update && sudo apt-cache search armv7-tvheadend-app-osmc. This should then return the package name, indicating that it is now available. You can then check in MyOSMC to see if installation is now possible or install from command line with sudo apt-get install armv7-tvheadend-app-osmc. You can accomplish all of the SSH commands without disturbing any media currently playing. If all of this is successful, it might be wise to then sudo apt-get dist-upgrade && sudo reboot to ensure the system is now entirely up to date, though as you can see, this procedure will restart the box.

So this is what happened…

> **osmc@osmc-Ethelbert** : **~** $ sudo apt-cache search armv7-tvheadend-app-osmc

(Blank as you suspected)

> **osmc@osmc-Ethelbert** : **~** $ sudo apt-get update && sudo apt-cache search armv7-tvheadend-app-osmc

Ran OK and ended like this

> Get:21 stretch/non-free Translation-en [80.6 kB]  
> Fetched 13.5 MB in 16s (828 kB/s)                                              
> Reading package lists... Done
> armv7-tvheadend-app-osmc - TVHeadend for OSMC

Went in to My OSMC/App Store - still greyed out

Installed from command line - installed AOK

No when I go to My OSMC/App Store TVHeadEnd says installed under it as expected and if I click in then Uninstall is active.

However - If I go into any of the other apps they still can’t be installed - Samba for example.

TVHeadend has installed OK - I can get into the web interface and this time it has installed 2x SONY demodulators as well as the Realtek DVB-T.

Maybe needs a reboot before all MyOSMC app store features are seen as available.

Edit: or possibly, force a manual update of the system from within MyOSMC so that it’s logic is made aware of these availabilities!

I’ll give that a go and let you know how I get on - Thanks for all your help!

Hi - finally got some time to play around again…

So I re-burnt my SD card with Feb 2017 (2017.02-2) and App store works as expected and I’ve installed TVHeadEnd and Samba.

So I then re-burnt the latest version (Aug 2018) - and now it works (install Samba, Install TVH) through the App Store… I don’t get it!? The highlight state on the install button is super hard to spot, but I really don’t think it is just down to that?!

We’ll fix the highlight colours.