UHD 24p broken in 1080 with Feb update

Yep - I just did a full power-down of the entire system, still no joy. Must surely be the OSMC update that has broken this.

I had the problem too.
“Also allow resolution switch” didn´t fix it.
What fixed it was a cold reboot of the Vero4K and all the other devices in the chain.
Might really be a handshake issue directly after the update.
Now it works fine again, but only when “Also allow resolution switch” is turned on, don´t know if thats on purpose.

Sam said it should normaly be turned off by default. It’s strange that the correct 4K 24p output is only working when the setting is turned on.
So, you’re using a UHD TV or also a 1080p TV where the downscaling of 4K 24p content didn’t work properly (only to 1080p60) after the update?

I´m using a UHD Sony from 2016 and a 4K Capable AVR.

Poor color and lack of brightness. I noticed the very same when i recieved my Vero 4K. Not sure what to do. I first thought color space was wrong or something but my skills/time sorting out is limited.

Ok… So, with “Also allow resolution switch” switched off neither downscaling UHD 24p content to 1080p24 is working correctly, nor is native resolution playback of UHD 24p content.

Was 4K 24p content played back as 2160p60 on your setup before your got it fixed or as 1080p60?

Isn’t this more related to another thread… This thread is only about wrong framerate playback of UHD 24p content. This one e.g. is about color space output:

Had time to test on my own equiment (1080p) now… Here I can’t get proper playback of 2160p24 material to work at all. No matter what the setting “Also allow resolution switch” is (on or off), 2160p24 is always downscaled to 1080p60. No 24p playback of UHD content possible. For me, UHD playback is completely broken when it comes to framerate.

I also tested @inspectah’s approach:

No luck here!

You need to post a full set of logs with debugging enabled then.
I think I’ll revert the downgrade resolution patch for now, as it seems to be causing too many issues.

Of course… Just had time for a short test, will do that asap.

So, the logs:

First one with “Also allow resolution switch” enabled: http://paste.osmc.tv/iqahirimul

Second one with “Also allow resolution switch” disabled: http://paste.osmc.tv/iyasagarod

Both times I played a 2160p24 video first (both times played back as 1080p60) and then a 1080p24 video afterwards (which played back correctly as 1080p24).
For resolutions below 1080p, everything worked as expected:

  • “Also allow resolution switch” enabled: e.g. 720p50 -> 720p50
  • “Also allow resolution switch” disabled: e.g. 720p50 -> 1080p50
====================== Display Cap =================== g0gjk991
480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz*
720p50hz
1080i50hz
1080p50hz
1080p24hz

Your device is not receiving an EDID that shows support for 4K video modes.
This wouldn’t be affected by any Kodi patches.

Sam

Of course, it doesn’t. My setup is a 1080p setup :rofl:

It was working before. The very file I tested with now did playback properly downscaled to 1080p24 before the update (I watched the whole movie before the update on my Vero 4k and my 1080p setup).
And this thread is titled: UHD 24p broken in 1080. My setup is a 1080p setup… What’s the problem then?

And above, some others reported exactly the same issue on a 1080p setup. :wink:

Sorry – reading too many posts.

Yes, looks broken.

I’ll kick off a build with this patch reverted and it will be ready in staging in an hour.

No problem :+1:t2::wink:

Just give us a small note here, please. Thanks for the effort, Sam!

Hi

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Fixed! 24p playback of 4K files now works again.

Now if we can get the white-point sorted out in the HDR>SDR conversion, I have several TV’s that are waiting for a Vero 4K.

And of course, thank you for the prompt action to work on this.

Couple of follow-up observations:

  1. Switching my TV’s picture mode to Dynamic and dialling down the colour a little recovers the lost brightness with 4k mkv’s and overall gives a very watchable picture. And films that have white-on-black credits actually show the credits in white.

  2. Because I’ve been holding back on 4k, waiting for the HDR standards to settle down, I’ve not previously had opportunity to check out the audio side of UHD discs. Now that I have a few titles, I’ve been checking out bit rates vs corresponding blu-rays. On some titles, the bit rate is similar (it may even be the same audio track), but for some, the UHD audio has a massive increase in bit rate compared to the blu-ray (Batman Begins, The Dark Knight, Blade Runner 2049). Any my goodness, is the difference audible (I only run 4.0, but the difference on the aforementioned titles is quite noticeable).

  3. So far, playback seems to be holding up without stuttering, even on 4k titles with very high bit-rates. I mount via Kodi/nfs so that database paths are consistent across devices, server is a Synology NAS.

Working here again as expected! :+1:t2:

This is partly a reason for me to watch UHD rips… The audio → also those Atmos/DTS:X mixes we only get on the 4K release. :slightly_smiling_face:

Generally, the UHD and BluRay from the same package have exactly the same 4K source transfer, so it’s pretty easy to re-mux the better audio with the BluRay video. I do the reverse and add commentaries back to the 4K video. Apparently, if you want to watch UHD eye candy, you don’t want to listen to the F/X guys talking about how they created it.

I’m testing UHD video mostly to see how the Vero 4K performs when having to decode that and then doing things with the Titan skin (which is much more performance intensive than the OSMC skin).