UHD 24p broken in 1080 with Feb update

Anyone else finding that UHD 24p is now forced to 60p in a 1080 environment? If the source is 1080/24 I get 24p playback just fine. Downstream of the Vero is a Marantz AVR and a Panasonic TV. I’ve checked that any internal conversion by the Marantz is disabled. Previously, UHD 24p played at 1080/24 correctly, albeit with poor colour and lack of brightness.

Make sure you have Also match resolution disabled and post a debug log if it persists

1 Like

match resolution is disabled. Will do a clean install of latest OSMC and try again.

Clean install and 24p still broken for UHD mkvs that play in 1080/24p on previous OSMC version.

By the way, have done several clean installs now of OSMC - every time I change skin during set-up to Classic, and every time the skin changes, but does not survive the first reboot when the OSMC skin comes back. At this stage, changing skin does become permanent after subsequent reboots. A minor niggle, but would be nice to fix.

A full set of debug enabled logs would be useful here.

Thanks! :wink:

Just tried this and can’t reproduce. Can you confirm you were installing the latest version of OSMC?

I have attempted to submit a log, not done so before so not sure if I did so correctly.

You have to provide us the resultant URL. It is clearly explained in the link.

In relation to skin change not sticking during set-up, this has happened with all installs on the Vero 4k. It happened “out of the box” (can’t recall the version, think it was a few months old), then on the December build which I installed via a USB stick, then again when I reinstalled last night.

By the way, clean installs occasionally are interrupted with the unhappy face and a spontaneous reboot, then all seems to work. It’s these features that generally create a somewhat flaky impression of OSMC, though I’m really keen for Vero 4k to work - if I can get it running well, I’ll be replacing my other Kodi devices as well, but for now they are staying put.

I have just tested and can’t reproduce a problem where I’m unable to switch skin.

I suspect the logs will show us the issue.

Clearly? I think the instructions are a bit poor. Extract below just stops. Where is the instruction to note the link?

Providing diagnostic logs

Logs are needed so we can identify problems quickly. A full set of logs should be uploaded with ease via My OSMC.

Before uploading any logs, you should ensure that Debugging is enabled in Kodi. This can be done by going to Settings -> System -> Logging -> and selecting Enable Debugging. You should then perform a reboot of your device and perform only the minimum actions required to replicate this issue so that it is easy to identify the cause of the problem.

If you are using the default OSMC skin, then My OSMC will be accessible via your Home screen. If you are using Confluence then it will be available via the Settings sub-menu. For other skins, My OSMC can be found via the Programs section. Before doing so, you should read the rest of this article.

After opening My OSMC, navigate to Logs.

Sorry about that. I have improved the wiki based on your recommendation! Thanks!

After opening My OSMC, navigate to Logs. Using this method will result in a URL link that you should provide so that others may be able to view.

Thanks, I appreciate the responsiveness of the support on this forum.

I’ve just played back 24p content via UHD and 1080 mkv files, link is https://paste.osmc.tv/ipalinoxib

Just to note again, 24p playback was perfect on these files before updating OSMC yesterday, now only the 1080 source plays in 24p in my 1080 system.

Can you verify if I have done the log correctly, if so I will get on an post a log of the failed mysql set-up via the GUI.

Very strange… When you playback the 4K file (4K/Star Trek 2009.mkv), it’s recognized as 4K 23.98p:

12:38:23.552 T:3447714560 DEBUG: CRenderManager::Configure - change configuration. 3840x2160. display: 3840x2160. framerate: 23.98. format: AMLCODEC

But the picture mode chosen afterwards is 1080p60:

12:38:23.595 T:4076253776 DEBUG: Resolution 1920x1080 @ 60.00 - Full Screen (16) not a very good match for fps 23.976 (weight: 0.166), trying 2:3 cadence
12:38:23.596 T:4076253776 NOTICE: Display resolution ADJUST : 1920x1080 @ 60.00 - Full Screen (16) (weight: 0.001)

Playing back the 1080p file (BR Films/Star Trek/Star Trek.mkv), it’s also recognized correctly:

12:38:58.292 T:3489481472 DEBUG: CRenderManager::Configure - change configuration. 1920x1080. display: 1920x1080. framerate: 23.98. format: AMLCODEC

And then switches to 1080p23.98:

12:38:58.321 T:4076253776 NOTICE: Display resolution ADJUST : 1920x1080 @ 23.98 - Full Screen (26) (weight: 0.000)

Does this happen reproducibly with all of your 4K files?

24p playback of 4k mkv’s was fine until I installed the OSMC update last night. Now all of them (I only have 12 or so) play at 60p.

Possibly related to:

Try changing the options there.
It may be an idea for us to revert the downgrade resolution patch.


Can I just check - is there an action for me here? I’ve tried the new options in all possible combinations, nothing gives me 24p playback for 4k content.

It doesn’t work, even if you disable ‘Also allow resolution switch’, under Settings -> Player -> Video?

1 Like

Checked your logs in a bit more detail as I got some time.

====================== Display Cap =================== g0gjk991

Your TV isn’t advertising support for 4K to Vero 4K.
Has something changed in your setup recently?


It is broken for me too. installed the update 5 minutes ago and now 4k 24p is forced into 1080/60p.

I changed nothing else obviously.