Unable to compile driver on kernel 4.4.27-7 for rtl8723bu

I would like to use bluetooth streaming from my RPi3 to my Creative Jam headset. Internal integrated wifi/bluetooth chipset on RPi3 is unstable on streaming, in fact no mather i do it is randomly drop connection without a reason during streaming and there is no other way to connect headset again without restarting osmc… So i bought USB dongle Mantistek WA150 which has wifi/BT 4.0 inside with chipset rtl8723bu. This chipset has no native support on osmc so i tried to compile it. The main problem is that i did exactly the same steps for preparing (compilation prerequisites) like on this post:

(ofcourse i changed everything what it need to be changed for this scenario)

with this git source and build steps for this specific realtek chipset:

but it endup with this result:
rtl8723bu$ make
make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- -C /lib/modules/4.4.27-7-osmc/build M=/home/osmc/rtl8723bu modules
make[1]: Entering directory ‘/lib/modules/4.4.27-7-osmc/build’
CC [M] /home/osmc/rtl8723bu/core/rtw_cmd.o
CC [M] /home/osmc/rtl8723bu/core/rtw_security.o
CC [M] /home/osmc/rtl8723bu/core/rtw_debug.o
CC [M] /home/osmc/rtl8723bu/core/rtw_io.o
CC [M] /home/osmc/rtl8723bu/core/rtw_ioctl_query.o
CC [M] /home/osmc/rtl8723bu/core/rtw_ioctl_set.o
CC [M] /home/osmc/rtl8723bu/core/rtw_ieee80211.o
CC [M] /home/osmc/rtl8723bu/core/rtw_mlme.o
CC [M] /home/osmc/rtl8723bu/core/rtw_mlme_ext.o
CC [M] /home/osmc/rtl8723bu/core/rtw_wlan_util.o
CC [M] /home/osmc/rtl8723bu/core/rtw_vht.o
CC [M] /home/osmc/rtl8723bu/core/rtw_pwrctrl.o
CC [M] /home/osmc/rtl8723bu/core/rtw_rf.o
CC [M] /home/osmc/rtl8723bu/core/rtw_recv.o
CC [M] /home/osmc/rtl8723bu/core/rtw_sta_mgt.o
CC [M] /home/osmc/rtl8723bu/core/rtw_ap.o
CC [M] /home/osmc/rtl8723bu/core/rtw_xmit.o
CC [M] /home/osmc/rtl8723bu/core/rtw_p2p.o
CC [M] /home/osmc/rtl8723bu/core/rtw_tdls.o
CC [M] /home/osmc/rtl8723bu/core/rtw_br_ext.o
In file included from include/linux/filter.h:16:0,
from include/net/sock.h:62,
from include/net/inet_sock.h:27,
from include/net/ip.h:30,
from /home/osmc/rtl8723bu/core/rtw_br_ext.c:24:
include/net/sch_generic.h: In function ‘skb_at_tc_ingress’:
include/net/sch_generic.h:414:2: error: implicit declaration of function ‘G_TC_AT’ [-Werror=implicit-function-declaration]
return G_TC_AT(skb->tc_verd) & AT_INGRESS;
include/net/sch_generic.h:414:33: error: ‘AT_INGRESS’ undeclared (first use in this function)
return G_TC_AT(skb->tc_verd) & AT_INGRESS;
include/net/sch_generic.h:414:33: note: each undeclared identifier is reported only once for each function it appears in
cc1: some warnings being treated as errors
scripts/Makefile.build:258: recipe for target ‘/home/osmc/rtl8723bu/core/rtw_br_ext.o’ failed
make[2]: *** [/home/osmc/rtl8723bu/core/rtw_br_ext.o] Error 1
Makefile:1400: recipe for target ‘module/home/osmc/rtl8723bu’ failed
make[1]: *** [module/home/osmc/rtl8723bu] Error 2
make[1]: Leaving directory ‘/lib/modules/4.4.27-7-osmc/build’
Makefile:335: recipe for target ‘modules’ failed
make: *** [modules] Error 2

I tried to copy headers and kernel sources to /lib/… and also to /usr/src/… folders but it did not helped. Everytime i run make command it endup with the same result.
I tried to search on internet and found simillar problems with this same results when compiling on osmc 4.4.x-x kernel but no solution.
Than i tried to compile it the same way on my debian x64 system and it was compiled successfully and device is working.

Is there something i forgot to do (steps) or something else to build it successfully?
Can someone help?
Thank You for help.

Your driver is missing a header or include, probably: include/uapi/linux/pkt_cls.h from a quick glance at Free Electrons.

This is an issue with the driver you’re using rather than OSMC.

Thank You Sam for your quick response. Probably yes, there is some problem with this driver (manufacturer announce compatibility only for kernels to 3.19.3…) and now im see that my debian x64 is on 3.16.x-x kernel but i have seen some fixes on that drivers git repo for newer kernels (4.7) so i thought it can be compiled and used on 4.4.x-x.
Is there any possible way to build this rtl8723bu driver on latest osmc or the better way “to do” more stable streaming from RPi 3 internal bluetooth device?

I suspect things may improve in the future with the internal adapter.
I don’t know a lot about the RTL8723bu chipset and don’t have one to test, so I can’t add support as I would be unable to test it.

Update: On current version raspbian with kernel 4.4.38-v7 driver was compiled successfully without a problem… Just installed raspbian distro to sd card, kernel headers, made git clone from repository and run make and make install - everything sucessfully… So now im really not understand why it is not working on osmc with correct kernel headers.