Unable to connect Vero 4K+ to Bluetooth device

Maybe try to reboot. Basically in the current setting OSMC should automatically switch audio to the headset when it is connected and back to HDMI when you disconnect (switch it off)

I tried rebooting. No dice. Also tried setting number of audio channels to 2.0 Fixed rather than 7.1 Best Match, and fiddling with a few other audio settings, all to no avail.

As the video becomes completely unwatchable with the Bluetooth device connected - picture keeps freezing for several seconds at a time - I’ve had to turn Bluetooth off for now, but if you want me to test anything else, let me know.

(The last logs I posted were taken during a video freeze).

So I assume with your headset switched of but audio setting unchanged the video play well?

This sounds like pulseaudio hanging.
Maybe @sam_nazarko has an idea. More next idea would be in the case of a hanging video (with bluetooth headset connected) connect via SSH, check the PID of Pulseaudio and sent a kill -9 <PID of pulseaudio)

How do I do that? :slight_smile:

ps -aux | grep pulseaudio the nuimber after osmc is the PID

Hi,

Coincidentally I was just wondering about outputting audio from the Vero 4K to my Anker Soundcore 2 speaker, and found today’s thread.

I’ve installed the a2dp package, and rebooted. In settings, audio output had been automatically changed to “Playback/recording through the Pulse audio sound server”.

Unfortunately the Anker speaker isn’t making a connection, as shown by the device’s blue led continually flashing.

I cannot locate any option to initiate pairing in the osmc settings. Rebooting with the speaking in pairing mode didn’t help.

This speaker has bluetooth 4, and works fine with my ancient Galaxy S2, my Raspbery Pi 3, Galaxy Tab E, and Esinkin bluetooth to 3.5mm receiver.

Any help gratefully received.

It’s in MyOSMC -> Connections -> Bluetooth.
If that fails than go via command line using bluetoothctl

If I execute that command repeatedly during playback, I get a different number after the osmc each time. And trying to kill any one of them with kill -9 gives me “No such process”; tentative conclusion is that the process is continuously crashing and restarting, and this is somehow connected to the video freeze.

Looks like that. Maybe upload new logs with the respawning visible. Maybe @sam_nazarko has an idea

Is that not visible in the last logs I uploaded (post 5)?

Didn’t see a spawning of pulseaudio in that log

@fzinken Try https://paste.osmc.tv/qokorohewu

Hi,

Thanks for the assistance.

No joy via My OSMC, but partial success using bluetoothctl.

issuing ‘scan on’. The speaker is found, and its MAC displayed.

Issuing ‘pair [mac address]’ works, and triggers the pairing confirmation sound from the speaker.

‘trust [Mac address]’ also succeeds, however
‘connect [Mac address]’ fails

Attempting to connect to 08:XX:XX:XX:XX:41
Failed to connect: org.bluez.Error.Failed

You had successfully installed a2dp and rebooted?

Hi,

Yes to both

Just remembered it could be the double profile setting (means it might be discovered as headset). Read this post and the following

Ok a bit out of ideas here. Try to remove/unpair in MyOSMC and also in bluetoothctl. Then start fresh with scan on, agent on, pair, trust, connect

Thanks, I’ll give that a try, and also test with the Eniskin bluetooth-to-phono/3.5mm receiver

Hi,

I now have this working.

I wondered if the Anker Soundcore needed resetting, and found the internal list of paired devices can be cleared by holding volume up and down together for 3 seconds.

I had already removed paired devices via My OSMC and bluetoothctl, then uninstalled a2dp.

I reinstalled a2dp, rebooted, then used the Network menu in My OSMC to select Bluetooth (where Bluetooth was already enabled).

I powered on the bluetooth speaker (which entered pairing mode automatically), then enabled ‘start/stop discovery’ in OSMC.

The Soundcore 2 was detected. I was able to then select the device and pair (without pin).

Audio automatically directed to the bluetooth speaker.

It’s worth noting that my system always outputs using Pulse audio, as I use the vero’s 3.5mm audio jack to connect to my main speakers), so I didn’t need to change the Audio Output setting.

Thanks for your assistance @fzinken, it’s much appreciated.

1 Like

Okay, I tried doing
pactl list cards short
and then
pactl set-card-profile X a2dp_sink
where X is the listed ID.

That made the audio start working. But I was still getting the video freezing up. Serendipitously I discovered that this is in some way linked to it being a standard-definition video decoded in software: if I switch to hardware decoding, then it works okay.

So I’m set for now; but it might be worth looking into why software decoding doesn’t seem to be compatible with Bluetooth audio (maybe just lack of CPU power, but it could be something else); and it would definitely be better if there were a way of automating the process of getting the headset working as an A2DP sink.

2 Likes