Unable to install SSH Service in OSMC


I wanted to set the hardware keyboard layout to AZERTY because it remains set to Qwerty ignoring the Kodi Locale settings.
To do that I found this thread on the forum : Bug installation - #9 by grahamh
The first step is to log in SSH by using the ‘Esc’ key at boot time.

But that didn’t work (black screen with some white text appearing so fast it is impossible to read it) therefore I went to “My OMSC” program in order to reinstall SHH. I could uninstall it, but I can’t install it anymore:

  • I select it in the “App Store” and choose “Apply”
  • The installation process tooltip shows everything normally : “cache udpdated - please wait”, “starting installation”, “operation successfully completed”.
  • But when I click “OK” and go back to “Services”, SSH is not in there. Moreover in the App Store SSH is still displayed with “Install” action.

Then I tried to install SAMBA just to test, and this time it worked. Then I could uninstall Samba, but I got the following message :
“error installing: ssh-app-osmc
Please report this on the OSMC forum”

Here are the logs : https://paste.osmc.tv/wagokolame

Thanks in advance for your support.

Perhaps you misunderstood. SSH is a communications protocol that will allow you to logon to your Vero4K from a remote PC. On a Windows system, you would generally use PuTTY as an SSH client. The “Esc” method doesn’t use SSH but is a way of accessing the Vero4K’s system console directly.

Right now, the SSH server is in a “half-installed” state. (You shouldn’t have needed to uninstall it in the first place.)

The only way I can think of recovering SSH is for you to attach a USB keyboard to the Vero4K and try pressing Esc at boot time, in order to get direct access to the system console. If you can get a command line prompt, run this command:

sudo apt-get install --reinstall ssh-app-osmc
1 Like

Thanks for defining what is SSH. It’s clear now.
Anyway the problem is actually that with a USB keyboard, pressing ‘Esc’ during boot does not display the console anymore. OSMC loads just as if I was not pressing ‘Esc’. I was able to get the console before I uninstalled the “SSH Server”, and The ‘Esc’ key does work inside Kodi.

The other problem is that I cannot install “SSH Server” anymore.

That’s why I provided the log trace during the scenario : “boot and try installing SSH Server”.


As @dillthedog wrote your installation is stuck in a incomplete state which you only can overcome by executing sudo apt-get install --reinstall ssh-app-osmc

But if you can not get to the local console than that is an issue as you can not execute that.
My Recommendation as you still can access via sshfs, login via sshfs and make a backup of the .kodi folder and then reinstall OSMC

Sorry but I’ve no idea of what “sshfs” is and how to login it with the Vero4k.

Don’t you think waiting for the next OSMC update release could solve the issue?
Otherwise I’m not sure I would take the risk of such a manual operation (I’m not used to linux system) just for switching from Qwerty to Azerty.

That sounds disappointing :disappointed:

Sorry, I mixed up your thread with another where a guy still had SSHFS access.

The next update most likely will fail due to the inconsistent state of the SSH package

Actually I read your comment again and found a possible misunderstanding. You don’t press ESC during boot. You let the Vero start and then in the power menu you choose “exit” and then you press ESC on the black screen.

Oops I feel pretty ashamed. Sorry for not having understood that esc should be pressed at exit time and not at start up.

Thanks to your help I could at least run into sshfs, then reinstall ssh-app-osmc, and finally set Azerty. BTW I hope the physical keyboard layout management will be included into OSMC’s UI settings, because that’s a challenge to type in the login infos and commands in sshfs with the inappropriate layout…

Thanks again and have a nice week-end!

Not for a while yet unfortunately. There’s been a lot of discussion about it.