Unable to login after latest update

Hi everyone.

I ve just updated as I always do my OSMC. After that I am unable to login using ssh it says that my password is wrong.

Does anyone have an idea how to fix this?

Is there a possibility to an update to fix this bug?

Please, let me know.

Linux never says “password is wrong”. We need to know exactly what the error reads.

Hi ActionA,

You are right.

It says:

Access Denied.

My password is already saved on putty. It gives me an error while trying to log in.

Even when I am entering manually the password “osmc” it stills gives me the same error.

Ive tried to login trough the console, hitting ESC when exiting Kodi to no avail

When I do enter my login and password it says that I do have a “inavalid login”.

This latest update broke something. It not restricted to a remote login.

Oh man, To loose a perfect installation of OSMC because of this…

Can a new update undo this?

That’s pretty much impossible that an update would change or invalidate your login credentials. It’s never occurred in OSMC before and, if it did, you wouldn’t be the only person affected. Are you certain you are attempting to connect to the right device or that dhcp did not sign another IP for some reason?

Sorry for the obvius, checked CAPS-LOCK?

Good idea but should have no effect on putty saved credentials.


Update your version of putty to the latest version and try again. Older versions of Putty will not be able to connect to the current version of OSMC as Debian deprecated some older insecure SSH keying schemes in a recent update.

If you are sure it is a password problem (I don’t see how) then do the following:

Shut down and remove your SD card, insert it into an SD reader in a PC.

Edit cmdline.txt and add the word recovery to the end of the line, save, and boot off the SD card.

This will take you directly to a root recovery console - you will need a keyboard plugged into your Pi. Type:

passwd osmc

And retype your password. Then edit cmdline.txt to remove the word recovery:

nano /boot/cmdline.txt

Once you have done that type exit to reboot.

If this does not work, your issue is not that the password is wrong.

Edit: fixed typo. passwd root should be passwd osmc of course.

1 Like

Thank you, DBMandrake.

It worked. I was about to wipe it out, since i dont own a wired usb keyboard anymore, but thankfully my FAVI IR keyboard worked like a charm.

This is what happened. Somehow, because of the latest OSMC updates, my osmc password got changed, or garbled. I cant think of another explanation. It was just fine yesterday

My RPi is connected to an UPS unit btw. I had no power outage or surge.

If someone else encounter this problem the workaround from DBMandrake works.


I have a RPI, and the password (which I never change) is no longer accepted from SSH (LAN/WAN), FTP (LAN/WAN), terminal itself.
Media stuff still works, web server too.
It seems password changed, even if it’s impossible…

Tried to Google my problem, but I didn’t found anything.
I would really approciate any kind of help, THANKS!!

Edit~ Samba network link on my Win7 still works, but I don’t know if it check for credentials every time (I suppose it does)

Edit~ Never set password to root

Thanks to ActionA for redirecting me and DBMandrake for the solution, worked like a charm :thumbsup:

1 Like

Hi all,
I can’t seem to be able to login to my RPi running Kodi.
Using Putty I get “Network error:Connection refused”
See screen shots.

I am trying to make my Kodi ignore the Volume Up and Down and the Power Button.

Have tried KeyMap editor but it didn’t seem to work.

Confirm the IP address is correct.(That’s the problem 90% of the time.)

Yes it is correct, my router/cable modem confirms it with MAC addrress.

After an update and reboot Raspberry Pi its also possible that the IP address has been changed.

Check in MyOSMC->Services that the SSH service is enabled.

Also check in MyOSMC->Network that the IP address is what you think it is.

I did check MyOSMC->Network and did indeed find it was not what I had thought.
I am able to login and have found the file zi think I need to edit to fix my remote. It uses samsung-lirc.conf
I need to enable root login in order to edit, I think now.
what is the default pw for root?

What files do you think you need? I’m not sure root should be required for these.

Well actually I was able to use “sudo nano samsung-lircd.conf” to edit out the key codes for VOL UP and DOWN and the MUTE and it works!! Could not find a POWER key entry.

Thanks all for the help.

Root access is never needed to edit any files on the system. You can always use sudo to escalate privileges

I’m having the exact same problem as the original poster. Updated my OSMC install and now my username/password combination does not work, both on SSH and when dropping down to the shell from OSMC.

I’ve tried your solution, however, when I boot into recovery, my wired USB keyboard does not seem to be detected (but it does work normally on my Pi). Any suggestions on how to make the keyboard work? Also, is there any update on why the passwords were randomly changed for some users after update?