Unable to Scan new movies on OSMC for last 48 hours

On Monday I found the Vero was displaying a red light and had crashed.

After a reboot i found it was unable to pickup any new movies added to its library.

After a minute the error message comes up ;

“Couldn’t download information. Unable to connect to remote server. Would you like to continue scanning.”

It displayed this message for each new film Ive added

And has continued to do this for the last couple of days.

Whats caused this to stop working?

Log ip loaded
https://paste.osmc.tv/ mipilobobi

I just got a Vero 4K as of yesterday and I’m also having this issue.
I wonder if it has anything to do with the TMDB scraper add-on not being the latest available.
Vero 4K has version 5.1.2 from the official kodi repo however I also got a kodi 17.6 on kodibuntu which is on version 5.1.3 and is working fine with scraping new content.
Unfortunately the OSMC kodi 17.6 with all available updates applied doesn’t show anything newer available than 5.1.2.
Just ran the OSMC updater but it doesn’t have anything new available.

@sam_nazarko any ideas how to go about this ?

I’m also experiencing this issue with my Vero 4K. When i try to paste the URL of the attempted scan into my browser the site tells me:

status_code 7
status_message “Invalid API key: You must be granted a valid key.”
success false

Same issue - seems to be something to do with API keys being misused. There is a new version of tmbd add on v5.1.3. Updating though kodi only showed me v.5.12 - You can manually download v5.1.3 as a zip here:


and install then it works again :slight_smile:

1 Like

Yeah I noticed the API key messages but didn’t wanna go the route of manually installing from zip before asking around here first.

thanks tho for confirming

As I don’t know how to manually update an add-on I am hoping to see an official fix soon. :slight_smile:

You should be able to update via Kodi under Settings -> Addons.

1 Like

You are a genious!! thanks a lot, I was searching for hours the solution to this problem!!! You saved my day.


Manual downloading and updating from the zip file has partially worked.

Its now loaded the films into the library successfully however its not getting any poster art or cast information just name of film and plot synopsis with a thumbnail - refreshing those films does the same.

I tried updating via Settings -> Addons, but end result was the same version. I will try the manual zip file method.

Hello, I can’t use the Movie database anymore because the cannot connect to the remote server message appears every time. I checked if there was an update to my add-on and there is none available. I just wanna know if I’m the only one with this trouble. I know it occurred in the past for some users and updating the add-on was the solution… thanks for the help.


I’ve moved your post to this topic, as the solution is here; please see post #4

Thanks Tom.

yup got the same behaviour going.
manually installing 5.1.3 from zip got the scanning finally going (even though kodi.log still shows lots ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 401) but I’m not getting any posters or cast info.
I’ve tried deleting my movie media info from kodi and re-adding them but after the scan I end up in the very same situation.

Tried to downgrade the add-on but the problem remains. Guess I’ll have to wait for the next update but it’s strange that it stopped working suddenly.

if the 5.1.3 update to the add-on was to prevent people abusing API keys to query TMDb it makes perfect sense that whilst on 5.1.2 scraping would stop working.
I just find it strange that OSMC doesn’t find anything newer then 5.1.2 despite using the official KODI repo.
And perhaps even stranger is that after having done the manual update the library doesn’t get scanned properly (no posters or cast info).
But what I’ve seen from the kodi.log it still might be caused by TMDb itself or the addon and thus OSMC can’t do anything about.

Please post a log if this is the case.
Latest version should be available to all OSMC users


which log do you require for this?
I’m assuming only the kodi log (grab-logs -X) but with DEBUG enabled?
Haven’t enabled debug yet so lemme do that first.
Then I’ll downgrade metadata.themoviedb.org to 5.1.2 and perform a refresh of the official kodi repo.
hopefully that’ll end up in the kodi log then.

EDIT: have enabled debug now.
what’s interesting to me (could be considered as proof ?) is there’s a metadata.themoviedb.org-5.1.2.zip in ~/.kodi/addons/packages (timestamp of 8 May) but not 5.1.3 despite me having performed multiple repo refreshes today (9 May)

osmc@vero-4K:~/.kodi$ find -iname ‘themoviedb

I also got working with the 5.1.3 version, but only fanart, no posters are available as others have noted.

I’ve taken a quick look and the latest add-on wasn’t available via OSMC’s mirror for the Kodi repository.

This has now been resolved.

1 Like