Unable to update osmc from November 2019

I purchased an additional Vero4k some time ago and am now only just getting round to installing it for the first time!

I’ve tried manually updating from the November 2019 version (2019.11-1) it says it’s on, and it looks to download 42 files (though flashes very quickly through it on the screen) then reports “There are no updates available”.

I’ve looked through the forum (but apologies, might not be typing the right thing in) and did find some help.

I have applied the hotfix “ucawobahij”
via ssh:
I have run sudo apt-get update
and sudo apt-get dist-upgrade
then rebooted and tried updating again but the same thing happens.

The first time the “dist-upgrade” was run from the command line it upgraded 123 packages with only 2 failure lines:
Failed to try-restart apt-daily-upgrade.timer: Unit apt-daily-upgrade.timer is masked.
Failed to try-restart apt-daily.timer: Unit apt-daily.timer is masked.

I did see an entry about running sudo apt-get update --allow-releaseinfo-change but this comes back with an error message “…not understood in combination with other options”

Any ideas as to something I’m missing? The primary Vero4k updates whenever a new release is available and is currently on September 2022.

Thanks in advance…


This version is far too old to be updated. You’ll need to reinstall OSMC from the download page

As you’ve never used it - just grab a fresh install.



1 Like

Thanks Tom, I had already tried using the –allow-releaseinfo-change option but it errors (see original message).

1 Like

Understood - thanks Sam.
Will download and install from a USB image,

Interestingly, downloading the Windows Installer programme causes Malwarebytes to say it should be quarantined…

It’s a false positive. But as I always say — if you don’t trust us to run an installer on your computer, you shouldn’t trust us to run an entire operating system on your device.

I’m not going to pay antivirus companies their ‘safety’ fees.

1 Like