Uninstall OSMC packages

I’ve got OSMC running, but I’d like to remove the osmc part so I’m just leftover with a Debian installation. I’m doing this because I’ve got other things setup so I don’t want to reinstall the whole OS. What packages do I need to uninstall so I can uninstall OSMC as whole so I’m just left with Debian. Thank

Why not just disable the media centre?

“systemctl disable mediacenter” should work.

If not, I would try " systemctl stop mediacenter" in “etc/rc.local”

I don’t really see a benefit to removing the binaries, it’s not like you’re that hard up for disk space.

IMHO, and all that.

It may just make more sense to download and install Debian. There are a fair few customisations OSMC makes outside of packaging.

If you don’t want Kodi and OSMC’s userland, you’re probably better off installing Debian directly.

Understand! My issue is I’ve set up a number of other services and applications that I never automated. I’d like to avoid losing the current installation if possible. Before I start installing Debian from scratch I’d like to see if it is stable enough if I just uninstall all OSMC packages. If not, then I’m essentially left with no choice anyway!

It won’t be. The systemd startup process is dependent on several OSMC packages and boot up will therefore be broken if you remove them.

If it’s just systemd dependencies, I can probably address that. Shouldn’t be an issue. Is there no specific packages that you guys develop/maintain that can be removed from dpkg? I’ll deal with any problems after.

dpkg -l | grep osmc

Should have known. I was just slightly wary cos there may have been some packages that didn’t have OSMC in the name. Thanks though :slight_smile:

Here goes nothing!

Sorry for bumping this thread, but how am I supposed to install Debian from scratch ?
I have Atv1 up and running with OSMC, I disabled mediacenter but I have 40MBs of ram free. Since I an using OSMC on Raspi I’d like to use this box for other purposes (TimeCapsule backups), and I need a vanilla Debian install.
Atv patchstick creator from Davilla seems not to work… Could you please help ?

OSMC with mediacenter disabled already has a minimal set of services.

If you want Debian from scratch then you could try kexec a netboot ISO

The ATV1 has 256MB of RAM. I assume you are getting your information from the free command. Here’s what I get on a Raspberry Pi 3 with mediacenter disabled (numbers in megabytes):

osmc@osmc:~$ free -m
             total       used       free     shared    buffers     cached
Mem:           747        443        304          5         35        353
-/+ buffers/cache:         54        693
Swap:            0          0          0

I’ve allegedly used 443 MB and have 304 MB free - but there is 388 MB of buffer/cached data most of which can be freed if the kernel needs to use the memory. So, in reality, when stripped of all the buffer/cached data, the core memory usage, is more like 443 - 388 MB, which equals 55 MB. Allowing for a rounding error, it’s shown on the -/+ buffer/cache line as 54 MB used - and most importantly there is a true usable memory on the Pi 3 of 693 MB. That’s the number you need to look at.

Here’s a Debian VM that only has 512 MB:

             total       used       free     shared    buffers     cached
Mem:           494        483         10          8         24        373
-/+ buffers/cache:         85        408
Swap:          382          0        382

In this case, the -/+ buffer/cache line shows that the core usage is around 85 MB and 408 MB is still available for use.

So the bottom line is that you probably have more than enough available RAM on your ATV1 to run OSMC as a server.

Thanks @dillthedog, your’re right about the memory, I read the wrong line. My problems are related to services already used/started by OSMC that I also need to use.
For instance, I am facing issues with avahi for timecapsule use (via netatalk). I was able to make it run but upon restart, it complains about local name collision.
I am trying to understand how to remove OSMC’s native avahi service

Don’t remove it, simply disable it:

sudo systemctl disable avahi-daemon.service
sudo systemctl stop avahi-daemon.service