Unsafe storage device removal

Just tried a couple of drives looking for a series i have and on some of them i keep getting this error message and can’t play any files on them. Never had this issue before, any ideas?

I’ve tried the drives on my laptop and they work fine.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I did a reinstall of OSMC and it now works, maybe it was after the update to the latest version? I’m now running the January software.


Could I please request you update to the latest version and if the issue persists can you please provide some logs, so the issue can be fixed.

Thanks Tom.

What device are you using?
It sounds like your drives are not getting enough power.

Have just updated to the latest software and all still working.

1 Like

4k+, i tried the drives on my 4k and they worked fine.

Anyway, all good after reinstalling OSMC.

Are the drives externally powered?


No, USB powered.

We recommend a USB powered hub or an external power supply. Otherwise these drives won’t be getting enough power, particularly if there are a couple of them.


I copied some files from nas to a USB hdd connected the 4+ via usb. Noticed there is an option to safely remove it.in kodi which I did as it.was for someone else. No issues but I’d recommend it.

If you get the device removed unsafely error, it means the drive has likely disconnected due to a lack of power. This can only be mitigated by using a powered USB hub or powering the drive with an external power supply. From a data integrity perspective, it’s important to power the drives, even if it sort of works presently.

Old thread but still the same issue again. I just don’t understand why i only have this issue on the + unit, all works fine on my 4k unit.

Did you get a powered USB hub as was suggested 5 months ago?

No, I’ll just move the 4k+ to my bedroom and bring the 4k out to the living room. Just disappointed that a hub needs to be used on one but not the other. I can no longer recommend the Vero to others.

We have always recommended using a powered hub or self powered drive. Same as with the Pi. They are not designed to power an external drive. As drives age, they can start drawing more power, and with slight manufacturing differences, power supplies will vary on what they can output.

Also, the USB2 specification only allows 900mA of power to be delivered to a device. That’s low for a spinning drive. Because a desktop/laptop has a larger power supply, they can exceed to 500mA spec. Remember the spinning drives that used to come with a Y cable? That was because back then even desktops/laptops stuck to the 500mA spec.

It’s a shame that you won’t recommend a Vero just because it works best with a powered hub. That also means you can’t recommend a Pi, or any other SoC type system.


You’ll find the same problem with all media players and using USB hdd. Its really a USB power spec issue

Sorry to hear that, but that’s understood.

Our next model (we have no ETA) will implement USB3. This will support 1.5A power delivery to a single device. But this still may not be sufficient for some large capacity 3.5" drives – although it would be fine for 2.5" drives.

The Vero isn’t a NAS – it’s a media player.

This won’t be the case. The power output (0.5A) will be the same across both devices.
I’d be interested to know if both devices are connected to the black coloured USB port and not the OTG port.


I noticed after moving the + into my bedroom, i had the remote dongle in the opposite port to the 4k, i think you may be onto something there. I’ll swap it and see what happens.

OK so no change. What i have noticed is that when i have the + in my bedroom, it hasn’t played up. Are the power supply’s the same? I haven’t moved them when moving the units.