Unusable at the Moment

I identified a folder on my new NAS and the “Checking Media Files” process started. It got about ten albums into the process and the box crashed.
It then recovered, restarted the check process and crashed again at around the same point.
It’s been doing that for half an hour.
I’ve tried power off and reboot but both leave the unit in the same state.
Is there a 3 finger salute equvalent for Vero?

It sounds like some of these files may be corrupted and it is causing Kodi to crash.

You could SSH in to the device to move the ~/.kodi directory away temporarily.


I have no idea how to do any of that.
It seems to me that a corrupt file shouldnt render the vero unusable.
Can you send me a repacement box and I’ll return this one?

How to login via SSH is explained here

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

How to move your Kodi folder is explained here

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Just re-install OSMC. You don’t need any command line experience, just a PC.

I didn’t present this as an option originally, because I didn’t know how ‘configured’ your device was. If you’re happy to start fresh, just reinstall.

When using PUTTY it doesnt let me enter the password and then terminates with an unexpected network error. I guess that’s the sytem crashing again.

No – Kodi crashing won’t prevent the rest of the system from coming up. I’d just advise formatting the device as per the instructions above.

I cant enter the password.
The login as worked fine. Password wont accept anything.

Message is remote side unexpectedly closed connection. Then putty goes intert.

It looks to me like its the system that’s crashing. I get the blue screen, weepy face and then the OSMC logo before it goes to Kodi and crashes again.

The sad face means that Kodi cannot start, it does not mean the system is not starting.
The password is not meant to show characters as you type it for security reasons. You don’t see anything like **** as you type.

I followed the instructions to reinstall OSMC. That seemed to work, but when I tried to play music directly from the NAS there was a lot of distortion.
To check that there is no problem with the NAS or the data on it I have reinstalled Kodi 18.5 on my HTPC. Everything works fine there. The music plays without distortion, the files ckecked without a hitch and the auxiliary stuff was added in the process.
So what wont work is Kodi on vero.
Right now I’m trying to repeat the reinstall. I’m using the same file on the same USB stick to load from, and am connecting the stick while the vero is powered off, and when I put power to the vero it comes up without the reinstall. Is that the way it’s supposed to work?

You need to re-image the USB stick again if you’ve already installed OSMC.

Did you configure your audio settings?

I identified the folder that was causing the crash and deleted it from the drive.
I figured out my reinitialze problem, reintialized, identified the source and then the checking completed. Interestingly enough, the offending album is not in the file list but is still in the album and artist li (and pays from there), but without album art. What’s that about?

The pulsating hissing is still there on several albums. It is not there when I play the same albums under Kodi on my PC though my reciever. I’ve tried all the audio settings I can see without affecting any of the symptoms. I only want Kodi to mange the files and pass the data to my reciever for decoding. The problem files are .flac, but not all my .flac files have this problem.
I’m intigued as to why this happens on the Vero and not my pc.
Any ideas on why that is and what I can do about it? Again, this only started happening when I changed my NAS hardware.

If you deleted the folder that had the offending album but it still plays then obviously there was a second copy. If you play the file you should be able to see where it playing it from in Kodi’s log. As for your audio settings it is kind of hard to say much without knowing anything about your setup and no logs to see what settings your using.

Have you followed this guide: Audio hardware and software configuration


I haven’t seen that audio guide before. It looks very comprehensive and I’ll look at it carefully tomorrow when I’m less “Tired and emotional.” I notice you refer to logs a lot in your various correspondences, including this one. I guess I’ll have to find out about how to use logs tomorrow, too.
Now I’ve installed putty and actually succeeded in ssh’ing nto Vero, can I use that mechanism to install a VPN directly onto Linux that will work with Kodi addons?

You can install VPN without using the command line. I recommend using the Brian Hornsby VPN add-on.

You can upload logs via My OSMC, but for now I’d suggest you provide us some details about your audio setup.

We are keen to get this solved for you. Have a good rest