Update Error w/ Logs

New Vero, purchased in June, plugged in and updated and received an error. Posting to forum as instructed.
Logs: http://paste.osmc.io/wanirehuja

Also, the updates are downloading at a crawl (20-30kbps), is this normal?

Thanks for the help,

Nothing in the log is obvious.

Can you turn on debugging in the Kodi settings and try again?

Thanks for the quick reply. Turned on debugging, ran the update again, and new log here: http://paste.osmc.io/ocazafenoh

Bump. Can anyone spot the cause in the new log?


I don’t see anything immediately wrong here.

Try running these commands

sudo apt-get update
sudo apt-get -y dist-upgrade

and let us know how you get on

Thanks, Sam. New to Vero/OSMC, how do I get to the command prompt?

I dont have a wired keyboard with me, any other methods?

While I find one, is there a way to completely reset/reformat a Vero and try again from scratch?

You can get a command prompt by connecting with SSH.

No that’s not normal, and if it is going that slowly it’s quite likely that the download will end up aborting and causing the update error that you saw.

You can login via SSH.

You can restore your Vero by going to Download - OSMC and grabbing the latest installer for Windows, Mac or Linux


Thanks guys, was reading up on SSH when you posted (I’m a little out of my depth here).

Running Sam’s commands through SSH now…

Re: speeds - it starts, for a fraction of a second at 250+kbps and then plummets to 20-30kpbs. Any ideas no what could be causing this issue? Like DBM said, if it’s causing the update issue perhaps its worth looking into the speed first?

Where are you located?

US. On fiber. Have another Vero on this same network that doesn’t have this speed or update problem.

Results of running the commands:

[quote]login as: osmc
OSMC: Open Source Media Center
osmc@’s password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
osmc@osmc:~$ sudo apt-get update
Hit http://ftp.debian.org jessie InRelease
Get:1 http://security.debian.org jessie/updates InRelease [63.1 kB]
Get:2 http://ftp.debian.org jessie-updates InRelease [123 kB]
Hit http://apt.osmc.tv jessie InRelease
Get:3 http://security.debian.org jessie/updates/main armhf Packages [134 kB]
Get:4 http://apt.osmc.tv jessie/main armhf Packages/DiffIndex [2023 B]
Get:5 http://ftp.debian.org jessie/main armhf Packages [6623 kB]
Get:6 http://security.debian.org jessie/updates/contrib armhf Packages [1134 B]
Get:7 http://security.debian.org jessie/updates/non-free armhf Packages [14 B]
Get:8 http://security.debian.org jessie/updates/contrib Translation-en [1098 B]
Get:9 http://security.debian.org jessie/updates/main Translation-en [74.1 kB]
Ign http://apt.osmc.tv jessie/main Translation-en
Get:10 http://security.debian.org jessie/updates/non-free Translation-en [14 B]
Hit http://ftp.debian.org jessie/contrib armhf Packages
Hit http://ftp.debian.org jessie/non-free armhf Packages
Hit http://ftp.debian.org jessie/contrib Translation-en
Get:11 http://ftp.debian.org jessie/main Translation-en [4585 kB]
Hit http://ftp.debian.org jessie/non-free Translation-en
Get:12 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [643 B ]
Get:13 http://ftp.debian.org jessie-updates/contrib armhf Packages [32 B]
Get:14 http://ftp.debian.org jessie-updates/non-free armhf Packages [32 B]
Get:15 http://ftp.debian.org jessie-updates/contrib Translation-en [14 B]
Get:16 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [229 B ]
Get:17 http://ftp.debian.org jessie-updates/non-free Translation-en [14 B]
Fetched 11.6 MB in 3min 57s (48.9 kB/s)
Reading package lists… Done
osmc@osmc:~$ sudo apt-get -y dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following packages were automatically installed and a re no longer required:
armv7-libafpclient-osmc vero-image-3.14.37-3-osmc
Use ‘apt-get autoremove’ to remove them.
The following NEW packages will be installed:
eject ethtool vero-image-4.1.3-7-osmc
The following packages will be upgraded:
apt apt-utils armv7-connman-osmc armv7-eventlircd-osmc armv7-librtmp-osmc
armv7-libshairplay-osmc armv7-network-osmc armv7-remote-osmc
armv7-splash-osmc avahi-daemon base-files base-files-osmc bind9-host curl
dbus diskmount-osmc dmsetup dpkg fuse libapt-inst1.5 libapt-pkg4.12
libavahi-client3 libavahi-common-data libavahi-common3 libavahi-core7
libbind9-90 libc-bin libc6 libcups2 libcurl3 libcurl3-gnutls libdbus-1-3
libdevmapper-event1.02.1 libdevmapper1.02.1 libdns100 libexpat1 libfuse2
libgnutls-deb0-28 libgudev-1.0-0 libicu52 libisc95 libisccc90 libisccfg90
libldap-2.4-2 liblvm2app2.2 liblwres90 libmysqlclient18 libpam-systemd
libsqlite3-0 libssl1.0.0 libsystemd0 libtasn1-6 libudev1 locales
mediacenter-addon-osmc mediacenter-skin-osmc multiarch-support mysql-common
ntfs-3g ntp openssh-client openssh-server openssh-sftp-server openssl
perftune-osmc perl-base sysctl-osmc systemd systemd-sysv tzdata udev
vero-kernel-osmc vero-libcec-osmc vero-mediacenter-osmc vero-userland-osmc
vero1-device-osmc vero1-ftr-osmc vero1-wifi-osmc wireless-firmware-osmc
80 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 80.2 MB/125 MB of archives.
After this operation, 268 MB of additional disk space will be used.
Get:1 http://apt.osmc.tv/ jessie/main vero-image-4.1.3-7-osmc armhf 7 [21.7 MB]
Get:2 http://apt.osmc.tv/ jessie/main mediacenter-addon-osmc all 3.0.33 [17.9 MB ]
Get:3 http://apt.osmc.tv/ jessie/main vero-userland-osmc armhf 1.1.7-1 [11.6 MB]
Get:4 http://apt.osmc.tv/ jessie/main vero-mediacenter-osmc armhf 15.1.0-0 [29.0 MB]
Fetched 80.2 MB in 24min 25s (54.7 kB/s)
E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero-source-4.1.3-7-osmc/vero-image-4.1.3-7-osmc_7_armhf.deb Hash Sum mismatch

E: Failed to fetch http://apt.osmc.tv/pool/main/m/mediacenter-addon-osmc/mediacenter-addon-osmc_3.0.33_all.deb Hash Sum mismatch

E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero-userland-osmc/vero-userland-osmc_1.1.7-1_armhf.deb Hash Sum mismatch

E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero-mediacenter-osmc/vero-mediacenter-osmc_15.1.0-0_armhf.deb Hash Sum mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Your update error is certainly because of a download issue. The good news is that nothing appears to be wrong with the Vero itself.

How are your two Veros connected? The same network? Are they wireless?


They are on the same network, both wired. Turning on the wireless on the problem one to see if anything changes. Any ideas?

Are they both plugged into the same physical switch or different switches ?

I’m guessing they are on different switches in different rooms in the building ?

You could try dropping the ethernet port speed to 100mbit as described here in case it is an issue with ethernet flow control:

They’re plugged into the same physical centralized switch for the whole house.

Re: flow control - the slow speeds happen, and seem to be constant, even when nothing else in the whole house is using any bandwidth (other Vero not playing, no computers being used, etc). Would flow control matter even when it’s the only thing being used?

When I put the Vero on wireless, speeds increased to 100-150+/-kpbs, still not what I assumed they should be given that there’s an access point on the other side of the wall right behind it, but definitely faster. It’s attempting to install the updates now.

Thanks again for the help!!!

I was able to get the update installed by switching to wireless, however the speeds are still consistently sub 100kbps which doesn’t sound right.

A new problem has arisen or at least I’m just noticing it now that I’ve populated the library and tried to watch something. When scrolling through the menu using the supplied remote, I’ll click a few times ahead of what the screen is displaying and then suddenly the screen will show continued scrolling and options being highlighted long after I’ve stopped pushing buttons. It’s similar to if the buttons on the remote were pressed or stuck down but it continues even when I pull the battery from the remote just to be sure. Afterward, the system becomes largely unresponsive so I can’t stop it from scrolling around on it’s own, can’t stop the video from playing, etc. It’s unwatchable in it’s current state. I did the latest update from a day or two ago as well and no change.

Has anyone run into this before? Is this and the slow speed related?

Thanks for the continued help, looking forward to getting this working correctly.

This sounds like a network problem. I would run iperf and see if you can isolate the issue.

You could also try downloading a file from