UPnP library sharing - playback error [RESOLVED]

Hi.

This is a fresh install. PiB2 is the main unit sharing the library via UPnP. The PiB is in the bedroom.

Under Alpha 4 I had UPnP library sharing working fine and I am trying to do the same now with the RC but it won’t quite work.

The files show up, I can see the file and the associated data but when I select the file to pay it doesn’t start and throws a playback error that the file can’t play and to check the log.

Here is the log: it seems to be trying smb as well:

http://paste.osmc.io/obuwebowoy.coffee

Thanks

Whole Kodi log: http://paste.osmc.io/bizugihago.coffee

Is it all video files or just that one?

It’s all files. Movies and TV shows.

It’s set up the same as it was under Alpha 4 so I’m a little lost because it was working really well. I know UPNP isn’t the best but for the bedroom it’s all we need.

I did install Samba from the app store. Could something be clashing?

Turn on debugging, reproduce the issue and provide a new log.

Edit: If you use the log uploader in My OSMC you can choose to upload all logs which gives us a better idea of your setup.
But turn on debugging first.

Thanks miappa - forgot debug log.

Here is the full log uploaded from OSMC: http://paste.osmc.io/lovutoyano

The time stamps in the log are out by two hours as well.

Here it is trying to play a TV Show: http://paste.osmc.io/jehivugipi.coffee

Before we dig deeper, are you trying to share anything provided by an addon via UPNP?
If so, I am pretty certain that UPNP only works with local content even if it is scanned into library.

However, the smb error you get shows as a permission error in the debug log.
So that is without a doubt a simple permission issue that probably needs to get fixed on the server end.

No, not trying to share anything provided by an addon via UPnP.

I have my Movie and TV Show library on the PiB2 and just trying to share that library to the PiB in the bedroom.

I have set it up exactly as I had with Alpha 4 but now it’s not working - well…it’s working but I just can’t get it to play the content.

I did see that permission error in the log.

The permission issue is the actual issue.
UPNP will share the it´s sources which in this case is shared via smb, so sort of a relay.
So you need to look at the permissions on the smb shares.

Permission on the smb shares. That would be on the PiB2 - the one where the library is or on the PiB where I am getting the error.

Not sure where to quite look for the permissions or how to change it.

I’ve checked:

mediasources.xml
guisettings.xml
sources.xml
upnpserver.xml
smbconf.xml

All seems ok

Niether, unless you share your local content via smb from and to the same Pi on the “main” setup?
The permission issue should be fixed wherever you share your content from via smb.

Let´s get everything correct;
where do you share your content from to your first Pi?

Edit:
You might have stumbled upon this issue: http://forum.kodi.tv/showthread.php?tid=167059&pid=1442884#pid1442884
You could try to copy passwords.xml, or set up your sources on the first Pi with user:passwd in the URL, and see if that resolves the issue, but I would still recommend jut setting up the original smb share as source instead.

I got it working - not sure if it’s related to the link you provided.

All I did was begin setting up sources via SMB rather than UPnP. I did not have to run a library scan. I then removed those two sources that I created (Movies & TV Shows) and attempted again to set up via UPnP and it worked straight away.

Might be a “bug” in the way UPnP is implemented or as there was no SMB source initially set up the UPnP relay had nowhere to look.

Under Alpha 4 I did the same thing - set up initially via SMB until realising I could share the library via UPnP. Back then I did not know what effect this would have. I would have had the same issue as I had today.

Thanks for all the help.

Glad it´s working now.
I bet that if you check your log now you will have the user:passwd in the URL that UPNP provides.
Either that or you have a proper passwords.xml with all info which didn´t exist before you added the smb share.

I’ll check the log.

I actually did see a passwords.xml file with all the correct info when looking at all the .xml files for permissions.

Thanks again.

Interesting…it’s working fine and the UPnP library sharing is working but there is no reference to UPnP in the log now:

http://paste.osmc.io/upevategux.coffee

Strange

@miappa

Please;

what format has passwords.xml file?

thanks in advance

I’m having the same problem with sharing via upnp

I have my main raspberry pi in my living room with a few HDs full of movies that works flawlessly

Another in a front room with no HDs. And another in a bedroom. No HDs connected. I am attempting to be able to share the content with the two pis without having to physically move the HD and restart.

Not asking to much right. I can see the drives once I enabled the upnp but. Can’t get anything to play. I’m going to reinstall the newest version of kodi and start all over to see if all my tinkering created some issues.

Any advice? Anything step by step I need to do? Must be possible from all I read but I’m sure having some block somewhere!

Thanks for any help. I’ll keep you informed of my progress!

http://kodi.wiki/view/HOW-TO:Share_libraries_using_UPnP

Please consult Kodi wiki first for guidance on Kodi specific functions.

Thanks. I will

Yea. I looked. Followed that exactly. Still same issue