Using transmision and get error: read only file system

Hi

Firs time try to to set transmission on vero 4k. Transsmision instaled through app store.
I ssh to my vero 4k :
used comand: sudo nano /home/osmc/.config/transmission-daemon/settings.json

( and tried to chang download directory to my NAS WD my cloud mirror. My NAS is connected throug FSTAB)

so I changed:
“download-dir”:"/mnt/siusti",
“incomplete-dir”:"/mnt/siusti",

everything else stayed as default then ctrl+X Yes and Yes

So it looks that I changed downlowd directory on may web browser on transmission I see:

32

but then i try to upload file I get such error:

My log files: https://paste.osmc.tv/obunomiyoh

Sorry very much, i will change as you mentioned

I changed schreen shot with other name
Sorry one more time
Regards
Ariux

I don’t remember what error message I had, but i solved it this way:

What I’ve done is link my download folder from a mounted disk to a link in my home folder:

ln -s /mnt/siusti /home/osmc/Downloads

and point the downloads there to /home/osmc/Downloads

Hi,

Please post your fstab & the output of:

ls -lah /mnt

Thanks Tom.

osmc@osmc : ~ $ ls -lah /mnt

total 32K

drwxr-xr-x 7 root root 4.0K Oct 24 16:13 .

drwxr-xr-x 23 root root 4.0K Aug 10 14:44

dr-xr-xr-x 2 root root 4.0K Oct 16 15:53 CloudUSB1

drwxrwxrwx+ 86 root root 12K Oct 31 12:27 Muzika

dr-xr-xr-x 2 root root 4.0K Aug 11 19:16 Transmission

drwxrwxrwx 1 500 osmc 0 Jun 27 21:43 musicvideo

drwxrwxrwx 1 500 osmc 0 Oct 24 16:06 siusti

osmc@osmc : ~ $

And here is FSTAB info:

  rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0

192.168.1.5:/mnt/HD/HD_b2/Muzika /mnt/Muzika nfs x-systemd.automount,noauto 0 0
192.168.1.5:/mnt/USB/USB1_c2/CloudUSB1/musicvideo /mnt/musicvideo nfs x-systemd.automount,noauto 0 0
192.168.1.5:/mnt/USB/USB1_c2/CloudUSB1/siusti /mnt/siusti nfs x-systemd.automount,noauto 0 0

And if I verify my FSTAB

 osmc@osmc:~ $ sudo mount -a

mount: /etc/fstab: parse error at line 1 -- ignored

It shows some eror but everything works perfect (like movies , skiping chapters)
But if I try to downlowd using transmission as discribed in the first post got message : read only file system

Thanks everybody for quick support.
I am engoing my vero 4k
Learning by doing :slight_smile:

The first line of your fstab is missing a # at the start, that’s the cause of your error there.

What does

ls -l /mnt/siusti

show.

[quote=“bmillham, post:12, topic:76043”]
ls -l /mnt/siusti
[/quote] osmc@osmc : ~ $ ls -l /mnt/siusti

total 0

drwxrwxrwx 1 root root 0 Oct 19 21:21 MAMMA_MIA2

osmc@osmc : ~ $

Try this:

$ chown -R osmc:osmc /mnt/siusti

osmc@osmc : ~ $ $ chown -R osmc:osmc /mnt/siusti

-bash: $: command not found

osmc@osmc : ~ $

Remove the $, we normally use $ at the start of a command just to indicate that it’s run in a shell.

Also, what happens if you:

$ touch /mnt/siusti/test
$ ls -l /mnt/siusti/test

osmc@osmc : ~ $ touch /mnt/siusti/test

touch: cannot touch ‘/mnt/siusti/test’: Read-only file system

osmc@osmc : ~ $

and
osmc@osmc : ~ $ ls -l /mnt/siusti/test

ls: cannot access ‘/mnt/siusti/test’: No such file or directory

osmc@osmc : ~ $

And to the comand:
osmc@osmc : ~ $ chown -R osmc:osmc /mnt/siusti

chown: changing ownership of ‘/mnt/siusti/.DS_Store’: Read-only file system

chown: changing ownership of ‘/mnt/siusti/MAMMA_MIA2_2018_BLUEBIRD/BDMV/AUXDATA/sound.bdmv’: Read-only file system

chown: changing ownership of ‘/mnt/siusti/MAMMA_MIA2_2018_BLUEBIRD/BDMV/AUXDATA’: Read-only file system

chown: changing ownership of ‘/mnt/siusti/MAMMA_MIA2_2018_BLUEBIRD/BDMV/BACKUP/BDJO/00000.bdjo’: Read-only file system

chown: changing ownership of ‘/mnt/siusti/MAMMA_MIA2_2018_BLUEBIRD/BDMV/BACKUP/BDJO/00001.bdjo’: Read-only file system

It gives all structure of blue ray movie (mamma mia), but it is a lot lines, I can not copy them all here.

Check the settings on your NAS and be sure that you have allowed write access to the drive.

1 Like

I checkd on my NAS (WD Mycloud mirror) all my shares is made for admin with password with read/ write.

I changed my share /mnt/siusti for public , so that now means that I can access it on any computer on my network without any password with read/right posibility.

But any way the same message on transsmision web interfase: read only file system

I tried and joakim_s advise that to run :
ln -s /mnt/siusti /home/osmc/Downloads

and then changed transsmision download directory to /home/osmc/Downloads/siusti
05

But then get such error :
58

So can not understand until the end where is a problem? Brr… Is FSTAB just for read?

Hi,

Please provide the output of:

mount|grep siusti

Thanks Tom.

osmc@osmc : ~ $ mount|grep siusti

systemd-1 on /mnt/siusti type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)

192.168.1.5:/mnt/USB/USB1_c2/CloudUSB1/siusti on /mnt/siusti type nfs (rw,relatime,vers=3,rsize=65536,wsize=65536,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.5,mountvers=3,mountport=50414,mountproto=udp,local_lock=none,addr=192.168.1.5)