"UTMP System Runlevel" Now Stuck in an Infinite Loop

Hey guys,

Hope you’re all going well!

I was just wondering if anyone might be able to assist me with an issue I’m facing, please?

The other night the Vero 4k+ was stuck trying to play a video, with the circle going round & round. So I used the; “stop, start, restart mediacenter” command.
On boot, a black code screen appeared with the following; “Started Update UTMP about System Runlevel Changes” for a few hours.

With no loading dots or really any indication of progress, I entered the commands from this post; Started Update UTMP about System Runlevel Changes - #4 by Truly

After letting the update run, the system no longer responded on the TV, so I followed this post. OSMC Hanging on Boot - #4 by DBMandrake
I think after that I also ran “sudo apt-get -f install” as a last try. Letting that complete, I tried to restart the system the following day (This morning) and now find myself stuck in an infinite loop with the blue sad face.

I have tried to include as much info as I could think of, but if I’m missing something, please do ask. :blush: oh and this is a link to the logs; https://paste.osmc.tv/zajasimivu

Cheers in advance for any ideas!

You installed the Raspberry Pi Version of Mediacenter. I suggest a full reinstall.

Commandline: /usr/bin/apt-get-real install --reinstall rbp2-mediacenter-osmc
1 Like

oh really! wow well thats a bugger. haha

Before reinstalling, would there be any way for me to backup a few things like;
kodi/system settings, autofs mount media sources, media libraries & watched history, current scrapper settings and anything else that might be appropriate or worthwhile?

Cheers

As you still have ssh access you could just copy your /etc/ and /home/osmc/ folder to your NAS and restore them afterwards.

Hi fzinken,
Thanks for the help! :slight_smile:

Just before I do reinstall, I have simply logged into WinSCP & copied the folder “osmc” within “home” as well as the “etc” folder both onto my PC.
After reinstall I simply “copy and overwrite” again using WinSCP

And doing this would make it exactly how it was before reinstall, is there really nothing else I would have to do?
Just would like to check before hand I’ve not missed anything, just in case. :slight_smile:

Thanks again for your help!

Watch out .kodi is a hidden folder under /home/osmc so ensure that you have show hidden folders activated in WinSCP.
Also /etc would need root access.

Maybe easier to create tar containers and then just copy those via winSCP.

sudo tar -cvzf "etc_backup_$(date '+%Y%m%d').tgz" /etc
tar -cvzf "home_backup_$(date '+%Y%m%d').tgz" /home/osmc/

before you run the second command check that you have enough space
du -h will tell you how much size you need
df -h will tell you how much space you have on /

Afterwards just copy the files via WinSCP.

Alternative as you have mapped your NAS via autofs you also can directly write the tar files on the NAS>

Ahh thanks for the tip to unhide!
Yes, I gave myself root just now for the “etc” however, a few files ended up missing after copy, so I will also try the tar containers too.
If copying directly to the NAS, would I simply change “/home/osmc/” to the IP of the NAS?

No you would change the destination folder with the folder you have mounted the NAS.
What is the output of mount?

Found it from your logs. To directly write to the NAS it would be
tar -cvzf "/mnt/192.168.1.9/Movies/home_backup_$(date '+%Y%m%d').tgz" /home/osmc/

ahh. Apologies in advance, my CLI skills are very limited ahah

/etc/auto.nfs.shares on /mnt/192.168.1.9/TV-Shows, thats one of the mounted NAS shares. The other shares are a little disorganised and saturated.

oh haha you never cease to amaze me my friend!
Ohh I see the format now. I’ll have to remember that in addition to reading up on the CLI in general.

Thanks! :slight_smile:

https://duckduckgo.com/?t=lm&q=tar+cheat+sheet&ia=cheatsheet

Ohh very handy, I do like cheat sheets. Thanks! :slight_smile:

heyyy,
sorry to keep being a hassle. However, an error code returned while trying to reinstall.
Removing vero3-mediacenter-osmc (19.1.0-16) ... Errors were encountered while processing: vero3-device-osmc E: Sub-process /usr/bin/dpkg returned an error code (1) root@osmc:~# grab-logs -A
I’m just waiting for the logs to generate, but any ideas in the interim?

Cheers]

What do you mean with reinstall? We were referring to full reinstall therefore you did the backup (BTW did you validated your TAR files have all the content?

Sorry yes Full reinstall using the command from the first post “Commandline: /usr/bin/apt-get-real install --reinstall rbp2-mediacenter-osmc”
Should I do a full reinstall using a downloaded image onto an SD card?

ahh ahha I may have skipped that part of validating the TAR files

That would still be the wrong package!!! “rbp2” is the package for Raspberry Pi. You should never use that package on the Vero. The package for the Vero is vero3-mediacenter-osmc but before you reinstall that you would need to remove rbp2-mediacenter-osmc and all its dependencies which might not be possible. Therefore we recommend reinstall from USB/SD Card.

Just open them and check if you see the files inside.

1 Like

ahh ahah, please do excuse my total lack of Linx knowledge ahah.

Soo, I’ve completed a full reinstalled OSMC onto the Vero, using a downloaded image and the OSMC installer.

But I’m a little confused with what I do with the .tgz files… I’ve put then onto a USB but don’t really know where to go from here…

The cheat sheet didn’t helped :slight_smile:

So login into OSMC via SSH and run the following command

sudo systemctl stop mediacenter
cd /
sudo tar -xvzf <path to your TGZ file>

After you checked everything is in place just reboot.
I suggest to install autofs first before you run the tar command.

Also if you want this all a bit more visible you can install MC and use that to unpack. sudo apt-get install mc

Hi fzinken,

Thanks for the post.

oh it did quite a bit, I suppose that I was a little confused on how to go about it :slight_smile:

If I’m extracting the archive using “-xvzf” current directory, does that mean that the file needs to be placed inside the appropriate folder? EG. tgz etc placed inside the “etc” folder

Or can both the “etc” and “osmc” archives be placed inside “home/osmc” while executing the command?

Sorry If I’m not quite picking up on some of the more obvious details. I’m in the process of configuring an older Procurve and bonded trunks. :slight_smile:

No, the path (without the leading / was stored in the TGZ therefore we change to / first with cd /.
As mentioned if you install MC you can just look into the TGZ to see the strucutre of the files inside.

You don’t need to copy the TGZ first you just unpack them from the USB stick