[v19.1]No Remote and Slow, Jitter like UI while Video Playback

He doesn’t know, his remote doesn’t work :rofl: Hope CEC is working?

1 Like

Does it work when plugged into a PC?

Got a second remote + Dongle so i’m fine ^^
Yea the Original OSMC Remote is working when i’m Booting Coreelec from my SD Card.
But is not recognized in OSMC

Coreelec will change the boot environment on the internal memory. I can’t say how that would affect the behaviour of OSMC.

This was before the fresh install.
After the Fresh install i didn’t inserted my SD Card, so no Coreelec there

IIRC reinstalling does not re-write the bootloader or boot environment.

Please post new debug logs for the remote issue.

How is video playback, now?

Stuck kinda in a different Problem for now haha ^^
After the Bootlogo my Display jitters every second and i can’t get my NAS Server detected…

Already tried a different HDMI Cable.

I will report

Sorry guys for the Dumb question but shouldn’t OSMC have a Browse button in the add Library section?


And no way to add my Nas Share or any Share at all.
Upnp is activated. Browse Tab is missing.


Normaly there was something like this:

Suchen = Browse?

But generally browsing for SMB shares has been depreciated

I installed back Kodi v18.9

Everything is working:
Remote
no Jittering on Screen
fixed Framerates.

Edit:
After installing Kodi v 19 again.

Whats working:
NFS Share
No Jittering on Home Screen (was caused by a default OSMC Resolution Setting of 1080i instead of 1080p or 720p

Whats not working:
Remote Control
Fixed Framerate
Jitter UI while Video Playback

LOG FILES: https://paste.osmc.tv/xidicebefa

Well personally I am always suggesting to use Kernel Based mounts (e.g. autofs).
But for Kodi to add shares check this post

Î found out why my remote is not working on v19.
The second USB Port (if you counting from the front) is dead/not working.
I tried to insert a USB Drive and it didn’t got detected.
On v18 both Ports are working

Interesting find, let us check if we can replicate

For now i fixed almost everything except:
Framerates and “not working” USB Port.

Did you successfully replicate my error?

Will investigate the USB port issue.

Do you know when you purchased your device?

On the 20.01.2020
Edit:
Fixed Framerates working, so it’s only the USB Port left ))

Not sure if it’s the same issue as the jittering but since 19.1 on my Vero 4k+ my subtitles and UI during playback are having tearing issues, much like games without V-Sync. So going back into the menu during playback will have very bad tearing, like half the menu being a few milliseconds late when changing between screens. Subtitles changing between lines will appear partially first before the rest comes too.

My player is set to adjust refresh rate so that would be 24p or 60p in these cases, happens both times. If this were a videogame I’d look for the “V-Sync on” function.

Also experiencing short green distortions in the lower part of the frame when seeking in a video. Might be related since they change in size and position too.

@irockintomordor
Did you check your video Settings?
OSMC defaulted my Video Settings to 1080i instead of 1080p.
This will cause all kind of “V-Sync off” Jitter.
Also a fresh Install could help.

@sam_nazarko
Any news?
One working USB Port is kind of a Dealbreaker for me, cause I’m using it for the Remote.

@Alyx
thanks for the suggestion! It’s one of the first things I suspected but it’s 1080p60 as usual. I’ve played around with settings but couldn’t solve the tearing. Fresh install - maybe when I find the time. I’ll monitor the issue here and on my device.

Still investigating – will get it fixed, don’t worry.

wanted to report, that i checked the power output of the usb port and it does charge my controller.
It just doesn’t recognize any peripheral devices.
I first assumed there was no power because my usb stick didn’t lit up

Maybe this can help you:

lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2017:1688
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

usb-devices


T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 2
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=04.09
S:  Manufacturer=Linux 4.9.113-45-osmc xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=xhci-hcd.0.auto
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=2017 ProdID=1688 Rev=01.04
S:  Manufacturer=OSMC Remote Controller
S:  Product=USB Keyboard Mouse
C:  #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid
I:  If#=0x1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=01 Driver=usbhid

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 0
D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=04.09
S:  Manufacturer=Linux 4.9.113-45-osmc xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=xhci-hcd.0.auto
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=(none)