VC-1 playback improvements

There have been some issues with VC-1 playback, particularly when the Adjust Refresh Rate feature is being used.

We’ve worked on some improvements that will hopefully improve things in a lot of cases. Unfortunately it’s not a magic bullet, and we are still dependent on the introduction of a bitparser for VC-1. We expect this to land sometime in the near future in Kodi v18 (Leia).

It would be great to get some feedback about this. To test these improvements:

  • Ensure that your system is on the latest version.
  • Go to My OSMC -> Updates -> Manual Controls.
  • Under Apply Hotfix, enter (without quotation marks): [deprecated]
    Your device should now reboot.

I’m keen to hear your feedback


I downloaded the three VC-1 video clips from

Without the hotfix only the two 23.976 fps samples doesn’t look being played smooth (micro surges) but sound is absolute correct (I use pass-though to a 7.1 AVR processing all sound formats).

Before I install the hotfix and report: How do I revert back to previous state?

I’ve to correct my statement: After playing the 23.976 fps samples for 20-30 seconds and longer, video and sound are totally out of sync and sound gets cruel drop-outs. The 29.970 fps sample plays fine till the end, my TV shows 60 Hz.

This is before or after applying the hotfix?

Still before. I will not install the hotfix without knowledge how to revert the change.


If the changes are not satisfactory, you can use ‘xaviwinaro’ in the hotfix dialog and follow the steps above to restore the system.


Bad news here: Installed hotfix goyamopiza, system automatically rebooted … but the problem persists means the 23.976 fps samples show permanent video surges/stutter and sound gets drop-outs after around 30 seconds; some seconds later my AVR shows me “no stream” for the sound.

Uninstall hotfix xaviwinaro seems to hang somewhere

15:11:39.411 T:3792434160 WARNING: script.module.osmcsetting.updates : User entered hotfix ID - xaviwinaro
15:11:39.411 T:3792434160 WARNING: script.module.osmcsetting.updates : Retrieving hotfix from -
15:11:39.772 T:3792434160 WARNING: script.module.osmcsetting.updates : HotFix Result - sudo apt-get install --reinstall vero3-mediacenter-osmc/jessie
15:11:39.782 T:3792434160 WARNING: script.module.osmcsetting.updates : Description - No description available
15:11:39.783 T:3792434160 WARNING: script.module.osmcsetting.updates : Instruction - [u’sudo apt-get install --reinstall vero3-mediacenter-osmc/jessie’, u’reboot’]
15:11:39.783 T:3792434160 WARNING: script.module.osmcsetting.updates : Resolution -
---------------------- Kodi Log END --------------- HyhIT4UP

Will try to reboot via ssh.

We tested with the intro of The Shining (HD-DVD) rip. It’s got a lot of panning shots which makes judder very easy to see.

Can you paste the output of: paste-log /usr/bin/mediacenter. I want to make sure the fix has been applied correctly.

For downgrade, you can just do sudo apt-get install vero3-mediacenter-osmc/jessie. The hotfix was for those not familiar with SSH.


Reapplied hotfix goyamopiza, verified problem is still tere, paste-log /usr/bin/mediacenter:


Looks like the fix has been applied properly. So this may be a problematic VC-1 clip in particular. @bmillham reported some success. Unfortunately we can only improve VC-1 to an extent until we move to Kodi v18; but I want to check that the changes we have made are being applied properly.

When you get judder, can you paste the output of cat /sys/module/di/parameters/bypass_prog. It should be 1 for VC-1; otherwise 0 for any other content.


I tested this last night, and everything I tried played fine. All are direct BD rips (using MakedMKV)

The Mask
Purple Rain
The Shining

Do you have other clips you can test?

cat /sys/module/di/parameters/bypass_prog - is always 1 while the play.

Fair deal to save my time: I showed you the clips I used for the test (see my first post), you show me the clip(s) I should test for you.

My clips are all complete BD rips, so not easy for me to share.

But I think we know where the problem is. Looks like the hotfix wasn’t quite right. Sam’s looking at it now.

Just for fun try this:

sudo chown osmc:video /sys/module/di/parameters/bypass_prog 

and then play your clips again. (Do not reboot)

1 Like

YES, that let play both problem VC-1 videos correct. :+1::v:

Cool, so the hotfix for some reason didn’t change permissions correctly. @sam_nazarko will have a fix again soon I bet.

The chown is only temporary. It will revert after a reboot.

I go back to previous state using sudo apt-get install --reinstall vero3-mediacenter-osmc/jessie

I see the issue. It’s a typo (late night).

@JimKnopf I’ve updated the original hotfix in the 1st post.


1 Like

Can confirm that hotfix ibeyinusog makes his job for all VC-1 video clips from the kodi sample URL. Video and sound is synchron, no video judder, no sound dropouts. Tested some other coded videos, all ok.

1 Like

Brilliant. Thanks for testing.

Hopefully we can get some more feedback from others too.


OMG I was actually giving up on VC-1 support on Vero 4K but every single movie I have with VC-1 works perfectly now! Thank you thank thank you Sam! Tested over 20 Blu Ray movies that I have thanks to Makemkv and they all work great.

Do we have to apply this fix every time there’s an update for Vero 4K?

1 Like

No — it will be in the next update