Vero 1 died after June update (due to borked kernel, update available)

Got stuck on OSMC logo, and now it bootloops with sad face.

Which version were you on before?

It looks like you were on a really old version of OSMC. Perhaps one of your skins or add-ons aren’t compatible with the latest version of Kodi.

Try mv ~./kodi ~/.kodi-backup and see if Kodi starts. If it does, it may suggest you have a bad add-on or skin.

I had the may update, but reverted kernel since wireless died on that update. Otherwise it was bought on release and updated since.

Have you tried my suggestion above? That will rule out a bad add-on or skin.

Yes - kernal fails and what not and bootloop even before kodi starts. Maybe file system corruption when I pulled the plug on first logo hang.

If your ‘kernel fails’, then you would not see the sad face. The sad face means that Kodi is not starting / is crashing. Please post a debug log if this issue persists after verifying you have moved ~/.kodi.

If you pulled the plug during the update, you may have indeed caused some corruption.

Having the same issue. Even did a fresh install of the May release. Then did June update. Vero 1 won’t go past OSMC splash screen.

Since I had problems with may update not enabling wifi at all I guess something could have gone wrong there when I updated to june version over wifi. I tried to do a clean install from the may version, and then wifi is not selectable in my osmc.

I’m updating to june update again now on that one to see if I can get it working again.

Otherwise I suspect the new faster clock on the Vero doesn’t work reliably on all hardware. Mine is one of the absolutely first batches delivered.

I will investigate this issue for you and let you know when I have some news

The Vero should handle 1.2Ghz fine, I tested all batches to ensure this won’t cause any problems. Due to a variety of improvements, the device actually runs cooler at these speeds than it did at 1Ghz



I’m getting the same issue. I’ve imaged the SD Card to the May release and re-updated. Same problem.

My Vero gets to the OSMC logo screen and then reboots, no smiley face, and not sure if it’s my imagination, but it seems to vary the amount of time before rebooting.


Clean may install works (but no wifi)

Updated to june in GUI.

This time wired.

I get two different kernel panics with 5 sec reboot and then sad face and then stuck on OSMC logo. So june update effectively kills my Vero 1.

Same issue here, OSMC splash screen and then reboots. Same errors on screen like ogre showed. Was on may-update before.

Same for me here! After the update my Vero loops in panics. Last action I can see on my TV is a black screen and a switch to 16:9 format (shown by the TV) and then comes the kernel panic; I watched 5 panics with 5 different stack traces.

I fear I’ve to re-install from scratch and will try this now.

I will have a solution for this as soon as our build system permits. I will provide some background in to the issue and explain how existing, affected installations can be fixed.

Stay tuned



jfyi: Re-installed the Vero with current image on (2016 May), entered the data in the setup wizzard (language, timezone, skin) … and directly let run an update with 2016 June.

I saw one kernel panic (time too short to catch the info), a reboot and now a black screen without any further info. The box is not active in the network (no ping answer, no ssh, etc.).

So, since this is a out-of-the-box scenario, I would suggest to deactivate the June 2016 rollout for the Vero 1 asap until it’s fixed.

Greetings from Germany,

1 Like

I too have the same issue. fwiw

Just to add that I have the same issue.

Ever since this update, my Vero keeps crashing, rendering it unusable - in menus when browsing files (showing only a frowny face emoticon as an error message), during video playback (freezing the image and looping the last fraction of a second of sound).

I was running the May version before this. I am not using any custom skins or apps or anything - everything is default.

EDIT: I just tried the suggested test with moving .kodi to .kodi_backup, and the crashes continue to occur.

I have the same issue.
Updated through GUI. Vero reboots and stalls at the OSMC splash screen
Pull power and power it back on again. Vero crashes a few times and I get a sad face. And thats it.

Reinstalled May image and updated from there. Same story. Vero crashes.

Now I’m trying sudo apt-get upgrade…


As promised – a solution is on the way. I’ll post here as soon as it’s ready.

Just a heads up – you should never do this, on any system. dist-upgrade is the correct command.


Well I learn something every day :slight_smile:
I’ll do a dist-upgrade then. And report back

After apt-get upgrade I did a manual power OFF/ON (a reboot just hangs on a black screen)
But i came up again, and was working (but not fully updated)

I ran the apt-get dist-upgrade, and now I’m having the crashes and sad face again.

I installed May version again, and wait for a fix :grinning:

I know you are working hard Sam, Thanks