Vero 1 died after June update (due to borked kernel, update available)


I have had a look at the issue and it seems that this is unfortunately caused by some changes made by Freescale to the kernel. I think it’s safe to say we should trust our own judgement in the future, and avoid upstream changes from them.

Updating from the May version will no longer cause an issue. For those previously affected, we can recommend the following sequence of steps to rectify the issue:

  • Attach a keyboard to your device
  • Hold CTRL when booting
  • Login as ‘osmc’, 'osmc
  • Type sudo apt-get update && sudo apt-get dist-upgrade -y && sudo reboot

Your device will then be back to normal.

Thanks for your patience.



Updated from May release trough GUI.
Vero installed the update and rebooted.

Hmm… Now I get a lot of sad faces. Black screen, sad face, black screen sad face ect.
It is a different behaviour then yesterday.

Well… I’ll try with May again and then list-upgrade.

dist-upgrade did the trick for me. Everything is working again.

I use Vero for live TV, and it feels a lot faster. Channel switching runs much more swift now.

Thanks Sam.

Tried this on my original system, and the kernel upgraded fine, but there was an error updating perftune-osmc.

also sudo reboot fails (time out)

So I guess there will be corruption if i pull the plug…

Finally it rebooted after using ctrl-alt-del (or some timeout)

Managed to do sudo apt-get update && sudo apt-get dist-upgrade again and it configured perftools. Did sudo apt-get autoremove to get rid of the borked kernel, and now it boots!

Will try to get wifi working again as well…

Successful boot with cable unplugged:

Wifi working, and we seem to be back in business.

Thanks Sam!

Great to hear.

Note to self: ignore Freescale changes… They cause problems.


I can’t get to any prompt by holding CTRL on boot. I only have a Mac USB keyboard. Will that not work? I’ll try tomorrow with a PC keyboard then.

Try pressing alt-f1 if you get a GUI in case it doesn’t switch to the right tty.

Tried that, but doesn’t seem to work. Guess I have to wait until tomorrow when I can get a PC keyboard and try that.

Worked for me (though I did it via ssh for convenience)! Thanks for the quick response!

1 Like

I’m having no luck with this. I have run it several times with no joy. Same sad face, OSMC, skin, sad face repeat.

Did you update the kernel?

What does uname -a show?

can you tell me how to update the kernel?

Follow the dist-upgrade tips above


is what I ran

should I also run

sudo apt-get autoremove

What was the output of those commands?

What does uname -a now show?

They executed, when it was installing the vero image it stated 4% complete and then it rebooted.

Remember I had an issue with lip sync, you told me to revert the kernel. Was I on an older one than these commands would work with?

Can’t get to the machine at the moment to do the uname will post back when I can.

Osmc 4.4.12-3-osmc #1 smp Jun 6th 22:01:46

Ran the commands again. All is good. Thanks for the quick responses.

More than welcome :slight_smile:

That kernel doesn’t quite seem right though – it should differ after your original posting an hour ago and should be 4.4.0 based.