Vero 2 - Initial Feedback

I received my Vero 2 yesterday, and after battling through the horrors of my normal working day I dashed home to get it all set up. Here are my early thoughts on it, as an upgrading Vero user.

Build quality is excellent. Not that Vero 1 is shoddy in that department, but the flatter/more ‘Apple TV’ style look for Vero 2 is - to me at least - more pleasing. With the form factor, and the fact it’s in black, it doesn’t stick out so much when compared to the rest of my AV equipment. And although you only open it once, the packaging is of high quality. Not so great for the environment, what with Vero 2 being in a box, which is itselt in a larger (and sturdier) box - but with the packing material used, I reckon it’s well protected against any ham-fisted delivery personnel.

All told, it took no more than 10 minutes to get it set up - with most of that time being me fumbling around a stupidly inaccessible part of my AV setup to plug the power adapter in.

The jump in performance between Vero 1 and Vero 2 is pretty clear as soon as you start navigating the UI - everything is super smooth, and even something as (relatively) minor as this makes it feel much more solid as a product.

Before I unplugged my Vero 1 I did a backup of settings to my NAS, thinking that I could just restore them to my new Vero 2 - but had little joy with this approach. Maybe I made an error, but while my paths (ie: the SMB paths to my NAS where I store my music/video content) were restored, attempts to use those paths failed. Looking in the list of sources, there wasn’t an entry for my NAS itself, so I’m assuming that the authentication (user/password) associated with the SMB source wasn’t restored. Thankfully it didn’t take long to delete my existing sources, add a new SMB source, and then a couple of shares to my video/music sections - but due to having to do this I’d ended up losing some of the metadata associated with my video - I don’t use a library as such, but I do (did?) like that OSMC knew I’d watched/partially watched the files in my various video directories.

There’s a blue light on the front of Vero 2 which shines oh-so-brightly. I’ve already raised this with Sam on Twitter, and there’s an idea to make it only illuminate when the remote is being used. I’m very keen on this, as the blue light is intrusive as it is as the moment.

I’ve got my Vero 2 connected via HDMI to a Denon AVR-1912 receiver, and that receiver is connected to a Sony 55" X9005B TV. I notice that on power-up of the Vero 2 (and also during a reboot cycle initiated from within OSMC itself) that my TV now spits out a message about audio not being supported from the receiver and switches to TV speakers - and then when OSMC is booted up, the audio from the receiver is deemed to be there/OK, and audio playback then commences from my speaker setup. I’m assuming there’s some sort of boot-up state associated with the HDMI output on Vero 2 that results in no audio format being specified - and only when it’s initialised later on does it actually then push through what could be classed as a valid audio format. I’d be interested if there was a way to address this - I’m at work right now, so no logs handy, but can create/provide them if this would be of use in identifying the root cause of this. It’s a minor niggle though, as when OSMC is up everything works perfectly as far as audio goes.

Speaking of audio, it did worry me a little to see less audio functionality in the settings for Vero 2. There’s a DTS MA option there that’s disabled (I think it says it’s only changeable while watching DTS-MA source material - but maybe I’ve misunderstood that, as it would mean you’d need to pause your video, hoof it over to the settings, change this option, and then carry on watching). A quick search here shows that - initially at least - there’s no DTS-MA/HD passthrough, but I’d hope that this is still on track to be added. I think there are fewer varieties of Dolby present on Vero 2 at this time too?

The only visual glitch I’ve seen so far on Vero 2 comes when the screen resolution changes. It’s like the HDMI output isn’t being blanked around the resolution changes, so when transitioning between the UI (whether it’s 720p or 1080p) and a video (at whatever resolution is deemed suitable) then there’s a flash of a screen that looks like static. Typically you see this when starting a video, and when the video terminates and you transition back to the UI. I’ve confirmed this with/without having the refresh rate of the display match video (eg: it doesn’t matter if I’m transitioning to/from something like 1080p or 1080p/24… still happens).

Vero 2 seems to handle CEC natively out of the box - no libCEC stuff included. But there’s no way of disabling CEC from within OSMC’s settings, as far as I can tell. In the end, I’ve disabled menu button actions over CEC on my TV (as I was wanting to bring up the TV UI to check that output was at 1080p/24) - which gives me a short term fix when necessary.

New OSMC remote is awesome, btw. Solid feel, and I’m much happier with it being RF, as I’m no longer stuffed by line-of-sight issues as with Vero 1’s original remote.

So far, extremely impressed with things. For what’s essentially the first build of OSMC on a new platform (ie: different SOC), it bodes well for the future of the device and for OSMC.

Thanks!
Dean

3 Likes

Regarding to your audio formats statement Sam wrote this in the vero 2 introduction thread:

And CEC, I think you can disable it in via kodi settings > system > devices there disable the cec entry.

The Vero2 is currently supporting CEC via a kernel driver that sends standard Linux input events to Kodi, it is not using libcec, thus there are no CEC controls in Input Devices->Peripherals as Kodi is not handling the CEC directly itself as it does on other OSMC platforms.

I’m not sure if this is changing in the future but for now you can’t disable CEC through the Kodi GUI.

Ok, thanks for the info. So for me using CEC it sounds like good news and less problems with involved tv and avr. Ideal would be if Vero 2 itself could start both avr and tv. I’ll see, still waiting for the Vero 2 to be shipped whereas others already got it =/

Had a very quick play with the Vero 2 last night, and was very impressed with everything. Simple, familiar set up, coming from using OSMC on the RPi 1, although I’ve not brought across my library yet, it was up and running in 5 minutes.

The speed of the GUI is very fast, and i was skipping about between menus with out delay. The remote feels very sturdy and nice buttons. not rubbery, squidgy ones, and worked straight out the box.

The only slight problem i had was getting my AV Reciever to recognise all the audio channels when i tried to send the 7.1 DTS-HD track over PCM, it was not picking up the Sub channel… It was quite annoying, hence me skipping around the menus so much looking for the problem. In the end the problem turned out to be my Amp set up. My speakers were set to large, rather than small, and this was causing the amp to ignore the Sub channel for some reason. This doesn’t happen when I passthrough on my pi (just using the DTS core) so not something i’ve ever come across.

One question. I normally set OSMC to passthrough the audio to my AV Reciever then set my Reciever to PURE DIRECT mode, which stops any processing on the amp and turning everything off to eliminate noise…

With Passthrough this works fine, however when doing this with my DTS-HD track set to PCM (to take advantage of the hd audio) when i hit the PURE DIRECT button, it reverts to only 2 channels. Is this normal?

Thanks to the OSMC team, I’ve been using your software for a year now and think it is great.

Nice first impressions! Also, for some reason, it’s comforting to know that other people out there suffer from those nasty working day horrors as well :stuck_out_tongue:

If you still have the original library on the Vero 1 you may be able to export your watched status using Millhouse’s texturecache utility:

You would run it on the old system with the correct command line options to export watched status to a file, copy the file to the new system then run it there with the correct options to import watched status.

Provided that the names of the Movies / TV Shows in the new library are the same after scraping as the old library this should work. By default it will merge with any watched status that you have already saved by watching video on the new system - it will keep the most recent watched status for each file.

1 Like

Thanks, DBMandrake - that sounds perfect. I’ll give that a go! :slightly_smiling:

It would probably be easiest to just copy over your databases to the Vero from your Pi then when you start Kodi they will update to the correct version. Of course you would need to delete the existing databases.

Another reason I’d really appreciate some form of CEC control (that I’ve just noticed) is that when I turn off my TV, my receiver also powers off - and Vero 2 then brings up the dialog to shut down (exit/power off system etc).

On Vero 1 you could obviously configure all of the CEC behaviour via libCEC, but I’ve no way of preventing OSMC from trying to shut down at the moment.

is there a way how to modify CEC parameters at least ? For example setting Vero not to switch TV source when it starts and other options from that category.

We experimented with that, but it gave DBMandrake boot issues. I will revisit it again shortly.

There will likely be a libCEC port in the future.

Sam

Just to quickly follow up on this, after an evening of testing - I think I was incorrect in my assumption about this being related to resolution change/hdmi blanking. I think it’s more likely showing a frame of corrupt data from the video decoder based on the visual aspects of it. Or showing invalid/freed video memory. Something like that.

If it’s not being seen by others, I’ll get a video uploaded tomorrow so you can see what I mean.

Dean

Sounds good.

Also get some debug logs if you can.

Will investigate

Sam

I was under the impression there was a dedicated button on the remote to switch to android???

[quote=“doogdeb, post:15, topic:13344, full:true”]
I was under the impression there was a dedicated button on the remote to switch to android???
[/quote]Nope… My understanding is that you’ll just be able to exit from OSMC and then it will rapidly boot up into the Android environment.

The Android image will be ready soon. You’ll just select Reboot from Kodi and then Android will boot instead

Sam

Loving the VERO 2. Speed seems great.

However, for somereason my library isn’t building. Tried both network and local sources but it doesn’t add anything. Pressing update library does nothing. Can’t figure out the issue. I’ve changed skins and worry this has upset something, so is there a way to reset kodi in sense of back to factory? Feel like something has got corrupt somewhere along the lines.

A debug log will show us why this isn’t working

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

A separate thread may be better as your post won’t get lost in this thread which will likely become crowded soon

Sam

1 Like

I ended up having to use the “fresh start” add on from fusion repo. Works fine now. Something must have just got corrupted somewhere but ffine now! Isolated incident. Vero 2 is looking great.