Vero 2 not really usable so far

Hi,

So I git my Vero 2 last week and finally got it running today as I needed some cables etc. I ordered it because I had tested KODI on my PC (laptop), it ran very well so I thought I had found the perfect device to set up my home media library. My idea was/is to copy all my media to WD MyCloud device on my home network and run it from there. As mentioned it worked just perfectly from my PC, but I wanted a more convenient way of doing it.
I connected the Vero to the home network and internet via cable, ran the update which went fine, added the My Cloud the same as on the PC and that’s when the first problem appeared - it was unable to update the library. It found the media files, but was not able to connect to the media data base server, so no videos were showing up in the library.
If I go into network settings everything seems fine, but when I go into the status menu, it shows there is no network connection. But I was able to run the update…

Of course the files were there and I could access them via ‘Files’, but then the second problem - my PC is connected to the home network via WiFi and was able to play the files. The Vero is connected via cable and every time I try to play a file it keeps buffering every 10 - 20 seconds, depending on the video quality, file size etc. It’s impossible to use it.
I have seen videos on youtube people having the same setup as I using only the Raspberry Pi so I expected the Vero 2 should not have any problems doing the same. I have a high quality router, no cheapo and both the MyCloud and the Vero are connected right to it.

And while I was setting it all up the device (remote?) froze and crashed a couple times.

Not mentioning the freezing and crashing, is there anything I could about the first two problems or do I just ship it back?

Help would be much appreciated, thanks!

What protocol are you using to share from the MyCloud? SMB/Windows sharing? How are you attempting to add to library? Videos>Files>add Videos then what?

I used the same procedure I tested on my Windows PC. So from there I went to Browse>Add Network> used smb, added the IP address of the MyCloud manually and all went well from there, except for it not being able to “connect to the remote server” to obtain the info from the Movie Database and the constant buffering.
I also tried Browse>Windows network (SMB)>Homegroup>…, but the result is the same.

Any advice…? :-/

Not familiar with the WD MyCloud but if it is a NAS it should also support NFS - can you try connecting via NFS ? SMB support on the Linux versions of Kodi is not optimal, you will generally get better performance using NFS.

Also you have not said what the bitrate of the videos you’re having problems with are - you can get a rough idea by pressing O on a keyboard or the context menu button during playback which will bring up the codec info page.

I use a Mac Mini as a file server at home and my remote Kodi installs all use NFS to connect back to the Mac, including the Vero 2. I am easily able to stream 60Mbps+ test videos over NFS to the Vero2 without buffering. This is more than enough to play even full bitrate Blu-ray rips.

Also check to see whether your NAS supports iperf - some do. If it does you can install iperf on the Vero 2 and run a direct network speed test between the two devices outside of Kodi.

1 Like

Thanks for the advice. I connected via NFS and yes it got better, but the videos still tend to freeze from time to time and while they do the audio keeps playing and sometimes goes out of sync.

Here’s the info I got on the screen:

Today I also got an update “Add-on error”…

Please search. The add-on error has been covered many, many times today

1 Like

Regarding the network, this is what I get under System info

It thinks a while, a Mac Address appears and under Internet it says “No connection. Please check…something something”

Here it says: connected

Can you login and try ping 8.8.8.8. The connectivity indicator is not always a good way of verifying network connectivity.

Sam

Can you explain a bit more? I’m not that advanced. Log in where?

@Kato.

Just an FYI.
It’s perfectly safe to show your internal ip address in screenshots.
This is mine.

And these are the internal ip addresses of every device on my network

Indeed. And it makes it harder to diagnose the problem if most of the important information is hidden…

I’m just being careful. :slight_smile: And I guess it does not really matter…?
This is exactly what I would see in Kodi on my PC, but on the Vero it’s seems to be changing the MAC address, like searching for something.

Your internal IP addresses aren’t accessible to anyone that isn’t on the same local network as you - millions of people around the world have internal networks using the same IP range as you.

The MAC address will not be changing. The System Info screen in Kodi is not a good place to check network settings - My OSMC->Network or checking from the command line will give you a more truthful indication of the network.

The second image I uploaded is from My OSMC->Network. So I guess it’s working. Still I cannot access anything on the net.

If you say the MAC is changing then I need to see that. Can you take some photos?

Sam

I checked, it’s not changing, but it disappears and says “Busy”. When it appears it’s 00.11.22.33.44.55 and says “Not connected. Check internet connection”. Then it goes into “Busy” mode again and then back. All the time.

Busy doesn’t mean you are not connected to the Internet.

Can you run a simple ping test?

Sam

As I mentioned, I’m not sure how to do that on the Vero…