Vero 2 Please stand by loop

Got my new Vero 2 today. Imaged the SD card (10-2), plugged in, setup, everything looked great. I then downloaded the latest update (november). the box updated and rebooted as per normal but never came back to life. After 10 minutes or so I switched the power off and then back on again and I got a “please stand by” message flashing in the centre of the screen. I left this for another 15 minutes or so but nothing happened.
Since then I’ve rebooted several times (power off and on) and finally re-imaged the SD card but I’m stuck at the same “please stand by” screen everytime.

Any ideas?

Hi

Did it boot up before you imaged the card?

What did you image the card with, Android or OSMC?

Did you try https://osmc.tv/wiki/vero-late-2015/reinstalling-osmc/?

Potentially try another card as well; just in case it didn’t setup the system properly.

Hi Sam,

the card was blank when I received it. So I downloaded the windows installer and installed OSMC 10-2. Everything worked fine after that until after I tried to install the latest update via MyOsmc

Hi

Thanks for clarifying.

Can you try confirm if reinstalling works? I.e. does the OSMC installer come up?

Sam

It didn’t. When I powered up following the re-image I got the please stand by message and nothing else. I’ve just re-imaged again in case there was an issue. I’ll see what happens this time.

No. same again. straight in to a black screen with a flashing “please stand by” message and small OSMC symbol

Re-image with the October image.

SSH in and run

grab-logs -A

and post the output

Then run

sudo apt-get update
sudo apt-get dist-upgrade

And post the output. Then try a reboot and see how it goes.

Sam

Are you pulling the power after reinstalling?

OSMC should reboot automatically after installing. Pulling the plug might result in an incomplete installation.

Do you ever boot in to OSMC?

Sam

I only pulled the power after it hung for 10 minutes or so. Now I can’t get past the stand by screen.
After re-imaging the card, I put it back in the Vero and switched the power on but it hasn’t gone in to the setup routine it’s just gone straight to the “please stand by” splash screen.

How do I SSH to it? I don’t know it’s IP address and I can’t see it on my router admin.

Please follow these instructions:

https://osmc.tv/wiki/vero-late-2015/reinstalling-osmc/

Sam

That’s what I did first time although I didn’t remove the SD card before running the MyOsmc update. now if I follow those steps, this but doesn’t happen:

Power the Vero 2 and you will see the installation on screen

when I power on I just get “please stand by”. I thought the OS ran off the card like the Vero, I didn’t realise it was installed on the Vero 2. Have I corrupted the internal install somehow?

I’ll try the reset mentioned in the trouble shooting section.

That would be my suspicion. You should have been able to boot the Vero without any SD card; which is why I was a little confused as to why you imaged a card.

Try the troubleshooting section; let me know how you get on

Sam

The reset seems to have got the installer working. Fingers crossed.

It’s probably me missing something but as the Vero needed an SD card I assumed the Vero 2 did also. The page I purchased it from says at the bottom “requires an SD card”. I never even tried to be the Vero 2 before I’d imaged and inserted the new SD card.

Maybe it’s because I’m use to the PI and the Vero but it might be worth highlighting this somewhere. If it isn’t already! :slight_smile:

Ah sorry, it’s Android that needs an SD card for dual booting.

The card will come in handy for reinstalling OSMC

The Vero 2 has 8GB of internal storage

Sam

Now I understand :slight_smile:

The reset has worked and all seems good this time.

Thanks Sam

Glad to hear – let me know if it plays up again.

Hi Sam, I think I may have been a little eager with my assessment that everything was OK after the reset. They system looked fine after a complete reset and I left it booted up at the home screen for several days as I wasn’t available to finish the setup.
I’ve started again today but with no joy. I’ve had lots of little problems, CEC wouldn’t work and the OSMC remote was very intermittent. Ignoring keystrokes and then going in to rapid repetitive loops but the biggest problem is that every time I reboot the system, using the GUI not pulling the power, everything hangs. The bright blue LED on the front of the box lights up but the system never restarts. I’m left with no choice but to pull the power but every time I do that it appears to corrupt the internal memory and I get back to either the stand by screen or a screen that says the /dev/vero-nand/root can’t be found.
I’ve had to re-image an SD card and do 3 forced resets today. Each works at first but eventually dies in the same way.
Is there any chance I have a malfunctioning unit? I’ve never had these type of issues with my Vero1

Possibly yes

Are you sure the USB dongle is plugged in the rear port? If you plug it in the side port you will experience these problems.

A log from My OSMC when the system is up would help.

Have you tried sudo reboot via SSH? What happens?

The USB is in the side so hopefully that’s one problem easily solved :slight_smile:

I’ve not tried anything via SSH so far, I’ve just used the shutdown / reboot from the GUI. I’m just re-imaging again. Once I get it started I’ll get an SSH session setup before I do anything else and see if I can still get access to the system that way when it hangs this time.