Vero 4K - A few issues (new customer)

I just received my new Vero 4k as a replacement for my NUC i5 (which isn’t capable of decoding 4k h265) running Libreelec. After setting up everything there are a few issues left that I’d like to talk about:

IR reception:
I want to reuse my old XBOX360 remote that did a good job on the NUC but the IR reception of the Vero is somehow limited, I need to point the remote exactly at the Vero whereas the area to point at with the nuc was way broader.
Ok, so i thought I’d connect the IR extension cable to the Vero and tape it onto the frame of my screen but this thing seems to be defect, as the range is limited to about 1 meter. Going further away there is no reaction from the remote.

XBOX360 remote:
I reconfigured the keys of the XBOX360 remote by using “Keymap Editor” but I cannot configure the large X button of the remote.
Also I think the default mapping for this remote on Libreelec was way more complete by default.

When using the RF-remote and an IR-remote in parallel, how can I reconfigure the keys for both devices? Let’s say I want to have “Delete file” on the RF-Volume-down key and the IR-X key. I can only map it to one key with the Keymap Editor.

As my receiver can’t passthrough 4k HDMI I connected the HDMI from the Vero directly to the beamer and connected the receiver by TOSlink. I configured to use Analogue/PCM as audio out and set the speaker config to 5.1. When playing a movie I could only hear the surround channels.
I enabled passthrough and disabled all HD formats, it still didn’t work. Finally I found a working setup that plays all channels, but this is somehow not very self explanatory.

Banding on 4K-HDR:
As this is currently worked on I will not ask about this here, but I also see it (Sony VW260 projector).

As standby can switch off the blue led and turn on the red one it would be very nice to be able to disable the blue LED on power-on, as this thing is really way to bright to have it standing underneath the screen (needed for IR).

I was positively surprised that it’s no problem to play my highest bitrate UltraHD bluray (Planet Earth II) via NFS without any stuttering, it seems the 100mbit LAN port is not a problem for me at all.
When copying the same file to my external harddrive and playing it locally on the Vero it sometimes stutters! The drive is NTFS formatted if that matters and reads with >100MB/s on my PC with USB3 port.

When accessing the menus “Videos” (I added 5 NFS sources here), Movies (about 200 movies) or Series (about 20 series) the Vero sometimes hangs for about 10 seconds or more, this was never a problem with the NUC. Is this due to the slow LAN port? Would it help to add a USB-GBit LAN adapter?

And as a little sidenote, the Vero is that lightweight that my cables move it up from the sideboard it sits on :slight_smile: Maybe put a metal plate in the next revision of the Vero to make it feel much more valueable and steadfast. Ah, and one more thing… the USB ports are a pain in the a**, they are so tight I fear I damage the little device when inserting a plug!

Thanks in advance,


Sorry for the delay in response here and thanks for your feedback.

Which port did you use for the IR extender?

You can do this in theory by setting a custom keyboard.xml for each device, but this requires modifying quite a few Kodi files.

This should be HDMI.

SPDIF can only carry 5.1 as DTS or AC3, so you should set # of channels to 2.0 and enable AC3 upmixing.

Unfortunately it’s not possible to turn off this LED.

Hard to say: are you using a shared library?


If the audio on the movie is Dolby Digital (AC3) or any DTS format it should play through S/PDIF with passthrough as Sam says. If it’s any other format, vero will be sending PCM 5.1 through S/PDIF but only the front left and front right channels will be going through. You then need to enable AC3 transcoding to get all the channels. Maybe that’s the setting you found.

AC3 upmixing should not be necessary. And if you use passthrough the device you choose for output should be irrelevant.

Yes, it’s not very self-explanatory.

Meant transcoding. I don’t remember off the top of my head how it’s labelled in Kodi.

Hehe, no probem. Noone expects you to work at the weekends!

I tried both ports for the IR extender, one of them did nothing and the other one works, but as I wrote just to about 1 meter distance. The inbuild receiver works from 4-5 meters, but the reception range is quite limited.

About the hang on menu access:
I store my files on a 10GBit-NAS with high network performance and access it by NFS. On the NUC all menus open within one second, never experienced any hangs there. It’s not a shared library, I only use it on the Vero.
I just got a realtek-based GBit USB adaptor and tried again, it’s exactly the same. Could the performance be increased by switching the database to mysql?

I used to run automatic library updates on startup, but as I cannot shutdown and reboot the Vero with the remote what is the recommended way to update the library now?

Thanks for your help!

I would suggest you provide debug enabled logs to figure out what goes on in that 10 seconds.
when you share the URL of the logs write roughly in which timespan you entered the menu for easier finding in the logs. If you don’t know how to produce debug log, check How to submit a useful support request - General - OSMC

I can get some very long delays (on occasion, infinite!) accessing my ‘NAS’ which I had put down to spin-up time of the HDD, but maybe there’s something else in play here. Will watch with interest.

It seems to be a “problem” with my skin, I am using “Rapier” (OSMC or default Kodi skin are not hanging).
The log is:

Activating Movies at 15:10:06.061
Activating Series at 15:10:18.904

As far as I understand the logs it’s from building the XML file with the content from the database entries. What do you think?

Fixed the hanging now by changing skin configuration settings for low-power devices.

The IR problems remain! Please give me some infos on this. Thanks.

Did you put the IR receiver in the right port?
Which remote are you trying to emulate?


As there are 2x 3,5mm ports on the Vero and they are not labeled I tried both.
In one of the ports the remote is not working at all, in the other it is working, but as I said only in a very little range, about 1 meter.

It’s a XBOX360 remote, the backlit original Microsoft one.

I have used this remote for testing, but have found it slow to respond.

There are a lot of factors that can affect IR performance.
Do you have good line of sight with the receiver?

I used it for years with my old nuc and openelec/libreelec with good results. I taped the IR Receiver at the lower frame of my projector frame, the line if sight should be perfect. But when moving away from the frame to the sofa, which is about 4 meters away, the reception stops. Using the inbuilt receiver I can control everything, but the remote must be pointed exactly at the Vero, which sits on a lowboard, so I must point it downwards, which really sux :wink:

Just a thought …
If the battery power is low in the remote, then the IR signal will be weak and the range will be short.
Maybe try new batteries in the XBOX360 remote?

1 Like

The batteries are full, when the batteries run low on this remote, the button-backlight stops working.
Using it with the built-in receiver works fine over the whole distance (except that I need to point it straight at the Vero).

XBOX360 remote and Vero 4K using the Vero remote control USB dongle, then the range is 4 meters.
XBOX360 remote and Vero 4K using USB extender, then the range is 1 meter.
Is that correct?

Hey andobearg,

I am talking IR not RF here.
There is an integrated IR-receiver in the Vero which can do the full distance, the external IR-extender can only do 1 meter.

The internal components (receivers) are the same.

That’s what I thought and that’s why I think that either the IR extender or the port on the Vero is defective.


Which socket did you plug the extender in on the Vero 4K?
There are two 3.5MM female sockets.

sorry, I see that you tried both, and it worked in only one (with a range of 1 Meter).
Does it work without the USB dongle, or do you need the extender and the USB dongle connected to use the extender?

2nd edit:
Ok, I’ve just tried mine.
USB dongle installed in Vero 4K, and IR extender installed in outermost socket (farthest from HDMI).

The Vero remote with IR extender is working perfectly with a range of at least 9 meters. That’s as far away as I can be inside the house with line-of-sight to the extender.

Best regards,