Vero 4K and Denon X4400H -> no 4K video

I switched from an old Onkyo receiver, which could not handle 4K HDMI to a new Denon X4400H. Before I had connected HDMI directly to my Sony projector, now I route the signal through the Denon to get HD-Audio. Audio works on all tested formats when video is 1080p, but as soon as I try to play some 4K files nothing happens. The receiver doesn’t show the input signal, the projector tells me no input signal.
I run the latest Vero update (with the banding fix) and have set 444,12bit, as 444,10bit had some problems with round0/round1 before.
Any idea? I’d really like to play my 4K videos.
Thanks!

1 Like

Can you test a 4k clip without HD audio, please? Disabling HD passthrough should do the trick.
Please post debug logs for that and a problem clip.

I believe that Denon suggests to use the HDMI inputs physically close to the HDMI output for 4k (for my X4300H it means inputs 6 and 7). Also there’s a setting in the Denon to enable HDR (HDR format --> enhanced). You might already know these things, I’m just sharing my experience.

I tried with a very simple 4K h265-demo from Astra (2-channel PCM audio) (download link: Dropbox - File Deleted)
as well as reencoded x265 clips (DD5.1 and DTS core) and remuxed UHD BluRay streams (SDR & HDR, Dolby Atmos and DTS core).
Disabling audio passthrough doesn’t help.
I also switched to 444,10bit, no change.

Disabling refresh-rate-change helps, as it downconverts to 1080p, all clips work then. So it doesn’t seem to be an audio problem.

I also changed to the nearest input port on the AVR, though the manual of the x4400 doesn’t say anything about that. Also no change.

On playback the AVR display says Stereo (like when in the Kodi menu), nothing changes here, the projector says “no input”.
All files work when connecting the HDMI directly to the projector, but then there is no HD-audio.
I use the short HDMI cable that came with the Vero 4K to connect Vero to AVR. I don’t have another HDMI cable to change right now.

Debug log: https://paste.osmc.tv/yaxihefapa

I’m using the same receiver and it passes through 4K/HDR signals for me without too much difficulty.

I’d make sure that you have the relevant settings enabled for the HDMI input you’re using in the Denon setup menu? This sounds like a receiver issue rather than a Vero issue, but I’ll let someone with a better read of the logs confirm that.

Also, is it possible you need to enable “deep color mode” or some similar setting on your projector? I know that makes a difference on my E6 for some files.

Hey clawforce,
which settings do you mean? I can enable standard (8 bit only) or extended mode (10/12 bit) for 4K, but that’s all I found. The projector can play 10/12 bit HDR without any problems when directly connected to the Vero.

I don’t know if it matters but in HDMI settings I have “video conversion” --> on and “i/p scaler” -->off

https://denon-uk.custhelp.com/app/answers/detail/a_id/4377/~/hdr-passthrough-not-working

Thanks, I have both set to off, as the manual recommends.

Even switching the Kodi GUI to 2160p doesn’t work, so it’s not a video clip problem.
I now tried every possible configuration setting on the X4400, it’s not working.
Please help!

As a last test I now removed the forced bitrate (“444,10bit”) from rc.local and rebooted, now I can play 4K! So it’s a problem only when increasing the bitrate to 10 or 12 bit.

With the 8 bit setting there is banding on HDR content :frowning:

Do you have any other devices other than the Vero4k capable of 4k? Just to test if the problem is with the Vero or with the Denon.

One other thing I remember read about the Denons is that there can be problems when you use more than one hdmi out, disabling 4k and hdr.

Which pixel depth are you running on your Vero, do you force the signal to 10 or 12 bit?

Sadly not. My laptop only has displayport and I’d need an active converter to get 4K.

I only use “Monitor1”-HDMI out and also tried disabling “Monitor2” on the Denon.

Yeah I can confirm that forcing the 10 bit bandwidth kills the display. Bizarre.

I’ll be honest, I had no idea you could even send an 8 bit HDR signal, my assumption was that it was converting the pixel depth to 10 bit when the HDR flag triggered. Apparently not!

My PS4 has none of these difficulties, so I’m guessing this is coming from the Vero.

well I never had a Denon so I can only guess… on my Yamaha I can choose two different 4k/HDR modes in the (hidden) service mode… if I hadn‘t change it from Type 1 to Type 2, I would not have HDR on my PS4 Pro. No Explanation what Type 1 or 2 means… maybe the Denon has something similiar.

I really doubt it is the Veros fault. Usually the fault is between the communication between two devices.

I can’t help, I can just tell you that I experienced the same thing with my 3400 (lower tier model than yours). Black screen on 4k after I sent the echo command. When that happened I didn’t dig into it, I just reverted to 8 bits. Then just yesterday I tried again and everything worked. Tried several movies and got 10 bits without issues. I’m not sure what changed. I just thought that maybe the first time I didn’t enter the instruction correctly. Is the Denon firmware updated to the latest?

Yes, the Denon’s firmware in the latest.
I just bought a new highspeed HDMI cable, but it’s still the same.
Searching the web for instructions to enter the service menu didn’t give me any result.

Did you update the Vero to the latest developer kernel with the banding fix or are you running the release version?

With the 8bit-setting you get banding from downconverting 10bit to 8bit when playing HDR content.

Just the release version.