Vero 4k and LG OLED Remote Control

I have had my Vero 4k since December and it’s been a dream.

Last week I upgraded my TV from a Samsung to a LG B7 Oled but for some reason the LG remote isn’t working with the Vero like the Samsung use to.

I have enabled all the CEC settings within the TV etc, the Vero has had a new install but no joy.


1 Like

Is it not working at all or just some buttons not working?

None of them now. The remote did work only once when I first got the TV.

Try to unplug both the Vero and the TV from the main power for 10 minutes before reconnect.

Tried turning it all off more than a few times but still the same.

Anyone got the same set up but working?

You might need to enable CEC for that input or something along those lines. The manual might have more details.


Are you by any chance on the devel repository?

We removed those dodgy CEC commits.
Nonetheless, logs would be interesting as he may have reverted back after testing that kernel.

I’ve got the same tv and it does work for me. Have you enabled lg simplink? It’s in the general menu I think.

LG simplink always enabled. I’ll try and get some logs put up.

Another thing weird that happens, when I go to watch a film with the Vero, the TV reverts back to SkyQ. I then have to go back to the Vero input on the LG, which has the film still playing.

I have had the exact same thing. Start a movie and it changes input back to skyq. I have to unplug the TV to get this to stop.
Also the LG remote. Press the input button, go to all inputs, on the right click “setup universal control” then click “show all devices” then click “other box” then click “done” works for me.

It sounds like Sky Q box is signalling active source constantly. That’s not something we could fix I don’t think.

I am on Virgin but maybe someone on the team has Sky and can help debug.

That will work. It’s called CEC.

If that remote is ‘magic’ and has a mouse and voice control; those functions will not be usable to control Vero.


Works on my b7 just fine. I don’t touch the vero control during normal usage.

Mh. I can’t get my Magic Remote from my C8 working with CEC … Tried almost everything, LG Simplink is definitly enabled, tried >20 devices in it’s Universal Remote Control Config… Unplugged everything, but still not working. Even those flirc commands aren’t working (that worked with my RPI2 without problems) … Now I’m using an USB-Flirc Adapter, configured it via PC, this is working. But it’s slower than the OSMC Remote Control … Don’t know why CEC isn’t working for me …

One odd thing about it is that you have to wait for all lg menus including the cursor to disappear before it passes vero recognises the commands.

1 Like

lol … haven’t tried this… gonna try it later, will report back! thanks for this hint!

Did you tried to power down the TV and the Vero at the mains for 3 minutes than power on TV followed by Vero

So, I just tried it again. Not only 3min unplugged (and powered first TV on, than Vero), but also waited until the LG menus etc. were gone. Still doesn’t work, unfortunately. Still have to use the Flirc-USB Adapter… Strange

Just got a LG B9 and my remote is also not working at all. Im sure SIMPLINK(CEC) is enabled but no key is working. Does someone knows what might be missing? I already tried to set the vero4k as “other box” with no luck…