Vero 4k and LG OLED Remote Control

LG simplink always enabled. I’ll try and get some logs put up.

Another thing weird that happens, when I go to watch a film with the Vero, the TV reverts back to SkyQ. I then have to go back to the Vero input on the LG, which has the film still playing.

I have had the exact same thing. Start a movie and it changes input back to skyq. I have to unplug the TV to get this to stop.
Also the LG remote. Press the input button, go to all inputs, on the right click “setup universal control” then click “show all devices” then click “other box” then click “done” works for me.

It sounds like Sky Q box is signalling active source constantly. That’s not something we could fix I don’t think.

I am on Virgin but maybe someone on the team has Sky and can help debug.

That will work. It’s called CEC.

If that remote is ‘magic’ and has a mouse and voice control; those functions will not be usable to control Vero.

Sam

Works on my b7 just fine. I don’t touch the vero control during normal usage.

Mh. I can’t get my Magic Remote from my C8 working with CEC … Tried almost everything, LG Simplink is definitly enabled, tried >20 devices in it’s Universal Remote Control Config… Unplugged everything, but still not working. Even those flirc commands aren’t working (that worked with my RPI2 without problems) … Now I’m using an USB-Flirc Adapter, configured it via PC, this is working. But it’s slower than the OSMC Remote Control … Don’t know why CEC isn’t working for me …

One odd thing about it is that you have to wait for all lg menus including the cursor to disappear before it passes vero recognises the commands.

1 Like

lol … haven’t tried this… gonna try it later, will report back! thanks for this hint!

Did you tried to power down the TV and the Vero at the mains for 3 minutes than power on TV followed by Vero

So, I just tried it again. Not only 3min unplugged (and powered first TV on, than Vero), but also waited until the LG menus etc. were gone. Still doesn’t work, unfortunately. Still have to use the Flirc-USB Adapter… Strange

Just got a LG B9 and my remote is also not working at all. Im sure SIMPLINK(CEC) is enabled but no key is working. Does someone knows what might be missing? I already tried to set the vero4k as “other box” with no luck…

Might be due to the recent firmware update according to: CEC doesn't work with LG C9

Hmm I see. That’s a shame. The vero remote is ok but I miss some keys as the tv guide and the numbers pad to quickly change the iptv channels. I guess i have to wait a bit to see if LG fixes it…

However, the remote does work the amazon fire stick…

Moreover, it seems the TV is detected (I guess). Here is some log from libcec

Can you upload the full output of cec-client | paste-log?

The cec-client command was not exiting so the pipe to the paste-log tool was blocking. I saved the cec log to a file and then (for some a minute or so) and the fed that to paste-log. Hope this is enough:

https://paste.osmc.tv/exenibuvej

So, I got CEC working. My LG tv was doing some automatic configuration and it was seeing my vero as a bluray player as you can configure in the device configurator menu. When using the device configurator I think the CEC won’t be used. I could somehow (the menu on the TV is a bit confusing…) revert this configuration done by the TV and now the remote works. The problem now is that LG exposes just a small subset of keys of the remote via CEC:(. It’s a pitty that the numeric pad is not being exposed…

Try changing the role of the Vero - it may expose more keys

Sam

What type of device did you set the Vero as? I’m trying to get CEC working on my C9 without any luck so far.

I believe his issue was trying to program the magic remote in the first place which disabled the CEC for that device. Completely resetting the TV settings I believe turned CEC back on.

I believe his issue was trying to program the magic remote in the first place which disabled the CEC for that device. Completely resetting the TV settings I believe turned CEC back on.

Exactly.

Moreover, what was happening for me was that LG was automatically setting/seeing Vero as a blue-ray player. So, things start to work for me when I go to the device configurator, go to the blue-ray devices and reset my hdmi port… So, the following works for me:

  • remove the hdmi cable from the TV and remove power for both Vero and LG;
  • Wait a bit and then plug everything back. Not sure if it matters, but I turned Vero in last;
  • Then, the TV automatically sets Vero as blue-ray;
  • Go to the device configurator and reset the hdmi port.

I read somewhere that it is possible to also have the numbers to work, using a flirc. I guess with Vero we would not need one since there is a built in IR receiver. I’m also not sure if we need a conf file for the remote itself. Maybe I will give this a try in the future…

1 Like