Vero 4k and Pi3 Rebooting after scan to library

I have an NFS setting running that has worked for years.

This morning I woke up to a boot loop on both devices.
I found out that it was caused by the auto library update at start and after some looking into it it turned out to be my PVR TV show drive.

What I tried and what works.
I tried to watch something on the disk that can’t scan to library and everything works on both clients and server.
Scanning another disk not containing PVR TV fine.
Going through the file manager and checking all the directory structures and files works, everything plays.
Cleaning the library.
Checking the server disks for errors and if they all play, everything works, disk integrity looks good says windows.

What I tried and what doesn’t work.
If I try to scan for new media on any directory (after trying all files first) it fails.
If I try to scan the disk to library it fails.
If I try to scan any single show it fails (even if it plays).
I tried switching contents of the directory from TVDB to TMDB and even to Local but none of it helps it will keep rebooting.

The log shows nothing with debug and event with verbose on:

2020-01-11 14:35:36.767 T:3882083040   DEBUG: StartScript - calling plugin Skin Helper Service('plugin://script.skin.helper.service/','10','?action=alphabet&reload=','resume:false')
2020-01-11 14:35:36.767 T:3465011936   DEBUG: Thread LanguageInvoker start, auto delete: false
2020-01-11 14:35:36.767 T:3465011936    INFO: initializing python engine.
2020-01-11 14:35:36.768 T:3465011936   DEBUG: CPythonInvoker(18, /home/osmc/.kodi/addons/script.skin.helper.service/plugin.py): start processing
2020-01-11 14:35:36.769 T:3520066272    INFO: CPythonInvoker(16, /home/osmc/.kodi/addons/script.skin.helper.service/plugin.py): script successfully run
2020-01-11 14:35:36.770 T:3520066272   DEBUG: onExecutionDone(16, /home/osmc/.kodi/addons/script.skin.helper.service/plugin.py)
2020-01-11 14:35:36.792 T:3520066272    INFO: Python interpreter stopped
2020-01-11 14:35:36.792 T:3520066272   DEBUG: Thread LanguageInvoker 3520066272 terminating
2020-01-11 14:35:37.049 T:4045402848   DEBUG: LIRC: - NEW 67 0 KEY_UP linux-input-layer (KEY_UP)
2020-01-11 14:35:37.061 T:4065468416   DEBUG: HandleKey: 166 (0xa6, obc89) pressed, action is Up
2020-01-11 14:35:37.377 T:4045402848   DEBUG: LIRC: - NEW 160 0 KEY_OK linux-input-layer (KEY_OK)
2020-01-11 14:35:37.384 T:4065468416   DEBUG: HandleKey: 11 (0x0b, obc244) pressed, action is Select
2020-01-11 14:35:37.715 T:4065468416   DEBUG: ------ Window Deinit (DialogContextMenu.xml) ------
2020-01-11 14:35:37.719 T:4065468416   DEBUG: CAddonSettings[metadata.tvdb.com]: loading setting definitions
2020-01-11 14:35:37.719 T:4065468416   DEBUG: CAddonSettings[metadata.tvdb.com]: trying to load setting definitions from old format...
2020-01-11 14:35:37.719 T:4065468416   DEBUG: CAddonSettings[metadata.tvdb.com]: loading setting values
2020-01-11 14:35:37.729 T:4065468416   DEBUG: CAddonSettings[metadata.tvdb.com]: loading setting definitions
2020-01-11 14:35:37.729 T:4065468416   DEBUG: CAddonSettings[metadata.tvdb.com]: trying to load setting definitions from old format...
2020-01-11 14:35:37.729 T:4065468416   DEBUG: CAddonSettings[metadata.tvdb.com]: loading setting values
2020-01-11 14:35:37.743 T:4065468416   DEBUG: CNFSFile::Open - opened Shows/<My Tv Show>/tvshow.nfo
2020-01-11 14:35:37.832 T:4065468416   DEBUG: CNFSFile::Close closing file Shows/<My Tv Show>/tvshow.nfo

After these lines I get a :frowning: and it will reboot.
The setup was working great before I went to bed but without me doing anything both devices stop working.

I looks and sounds like you have a bad NFO file. What is this <My Tv Shows> folder? Is that a path to actual shows in their own subfolders? If so then why do you have a tvshow.nfo file in that particular location as that file should only ever be in the root directory of an actual TV series.

Those are auto generated by my video manager I have used for years.

The structures are Show Name (year) > Season (number) > Episode name and the settings are set to generate compatible files for Kodi.
The NFO files have always been in the same folders so maybe it is a problem with the manager and the new tvdb api creating a bad file without content?
TVDB API V3 has a lot of issues so maybe that causes it?

So did you edit the file path in that log snippet and not bother to say so? Please enable debug logs, reboot twice, run the scan (letting it crash) and then upload logs from the MyOSMC add-on with all logs enabled. Paste the url it generates in this thread.

I only removed the series name, it was a single path source with nothing but episodes under it and the accompanied tvshow file.
The rest of the code snippet was copy and paste and none of the structure of the file was changed.

The code snippet was made with all log options enabled, rebooted and crashed, copied from the kodi log.

without a log all I can suggest is going to the video>files section and context menu>scan for new content on different paths until you figure out the problem location. Once you do that I would recommend removing the NFO file/files and rescan and see if the problem goes away. If you find the problem file and can’t figure out exactly what is problematic feel free to copy its contents to paste.osmc.tv and post a url here and I can take a look.

In the future please state if a modification was made.

It happens on all show directories that previously worked and every season or show I try to add manually.

The only thing I can think of that changed is that the program wrote a bad nfo for all shows if that could be the issue.
I will try and let it write new NFO’s for everything.

I’m sorry I didn’t mention it, I followed the original How to make a good report for OSMC which has a small section about how to sanitize things if you wish that did not state you have to mention it.
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Edit: it does mention it, my apologies!

For TV shows there is no file that spans across all shows. As the problem persisted when you changed your scraper it strongly suggests that there is something wrong going on with your NFO files which Kodi is quite picky about them being 100% correct. Did the program you use to generate them update all your files with new info previous to this behavior? Perhaps you could just remove all the NFO files from a single folder and try to rescan just that folder to see if it still crashes.

I am updating all files right now but it looks like the problem stays, I will check again and update the log with a show has already been updated.

Still the same problem as before with fresh generated logs @darwindesign .

2020-01-11 23:25:15.973 T:4072099840   DEBUG: CNFSFile::Open - opened Shows/{Sanitized}/tvshow.nfo
2020-01-11 23:25:16.062 T:4072099840   DEBUG: CNFSFile::Close closing file Shows/{Sanitized}/tvshow.nfo

completely remove the nfo files from the path and try to scan. If it does that without crashing pastebin the contents of the nfo file without modification so I can see where the issue is.

Worked on the Pi where I didn’t delete it but as soon as I get to episodes on Vero and it tries to hit up the NFO’s again it crashes on them.

So I think the problem is the NFO’s

Same issue as someone had a few days ago

  <ratings>
    <rating default="" max="10" name="thetvdb">
      <value>7</value>
      <votes>27</votes>
    </rating>
  </ratings>

The missing argument in default="" makes Kodi crash

That explains it! I will remove all NFO’s and report to the creator of my manager.