Vero 4k and xbox one remote

Hi there,

i am trying to use the xbox one remote…
works as the original remote but i want to use the volume up/down buttons.

I am searching for manuals and try some things but it don’ work :unamused:
i choose in my osmc this remote… but…volume buttons don’t work
etc etc…

i copied the Lircmap.xml in the userdata folder but no change :unamused:

can someone help me?

Can you show a photo of the remote you are using?
I think the remote we have in My OSMC is for the 360 one.

CC @DBMandrake

There is an Xbox one media remote profile in OSMC but it is a user submitted one so has not been tested by us as none of the OSMC devs have an Xbox one remote to test with.

I used the control on the raspi and it works…
And i compare the profiles… the same

Okay – there are remote improvements coming in the next update.

I assume you used a TSOP on the Pi.

Befor the last update the xbox one remote works except the buttons for volume.

After the update

the remote don’t work :unamused:

Not to worry – I’m looking in to this.

Can you try checking for updates and installing them and letting me know
if this resolves your remote issue?

It might take 25-30 minutes for the update to reach you.



Hi sam,
sorry for the late reply.
I use the IR-Extension-Kit from the set.

But after the update - sorry - no change

This issue should now be resolved.


Hi Sam,
And how?
No Update available.

Try checking for updates again. It can take up to 45 minutes for it to reach your mirror.

Ah ok
Thanks :slight_smile:

It’s probably reached you by now. Try checking for updates again and reporting back.


Hi sam,

The Volume Control +/- is working… (very well)
The ok button ( i pressed him about 30 times - 1 time it worked)
The same result with left or right arrow.
Up Down Arrow dont work
The Remote reacts extreme slow (i have changed to new batteries).
The Up down works after a longer press then very fast…

Hi Michael,

Did you record this profile with irrecord yourself?
Did you make changes to the remote configuration after the update to try and get it to work? If you restore things to how they were, you should find they work as expected.

As @DBMandrake says, none of us have an Xbox One remote, so we are using a user submitted profile that may not entirely be accurate

I tested with an Xbox 360 Media remote and it seems to be working well now. RC5 / old OSMC remote is now working as expected.


I have certainly made no changes.
How can i restore the profiles?

Hi Sam,
I do not restory anything (don’t know how)
But the remote works in a weird way.

The Remote works in this way:

I must press (very fast) every button twice than it works?
What’s wrong?


We never submitted the Xbox One profile ourselves, as we don’t have this remote. As such, we can’t really test it.

I’d suggest trying to record your own remote profile using irrecord for the remote. Then it may work better.


Sam it works - i must only “double.klick” :slight_smile:
I would be glad if you can help me :slight_smile: