Vero 4k and xbox one remote

Okay – I will see what can be done


Hopefully the issue is fixed now.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


Sorry Sam :smirk:
it does not work better, rather bad…

In the last version i press every button very fast twice and it works…

Now, when i press the button quickly twice it jumps not only to the next entry - sometimes two entries further.
When i wait longer and press the button longer he jumps to next entry and sometimes not.

the last version was better…

Hi @Michael_Gombkoto

I’m not sure what the issue is then. This commit effectively reverts
the changes made in recent updates.

This means that the problem is likely coming from elsewhere. Have you checked
that RC6 is disabled in My OSMC (or you’ll get duplicate presses), and whether
an older version still works as expected?

As said earlier, no one on our team has an Xbox One remote, so we can’t verify
whether the profile works well. I’d recommend re-learning the remote on the Vero
4K using irrecord


ups :flushed: rc6 wasn’t disabled.
Sam - how can i restore to the last version?

Any improvements with RC6 disabled? Having it on can certainly cause duplicate presses.

It works better - but i must test the last version.
The handling with the doubleclick was in the last version much better.
And if this was the failure (deactivating RC6) then it should work better.
How can i restore?

You can download an old version from Download - OSMC. I think
2017.04-1 is what you want.

Normally I’d suggest kernel downgrade instructions to avoid a reinstall
but this isn’t trivial with the latest update and I don’t want to prevent
future updates from working as expected for you

I’m pretty sure that if you configure your own IR profile with irrecord you’ll find
the results quite acceptable



i will try irrecord.
but where can i find a howto or manual for irrecord on vero ?:confused:

section 2

all that i get are errormessages…
driver not found
failed to detect etc…:weary:


Please advise on the full command entered and the full output of the command would be helpful to.

Thanks Tom

osmc@osmc:/etc/lirc$ irrecord --driver=irman --device=/dev/ttyS0 MyRemote
Driver `irman’ not supported.
Supported drivers:

Not sure where you read that but that isn’t correct. You should try irrecord instead, after stopping Kodi, eventlircd and lircd_helper service.


Apologies I think that was from the link I provided from the kodi wiki, just as an overview.

anyway sorry

regards Tom.

I’m confused
Don’t know what driver it is
is there a procedure available?

Not an expert here but what I read from Sam’s post

I would translate as

sudo systemctl stop Kodi
sudo systemctl stop eventlircd
sudo systemctl stop lircd_helper

Thats why i am asking:… :smirk:

there is no service named Kodi or kodi
there is no service named lircd_helper

and which parameter must i use with irrecord…

Sorry my mistake
sudo systemctl stop Kodi should be sudo systemctl stop mediacenter
Not sure about lircd_helper check name with systemctl | grep lirc

I assume without parameter, only if that doesn’t give you any think can try irrecord -f -d /dev/lirc0

It work’s very fine :smile: (very easy… )

I repeat the steps to the success (maybe someone had the same problem)

su …

cd /etc/lirc
systemctl stop mediacenter
systemctl stop eventlircd
systemctl stop system-lircd_helper.slice

irrecord -f -d /dev/lirc0 configname.conf

Follow the instructions :blush:

rm lircd.conf

ln -s /etc/lirc/configname.conf lircd.conf

shutdown -r now :grin: