Vero 4K+ Black and Blank Display

I have been in contact with Sam about a 3 month old 4K+ and he thinks that there must be a problem involving the software or my monitor etc.

It has been working fine using HDMI on a TV and also on my monitor that I used to set it up with, then a few days ago started saying no signal on the TV, so I plugged it into the monitor using another lead and the HDMI is detected by the monitor, I can get to the web interface and also use the network remote control, button presses made sounds via HDMI on the monitor, but the screen is blank.

I tried powering just the Vero with USB and it did the same.

So I reinstalled new OSMC via both SD card and USB, nothing came up on the screen during install, it was blank.

After the install I can still see the vero on the network and it still does the same with the monitor.

Sam says the HDMI is working as we can see the monitor from the logs. The monitor also shows that it is connected @ 1920x1200 60Hz 1080p

Does anyone have an idea what I should try to fix it?


It would be good to keep things in one place instead of debugging across the forum and a support ticket.

Please show a screenshot of the contents of the SD card. There should be an install.logfile present if reinstallation was successful.

Did you try moving the Kodi userdata directory via SSH as I suggested in my last email?

Sun Jan 1 00:00:11 2017 Starting OSMC installer
Sun Jan 1 00:00:14 2017 Detecting device we are running on
Sun Jan 1 00:00:14 2017 Mounting boot filesystem
Sun Jan 1 00:00:14 2017 Trying to mount to MNT_BOOT (/mnt/boot)
Sun Jan 1 00:00:14 2017 Using device->boot: /dev/mmcblk1p1 and FS: fat32
Sun Jan 1 00:00:14 2017 Filesystem defined by /mnt/boot/filesystem.tar.xz
Sun Jan 1 00:00:14 2017 No preseed file was found
Sun Jan 1 00:00:14 2017 Flash looks OK
Sun Jan 1 00:01:17 2017 Creating root partition
Sun Jan 1 00:01:18 2017 Calling fmtpart for partition /dev/vero-nand/root and fstype ext4
Sun Jan 1 00:01:21 2017 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
930240 inodes, 3716096 blocks
185804 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=3808428032
114 block groups
32768 blocks per group, 32768 fragments per group
8160 inodes per group
Superblock backups stored on blocks:
    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208

Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

Sun Jan 1 00:01:21 2017 From a root partition of /dev/vero-nand/root, I have deduced a base device of /dev/vero-nand/roo
Sun Jan 1 00:01:21 2017 Mounting root
Sun Jan 1 00:01:21 2017 Trying to mount to MNT_ROOT (/mnt/root)
Sun Jan 1 00:01:21 2017 Using device->root: /dev/vero-nand/root
Sun Jan 1 00:01:21 2017 Extracting files to root filesystem
Sun Jan 1 00:01:21 2017 Starting extract process ...
Sun Jan 1 00:01:21 2017 Extracting from /mnt/boot/filesystem.tar.xz
Sun Jan 1 00:02:16 2017 Extraction of root filesystem completed
Sun Jan 1 00:02:16 2017 Configuring bootloader
Sun Jan 1 00:02:16 2017 Configuring bootloader: moving /boot to appropriate boot partition
Sun Jan 1 00:02:17 2017 Vero 4K family: bootloader to be flashed is uboot-vero4kplus.bin
Sun Jan 1 00:02:18 2017 Configuring boot cmdline
Sun Jan 1 00:02:18 2017 Configuring /etc/fstab
Sun Jan 1 00:02:18 2017 Successful installation. Dumping log and rebooting system

That should indicate a successful installation then.

I would suggest testing with another HDMI cable on another display.
Do you see the ‘Please Stand By’ message when the device boots, or the OSMC splash screen?

Sorry Sam I missed that from the bottom of the email, I have just moved the .kodi folder and it’s still the same.

If you have reinstalled OSMC, you won’t need to do that.

I have just plugged it into a completely different TV and it’s showing in 720p :slight_smile:

Just need to get it working on the correct TV

It looks like it’s defaulted to 720p because your other TV doesn’t have advertise a preferred mode in its EDID. Selecting 1080p in Kodi manually would work.

I wonder if the Dell monitor doesn’t actually support 720p? Do you have the make and model?
Have you tested another device on the Dell such as a PC?

It looks like my monitors HDMI settings were set to zero for brightness & contrast, but I think something odd was going on as the vero was showing in black and white after changing them, I have reset some monitor settings and it looks happy.

I will have to look at the other TV to see why it’s showing no signal, fingers crossed it’s user error.

I wouldn’t have guessed that one…

1 Like

No, I remember it was making some odd hissing sound from the speaker when I first connected the vero to it, maybe the monitor is on it’s way out and corrupted it’s config in the process.

@sam_nazarko it’s now working on the correct TV, not sure if someone had moved the HDMI port on the TV over as I didn’t see it when it stopped working and probably wont find out. Thank you for your help.

I tried pairing the remote again like you said, blue flashing led when it paired and turning the power off for 2 mins. But the back button still doesn’t work, I tried doing it twice.

1 Like

Try changing the battery.
Otherwise we will need some logs to see if the button press is registering.

Do you see a blue flash when the button is pressed?

Yes there is a blue flash when the back button is pressed, I will put a new battery in the remote and let you know, it might be a few days before I can do that.

Can you tell me what I need to do for the logs please?

reboot twice then go to settings>system>logging>enable debug logging>[enable] and then hit the back button a couple times. You can then turn debug logging off and then open the My OSMC add-on and upload logs. It should return a url that you would then need to post in this thread so se can take a look at what is happening.

Changed the battery and that didn’t work so here is the log:

I pressed Volume Up once, Volume Down once, then Back 5 times.

The reason it isn’t working is because the product id of the dongle doesn’t match up with an OSMC remote dongle so the system isn’t loading the mapping as it should. Are you sure you are using the dongle that came with the Vero and didn’t mix it up with a similar one?

No that’s the only one we have and it came from the osmc store with the vero, it used to work fine?

If it had mixed it up wouldn’t I have needed to pair it to get it working?, as I have only paired it after the back button stopped working.

If you are positive that is the dongle that came with your unit you would need to email with your order number and a link to this thread and have them send you out a new dongle.

Will do, thanks for everyone’s help.