Vero 4k+ Blackouts

Hey i have the same problem like the guys had here

these random short blackouts where screen goes dark and then screens comes back and audio aswell after few seconds. It happens on all random files web dl, mvk ect.

My tv is plugged into a power strip and my vero 4k+ aswell in the same power strip.

I play the movies from my external 2TB WD Elements Portable which is connected directly to the vero 4k+ with usb.

The vero 4k is also directly connected to my Tv with a fast speed hdmi cable.

My tv is this one here

As far i remember i never had these blackouts before i did updates. But i don’t know how to solve this problem. Do i need to change refresh rate on vero 4k+ ?

Thanks for help.

The first thing to try would be a different HDMI cable. If that does not make the issue go away we would need some logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I had issues with dropouts, where there was up to a second black and then it came back, even though it was a good quality cable, when I changed to another cable (the one delivered with the xbox) the issues disappeared.


Post a log and power the device directly from the wall if you are able

I will try to get one. But as mentioned it is really random when it happens. Sometimes i can watch 2 videos full and nothing happens and then on third random video it happens. But i try my best to get a log.

This may not be related, but is the drive self powered? If it’s getting power from the Vero it’s possible that the drive is drawing to much power. Try a powered USB hub and see if that helps.

No the drive is no powered. I never used a usb hub so i would to buy one. Otherwise i just accept how it is. I mean the blackouts are random.

i get the 1sec blackouts on both my vero4k+'s once per movie, i keep meaning to turn on debug logging but its hard to reproduce it as it seems pretty random where in the film it occurs.

its not a kodi thing as never seen it on my atom+ubuntu or pi+libreelec boxes on the same tv’s.

Can you both just grab a log so we can see your settings. No need to reproduce the glitch.

1 Like

Yes here is my log

Can you set your resolution to 1080p instead of the 1080i it is currently using and if the problem persists try changing the hdmi cable.


1 Like

I will. I also will watch some movies so i will see if that trick worked.

my logs are at and and the tv and vero4k+ are reporting 2160p resolution - both tv’s are basically the same LG (one is 55" and one is 43")

Can you change your settings to the following and retest.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Did it, got no blackouts currently. Will keep an eye if blackouts happen again. Thanks.

Which one, just the settings change, or did you try another cable?

Just changed setting. Although first movie i tried after switching setting… vero 4k+ got sad smiley
and restarted…but after that no problem yet.

Edit blackouts happened again on a 2160p movie.

yeah does seem a bit like the vero 4k+ can’t handle 4k…

Are you saying the Vero 4K / 4K + can’t play 4K files…?

From a quick scan of your logs I can see Adjust Refresh Rate is disabled, which is going to be problematic. You should also set the GUI to 1080p.

Kodi cannot take advantage of a 4K UI, so you are just wasting CPU and GPU cycles by selecting a 4K resolution and you will likely see a poorer quality UI because your TV will likely have a better upscaler than Kodi.

I’m going to add a big warning when selecting 4K resolutions as this seems to be tripping a lot of users up.


1 Like

Can you upload a log so we can see the settings you have? I’m hoping that you have changed them as suggested; but wanted to double check.